Bug 101480 - [SKL]GPU HANG: ecode 9:0:0x85dffffb, in blender [1244]
Summary: [SKL]GPU HANG: ecode 9:0:0x85dffffb, in blender [1244]
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 18.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-17 10:47 UTC by Rik
Modified: 2019-06-21 15:43 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (74.19 KB, application/x-bzip)
2017-06-17 10:47 UTC, Rik
Details
glxinfo (4.21 KB, application/x-bzip)
2017-06-17 10:48 UTC, Rik
Details
/sys/class/drm/card0/error (16.20 KB, application/x-bzip)
2018-06-04 15:54 UTC, Rik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rik 2017-06-17 10:47:16 UTC
Created attachment 132018 [details]
/sys/class/drm/card0/error

#### dmesg output ####

[drm] GPU HANG: ecode 9:0:0x85dffffb, in blender [1244], reason: Hang on render ring, action: reset
[drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[drm] GPU crash dump saved to /sys/class/drm/card0/error
drm/i915: Resetting chip after gpu hang
[drm] RC6 on
[drm] GuC firmware load skipped
drm/i915: Resetting chip after gpu hang
[drm] RC6 on
[drm] GuC firmware load skipped
Comment 1 Rik 2017-06-17 10:48:06 UTC
Created attachment 132019 [details]
glxinfo
Comment 2 Elizabeth 2018-03-06 22:15:35 UTC
Hello Rik, is this still reproducible? What triggers this hang? Thank you.
Comment 3 vadym 2018-06-04 08:51:35 UTC
Unable to reproduce on my SkyLake. Use case is not described at all so I run blender with mesa 17.1.2 and did some basic operations. No issues found.
Comment 4 Rik 2018-06-04 15:30:33 UTC
Hello, I don't know if it's still reproducible, but the issue occurs during video editing.

So, load a movie in blender, play it, make changes, apply strip effects, do render animation and so on.

P.s.
I have no issues with last kernels(4.16/4.17) and Mesa 18.0.4.
Comment 5 Rik 2018-06-04 15:54:04 UTC
Created attachment 140016 [details]
/sys/class/drm/card0/error

OK, new hang during video editing. Issue is still there.

Dump attached.

Thanks.

Kernel 4.17.0

Mesa 18.0.4.
Comment 6 vadym 2018-06-05 08:49:38 UTC
Hi Rik,

Thanks for a quick response. Can you please record an apitrace for this hang ?
More info on apitrace here: https://apitrace.github.io/

You can simply run following command in terminal:

apitrace trace <program_name>

Then you can share result file with us.

Thanks in advance.
Comment 7 Rik 2018-06-05 09:37:37 UTC
(In reply to vadym from comment #6)
> Hi Rik,
> 
> Thanks for a quick response. Can you please record an apitrace for this hang
> ?
> More info on apitrace here: https://apitrace.github.io/
> 
> You can simply run following command in terminal:
> 
> apitrace trace <program_name>
> 
> Then you can share result file with us.
> 
> Thanks in advance.

Hi,
why you need an apitrace? 
This hang is not easy to reproduce and I have no time.
Thanks.
Comment 8 Danylo 2018-06-13 15:24:03 UTC
Was not able to reproduce on Skylake on latest mesa and on 17.2.8.

I tried to edited 4K video with overlaying rendering scene, several effects and other video. No hang occurred no matter what I've tried.

It seems if the hang requires some very specific actions or setup to be reproduced.
Comment 9 Denis 2019-06-21 13:27:11 UTC
Hi Rik, could you please clarify whether this issue still actual for you on latest released mesa versions?
I saw that for 18.0.4 it wasn't actual so want to confirm that current ticket may be closed
Comment 10 Rik 2019-06-21 13:38:57 UTC
(In reply to Denis from comment #9)
Hi Denis,
yes, you can close this ticket.

Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.