Bug 101576 - [KBL] GPU hang 9:0:0x85df7cff in GRID Autosport
Summary: [KBL] GPU hang 9:0:0x85df7cff in GRID Autosport
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-24 10:44 UTC by Daniel J Blueman
Modified: 2019-09-25 19:02 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features: GPU hang


Attachments
kernel log with drm.debug=0xe (208.29 KB, text/plain)
2017-06-24 10:57 UTC, Daniel J Blueman
Details
DRI error state (147.92 KB, text/plain)
2017-06-24 10:58 UTC, Daniel J Blueman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel J Blueman 2017-06-24 10:44:39 UTC
When running GRID Autosport on Steam in default settings on a Dell XPS 13 9360, we see it hang after ~60s of driving. I find this is 100% reproducible.

It reproduces on 4.11.7 (Ubuntu mainline) on Ubuntu 16.04.2 with linux-firmware 1.166 (providing firmware for 4.11 kernel).

System environment:
-- chipset: Kabylake
-- system architecture: 64-bit
-- xf86-video-intel: 2:2.99.917+git20160706-1ubuntu1~16.04.1
-- xserver: 1:7.7+13ubuntu3
-- mesa: 12.0.6-0ubuntu0.16.04.1
-- libdrm: 2.4.70-1~ubuntu16.04.1
-- kernel: 4.11.7-041107-generic
-- Linux distribution: Elementary OS based on Ubuntu 16.04.2
-- Machine or mobo model: Dell XPS 13 9360 with current BIOS
-- Display connector:  Internal eDP1
Comment 1 Daniel J Blueman 2017-06-24 10:57:54 UTC
Created attachment 132217 [details]
kernel log with drm.debug=0xe
Comment 2 Daniel J Blueman 2017-06-24 10:58:20 UTC
Created attachment 132218 [details]
DRI error state
Comment 3 Elizabeth 2017-06-26 18:22:22 UTC
Adding tag into "Whiteboard" field - ReadyForDev
*Status is correct
*Platform is included
*Feature is included
*Priority and Severity correctly set
*Logs included
Comment 4 Elizabeth 2017-06-29 22:22:19 UTC
(In reply to Elizabeth from comment #3)
> Adding tag into "Whiteboard" field - ReadyForDev
> *Status is correct
> *Platform is included
> *Feature is included
> *Priority and Severity correctly set
> *Logs included

Removing tag ReadyForDev, since it seems to be MESA bug instead. Thank you.
Comment 5 Elizabeth 2018-03-06 21:59:53 UTC
Hello Daniel, mesa 12 is quite old, are you able to reproduce issue with latest mesa releases? Also could you try at least kernel 4.13 to get more debug information in error state? Thank you.
Comment 6 Illia Iorin 2018-03-28 12:07:26 UTC
This game does not start at all on that configurations:

1. Lib: Mesa 12.0.6 

Dis: Ubuntu 16.04.4 

proc: Kabylake GT2

2.  Lib: Mesa 17.2.8

Dis: Ubuntu 16.04.4 

proc: Kabylake GT2

3.  Lib: Mesa 18.1.0-devel

Dis: Ubuntu 16.04.4 

proc: Kabylake GT2

4.  Lib: Mesa 18.0.0-rc4

Dis: Ubuntu 18.04. Beta 

proc: Skylake GT2
Comment 7 Elizabeth 2018-03-28 14:41:56 UTC
Which desktop environment are you using? Do you have any way to reliably reproduce the hang? Can you get an apitrace with the latest software? Do you mind sharing a new dmesg and error state with the latest versions? Thank you.
Comment 8 Illia Iorin 2018-03-29 08:54:55 UTC
On steam page http://store.steampowered.com/app/255220/GRID_Autosport/ we can see that " Intel and AMD GPU's are not supported at time of release."  I think you provide not full information about hardware, or game developers removed the possibility of run this game on Intel and AMD GPU's.
Comment 9 GitLab Migration User 2019-09-25 19:02:57 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1605.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.