Bug 101584 - clover: ethminer -G --benchmark: ring buffer overflow, GPU faults
Summary: clover: ethminer -G --benchmark: ring buffer overflow, GPU faults
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 99553
  Show dependency treegraph
 
Reported: 2017-06-25 09:21 UTC by Christoph Haag
Modified: 2017-06-28 01:36 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg (102.71 KB, text/plain)
2017-06-25 09:21 UTC, Christoph Haag
Details
without X (646.53 KB, image/jpeg)
2017-06-28 01:36 UTC, Christoph Haag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Haag 2017-06-25 09:21:19 UTC
Created attachment 132229 [details]
dmesg

Tested with my RX 480 on mesa git and Linux 4.11 and 4.12-rc.

To reproduce, get https://github.com/ethereum-mining/ethminer
in libethash-cl/ethash_cl_miner_kernel.cl add
#pragma OPENCL EXTENSION cl_clang_storage_class_specifiers : enable
then cmake . and make and in ethminer/ run ./ethminer -G --benchmark

it outputs some progress and at 97% something goes wrong and I get GPU faults and/or GPU hangs.

Interestingly with the closed source OpenCL runtime from amdgpu-pro it fails at 97% too.
Comment 1 Christoph Haag 2017-06-28 01:36:51 UTC
Created attachment 132290 [details]
without X

Thanks to a tip from tom stellard I tried it without X (after exiting sddm). 

I've tried to start the miner with "real work" from a pool as recommended:

GPU_FORCE_64BIT_PTR=0 GPU_MAX_HEAP_SIZE=100 GPU_USE_SYNC_OBJECTS=1 GPU_MAX_ALLOC_PERCENT=100 GPU_SINGLE_ALLOC_PERCENT=100 ./ethminer --farm-recheck 200 -G -S eu1.ethermine.org:4444 etc. etc.

I get gpu faults, but no hangs or other issues and the system is usable normally after exiting the miner.

The -G --benchmark mode still has worse troubles with hangs etc.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.