Bug 101641 - sw_sync.c:35:29: fatal error: linux/sync_file.h: No such file or directory
Summary: sw_sync.c:35:29: fatal error: linux/sync_file.h: No such file or directory
Status: RESOLVED FIXED
Alias: None
Product: piglit
Classification: Unclassified
Component: tests (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Piglit Mailing List
QA Contact: Piglit Mailing List
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2017-06-29 04:36 UTC by Vinson Lee
Modified: 2017-07-06 06:57 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2017-06-29 04:36:16 UTC
piglit: 3b9e5ba14b930fe61761d5ddbd736593ef000228 (master)

tests/egl/spec/egl_khr_fence_sync/sw_sync.c:35:29: fatal error: linux/sync_file.h: No such file or directory
 #include <linux/sync_file.h>
                             ^

Build error introduced with this commit.

commit 2e423dd3f4ca3820fbbc956f3b77ed3d7587dd87
Author: Rafael Antognolli <rafael.antognolli@intel.com>
Date:   Mon Nov 7 15:05:04 2016 -0800

    egl_khr_fence_sync: Add sw_sync lib.
    
    Add a small library that helps manipulating software fences. They are
    useful for testing EGL Android fences, since the latter can be created
    out of them.
    
    Signed-off-by: Rafael Antognolli <rafael.antognolli@intel.com>
    Reviewed-by: Eric Anholt <eric@anholt.net>
Comment 1 Vinson Lee 2017-07-06 06:57:40 UTC
commit 27b2914a8eed15c26698bd87cb1f4ca9106dccd6
Author: Vinson Lee <vlee@freedesktop.org>
Date:   Wed Jun 28 22:14:52 2017 -0700

    cmake: Check for linux/sync_file.h for egl_khr_fence_sync.
    
    Fixes: 2e423dd3f4ca ("egl_khr_fence_sync: Add sw_sync lib.")
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=101641
    Signed-off-by: Vinson Lee <vlee@freedesktop.org>
    Reviewed-by: Brian Paul <brianp@vmware.com>
    Reviewed-by: Rafael Antognolli <rafael.antognolli@intel.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.