Bug 101694 - [BDW] drm freezes temporarily on newer kernels
Summary: [BDW] drm freezes temporarily on newer kernels
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-07-04 15:50 UTC by bugger
Modified: 2017-07-07 22:46 UTC (History)
1 user (show)

See Also:
i915 platform: BDW
i915 features: GPU hang


Attachments
/sys/class/drm/card0/error (35.95 KB, text/plain)
2017-07-04 15:50 UTC, bugger
no flags Details
dmesg with drm.debug=0xe on kernel cmdline (231.74 KB, text/plain)
2017-07-05 15:36 UTC, bugger
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugger 2017-07-04 15:50:11 UTC
Created attachment 132426 [details]
/sys/class/drm/card0/error

On newer kernels, Xorg sometimes freezes temporarily. The bug occured on at least kernels 4.11.8 and 4.12.0, while 4.9.33 did not, after a long while of intense usage. This indicates that this is a kernel issue, but not necessarily.

chipset: Intel i5-5257U
system architecture: 64-bit
xf86-video-intel: not installed
xserver: 1.19.3
mesa: 17.1.14
libdrm: 2.4.81
kernel: 4.12.0
Linux distribution: Void (with musl libc)
Machine or mobo model: Apple MacBookPro12,1 (2015)
Display connector: internal monitor

Reproduction:
Open chromium and load some intensive web pages. After a while it should freeze for a few seconds, and later return to normal after some minor graphic artifacts. This will occur repeatedly indefinitely.

dmesg excerpt:

[  202.561869] DMAR: DRHD: handling fault status reg 3
[  202.561874] DMAR: [DMA Write] Request device [00:02.0] fault addr fd285000 [fault reason 23] Unknown
[  209.700964] [drm] GPU HANG: ecode 8:0:0x85dffffb, in chromium [1064], reason: Hang on rcs, action: reset
[  209.700965] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  209.700966] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  209.700966] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  209.700966] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  209.700967] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  209.701011] drm/i915: Resetting chip after gpu hang
[  219.743979] drm/i915: Resetting chip after gpu hang
[  229.727960] drm/i915: Resetting chip after gpu hang
[  229.728133] DMAR: DRHD: handling fault status reg 2
[  229.728138] DMAR: [DMA Write] Request device [00:02.0] fault addr ffff9000 [fault reason 23] Unknown
[  241.759968] drm/i915: Resetting chip after gpu hang
[  249.760012] drm/i915: Resetting chip after gpu hang
[  249.866657] DMAR: DRHD: handling fault status reg 3
[  249.866664] DMAR: [DMA Write] Request device [00:02.0] fault addr fbb00000 [fault reason 23] Unknown
[  259.744063] drm/i915: Resetting chip after gpu hang
[  269.728105] drm/i915: Resetting chip after gpu hang
[  448.369227] DMAR: DRHD: handling fault status reg 3
...etc...
Comment 1 Elizabeth 2017-07-04 19:51:05 UTC
(In reply to bugger from comment #0)
> Created attachment 132426 [details]
> /sys/class/drm/card0/error
> 
Hello,
Could you please attach full dmesg with drm.debug=0xe parameter on it, from boot till the problem is present? Thank you.
Comment 2 bugger 2017-07-05 15:36:10 UTC
Created attachment 132459 [details]
dmesg with drm.debug=0xe on kernel cmdline
Comment 3 Elizabeth 2017-07-05 17:42:33 UTC
Adding tag into "Whiteboard" field - ReadyForDev
*Status is correct
*Platform is included
*Feature is included
*Priority and Severity correctly set
*Logs included
Comment 4 bugger 2017-07-06 11:15:57 UTC
I was wrong about the issue not occuring in 4.9.33. It happens, but only after waking from sleep, it seems. The first time it happened I did not have the debug kernel arguments and the second time the entire system froze. I will attempt to reproduce and post the debug dmesg.
Comment 5 Chris Wilson 2017-07-06 11:38:22 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.