Bug 101729 - [SKL]GPU HANG: ecode 9:0:0x8fd87fff, in mpv/vo [2462], reason: Hang on render ring, action: reset
Summary: [SKL]GPU HANG: ecode 9:0:0x8fd87fff, in mpv/vo [2462], reason: Hang on render...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-09 10:30 UTC by Rik
Modified: 2019-09-25 19:03 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features: GPU hang


Attachments
/sys/class/drm/card0/error (13.41 KB, application/x-bzip)
2017-07-09 10:30 UTC, Rik
Details
mpv command line (606 bytes, application/x-bzip)
2017-07-09 10:32 UTC, Rik
Details
systool -m i915 -av (962 bytes, application/x-bzip)
2017-07-09 10:33 UTC, Rik
Details
dmesg with drm.debug=0xe (26.09 KB, application/x-bzip)
2017-07-12 05:24 UTC, Rik
Details
new gpu crash (13.33 KB, application/x-bzip)
2017-07-12 05:25 UTC, Rik
Details
dmesg with drm.debug=0xe (42.32 KB, application/x-bzip)
2017-07-12 18:15 UTC, Rik
Details
/sys/class/drm/card0/error (13.68 KB, application/x-bzip)
2017-07-12 18:16 UTC, Rik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rik 2017-07-09 10:30:28 UTC
Created attachment 132571 [details]
/sys/class/drm/card0/error

Got a new gpu hang on Skylake CPU during `mpv` playback.

%dmesg
[drm] GPU HANG: ecode 9:0:0x8fd87fff, in mpv/vo [2462], reason: Hang on render ring, action: reset
[drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[drm] GPU crash dump saved to /sys/class/drm/card0/error
drm/i915: Resetting chip after gpu hang
[drm] RC6 on

## System info
System:    Kernel: 4.11.9-1-stable x86_64 (64 bit) Desktop: Xfce 4.12.4 Distro: Arch Linux
Machine:   Device: desktop Mobo: ASRock model: Z170M Extreme4 serial: M80-68001700529
           UEFI [Legacy]: American Megatrends v: P7.20 date: 12/13/2016
CPU:       Dual core Intel Core i3-6100 (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 3700 MHz 1: 799 MHz 2: 799 MHz 3: 799 MHz 4: 799 MHz
Memory:    Used/Total: 1045.4/6978.3MB
           Array-1 capacity: 64 GB devices: 4 EC: None
           Device-1: ChannelA-DIMM0 size: No Module Installed type: N/A
           Device-2: ChannelA-DIMM1 size: 8 GB speed: 2400 MT/s type: DDR4
           Device-3: ChannelB-DIMM0 size: No Module Installed type: N/A
           Device-4: ChannelB-DIMM1 size: No Module Installed type: N/A
Graphics:  Card: Intel HD Graphics 530
           Display Server: X.Org 1.19.3 drivers: intel (unloaded: modesetting) Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) version: 4.5 Mesa 17.1.4

%cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-linux-stable root=UUID=4e2f3394-d315-4384-b975-05e33af1ab06 rw intremap=no_x2apic_optout acpi_backlight=none intel_iommu=on i915.enable_gvt=1 quiet loglevel=3 rd.systemd.show_status=false rd.udev.log-priority=3 systemd.log_level=err resume=UUID=25e25554-34e4-4d4a-a7f5-81ef2415db94 printk.time=0 splash
Comment 1 Rik 2017-07-09 10:32:07 UTC
Created attachment 132572 [details]
mpv command line
Comment 2 Rik 2017-07-09 10:33:30 UTC
Created attachment 132573 [details]
systool -m i915 -av
Comment 3 Elizabeth 2017-07-10 21:01:44 UTC
Hello Rik,
Could you please attach dmesg with parameter drm.debug=0xe on grub from boot till the problem is present again? Thank you.
Comment 4 Rik 2017-07-12 05:24:50 UTC
Created attachment 132624 [details]
dmesg with drm.debug=0xe

dmesg attached.
Comment 5 Rik 2017-07-12 05:25:43 UTC
Created attachment 132625 [details]
new gpu crash
Comment 6 Rik 2017-07-12 13:04:10 UTC
(In reply to Elizabeth from comment #3)
> Hello Rik,
> Could you please attach dmesg with parameter drm.debug=0xe on grub from boot
> till the problem is present again? Thank you.

Hello Elizabeth,
see my last 2 comments.

Have a nice day.
Comment 7 Rik 2017-07-12 18:14:31 UTC
OK, got a new crash.

But this time monitor is plugged-in with a DVI-D ---> HDMI cable
(DVI-D = PC port; HDMI = monitor port).

See files attached below.

Thanks.
Comment 8 Rik 2017-07-12 18:15:23 UTC
Created attachment 132642 [details]
dmesg with drm.debug=0xe
Comment 9 Rik 2017-07-12 18:16:50 UTC
Created attachment 132643 [details]
/sys/class/drm/card0/error
Comment 10 Elizabeth 2017-07-13 22:12:30 UTC
(In reply to Rik from comment #9)
> Created attachment 132643 [details]
> /sys/class/drm/card0/error

Hello Rik, 
From batch, this seems to be the process that hangs the GPU:
0xfea2c0a0:      0x70040000: 3D UNKNOWN: 3d_965 opcode = 0x7004

0xfea2c06c:      0x70000007: 3D UNKNOWN: 3d_965 opcode = 0x7000
0xfea2c070:      0x00000000: MI_NOOP
0xfea2c074:      0x00000000: MI_NOOP
0xfea2c078:      0x00893b00: MI UNKNOWN
0xfea2c07c:      0x00000000: MI_NOOP
0xfea2c080:      0x000f0020: MI_NOOP
0xfea2c084:      0x00000000: MI_NOOP
0xfea2c088:      0x00000000: MI_NOOP
0xfea2c08c:      0x00000000: MI_NOOP
0xfea2c090:      0x70010002: 3D UNKNOWN: 3d_965 opcode = 0x7001
0xfea2c094:      0x00000000: MI_NOOP
0xfea2c098:      0x00000100: MI_NOOP
0xfea2c09c:      0x00000000: MI_NOOP
0xfea2c0a0:      0x70040000: 3D UNKNOWN: 3d_965 opcode = 0x7004
0xfea2c0a4:      0x00000000: MI_NOOP
0xfea2c0a8:      0x70020002: 3D UNKNOWN: 3d_965 opcode = 0x7002
0xfea2c0ac:      0x00000000: MI_NOOP
0xfea2c0b0:      0x00000020: MI_NOOP
0xfea2c0b4:      0x00000100: MI_NOOP

I'm moving to product MESA for now.
Thanks.
Comment 11 Elizabeth 2018-03-06 21:45:25 UTC
Hi Rik, is this still reproducible?
Comment 12 GitLab Migration User 2019-09-25 19:03:17 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1610.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.