Bug 101753 - [SKL] XOrg server hangs during start if intel driver is selected
Summary: [SKL] XOrg server hangs during start if intel driver is selected
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
Depends on:
Reported: 2017-07-11 12:32 UTC by m_pashka
Modified: 2018-09-10 10:02 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features: GPU hang

xorg log when nvidia card selected (37.54 KB, text/x-log)
2017-07-11 12:32 UTC, m_pashka
no flags Details
bios info: dmidecode (13.49 KB, text/plain)
2017-07-11 12:32 UTC, m_pashka
no flags Details
Linux distro version: lsb_release -a (80 bytes, text/x-log)
2017-07-11 12:33 UTC, m_pashka
no flags Details
Kernel version: uname -a (112 bytes, text/x-log)
2017-07-11 12:33 UTC, m_pashka
no flags Details
lscpu.log (1.39 KB, text/x-log)
2017-07-11 12:34 UTC, m_pashka
no flags Details
lspci -vt (1.36 KB, text/x-log)
2017-07-11 12:34 UTC, m_pashka
no flags Details
lspci -nnv (13.23 KB, text/x-log)
2017-07-11 12:35 UTC, m_pashka
no flags Details
lscpu (1.39 KB, text/x-log)
2017-07-11 12:35 UTC, m_pashka
no flags Details
cat /proc/cpuinfo (9.02 KB, text/x-log)
2017-07-11 12:36 UTC, m_pashka
no flags Details
lshw (23.74 KB, text/x-log)
2017-07-11 12:37 UTC, m_pashka
no flags Details
dmesg (70.85 KB, text/x-log)
2017-07-11 12:38 UTC, m_pashka
no flags Details
/var/log/boot.log (4.59 KB, text/x-log)
2017-07-21 13:43 UTC, m_pashka
no flags Details

Description m_pashka 2017-07-11 12:32:02 UTC
Created attachment 132606 [details]
xorg log when nvidia card selected


I exeprience problems with Intel graphics driver. It hangs during loading. I'm not a big specialist in Linux drivers and I can't debug video driver and fix problem manually. But may be there are some people that can help me - I can install something and check and whatever.

I suspect this dmesg log output as a some source of my troubles:
[    4.874155] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170303/nsarguments-95)

May be the problem is my HW is recent enough and linux driver was not adopted to it - I have ASUS VivoBook Pro N752VX.

So I collected all system information I have (HW and software) and put into single file.

See https://www.dropbox.com/sh/nmzig3vcuijsxsn/AACm1NZK_JxReD6x6bcKLOpWa/General?dl=0&preview=reporting.txt with system collect details

And https://www.dropbox.com/sh/nmzig3vcuijsxsn/AACm1NZK_JxReD6x6bcKLOpWa/General?dl=0 with the reporting list
Comment 1 m_pashka 2017-07-11 12:32:55 UTC
Created attachment 132607 [details]
bios info: dmidecode
Comment 2 m_pashka 2017-07-11 12:33:33 UTC
Created attachment 132608 [details]
Linux distro version: lsb_release -a
Comment 3 m_pashka 2017-07-11 12:33:51 UTC
Created attachment 132609 [details]
Kernel version: uname -a
Comment 4 m_pashka 2017-07-11 12:34:21 UTC
Created attachment 132610 [details]
Comment 5 m_pashka 2017-07-11 12:34:51 UTC
Created attachment 132611 [details]
lspci -vt
Comment 6 m_pashka 2017-07-11 12:35:13 UTC
Created attachment 132612 [details]
lspci -nnv
Comment 7 m_pashka 2017-07-11 12:35:33 UTC
Created attachment 132613 [details]
Comment 8 m_pashka 2017-07-11 12:36:58 UTC
Created attachment 132614 [details]
cat /proc/cpuinfo
Comment 9 m_pashka 2017-07-11 12:37:19 UTC
Created attachment 132615 [details]
Comment 10 m_pashka 2017-07-11 12:38:46 UTC
Created attachment 132616 [details]
Comment 11 Chris Wilson 2017-07-11 12:41:51 UTC
Which of those logs are for the hang?
Comment 12 m_pashka 2017-07-21 13:39:06 UTC
I can't collect logs for the hang. There is nothing there - I don't see Xorg.log and don't see lightdm log. The only thing I see is /var/log/boot.log. Last line is:
[  OK  ] Started Permit User Sessions.
         Starting Hold until boot process finishes up...
         Starting Light Display Manager...
Comment 13 m_pashka 2017-07-21 13:42:24 UTC
I tried turn off hdd write cache - /etc/hdparm.conf - write_cache = off but that didn't help.
After system habg the only thing I can do is to turn off computer by long-pressing power button.
So my opinion is to solve this I need some speical driver version that will provide more debug output to make it clear where it hangs. And then try to figure out what causes that behaviour.
Comment 14 m_pashka 2017-07-21 13:43:21 UTC
Created attachment 132815 [details]
Comment 15 m_pashka 2017-07-21 13:47:39 UTC
FYI. After hang notebook doesn't react on anything - like caps button, e.t.c. And it seems that it begins to eat 100% CPU because cooler increases speed up to maximum.
Comment 16 Chris Wilson 2017-07-21 14:44:38 UTC
That strongly suggests the problem is kernel side (a kernel panic would have those symptoms, or it may just be a livelock). Diagnosing is impossible without getting the dmesg out of it, could you try either a serial console (unlikely for a laptop) or netconsole (usually requires a wired connection).

Failing that just try changing kernel versions.
Comment 17 m_pashka 2017-08-26 20:16:55 UTC
I tried netconsole but found it pretty useless.
Seems that netconsole starts sending logs after bringing interface up. First message I see:
[    8.626652] r8169 0000:03:00.1 enp3s0f1: link up
which is pretty useless because video driver is already initialized at that time. Will try to figure out possibility to up ethernet interface earlier.
Comment 18 Elizabeth 2017-10-26 20:34:10 UTC
Hello M_pashka, any change with latest tip or mainline? To get more debug information please add drm.debug=0x1e log_bug_len=2M parameters on grub. Thank you.
Comment 19 Jani Nikula 2018-01-22 11:51:05 UTC
Does it boot with nomodeset or without loading i915?
Comment 20 Jani Saarinen 2018-03-29 07:10:32 UTC
First of all. Sorry about spam.
This is mass update for our bugs. 

Sorry if you feel this annoying but with this trying to understand if bug still valid or not.
If bug investigation still in progress, please ignore this and I apologize!

If you think this is not anymore valid, please comment to the bug that can be closed.
If you haven't tested with our latest pre-upstream tree(drm-tip), can you do that also to see if issue is valid there still and if you cannot see issue there, please comment to the bug.
Comment 21 Jani Saarinen 2018-04-20 14:16:25 UTC
Closing, please re-open if still occurs.
Comment 22 m_pashka 2018-09-10 10:02:15 UTC
Using netconsole is pretty useless unless there is a way to change boot order.
Currently netconsole is loaded after video drivers and system halts during video drivers loading. E.g. in working configuration (with nvidia performance mode selected):
[    1.707407] [drm] Memory usable by graphics device = 4096M
[    1.707709] checking generic (b0000000 1e0000) vs hw (b0000000 10000000)
[    1.708054] fb: switching to inteldrmfb from EFI VGA
[    1.708403] Console: switching to colour dummy device 80x25
[    1.708554] [drm] Replacing VGA console driver
[    1.714193] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    1.714196] [drm] Driver supports precise vblank timestamp query.
[    1.716190] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    1.716543] [drm] Finished loading DMC firmware i915/skl_dmc_ver1_26.bin (v1.26)
[    1.724953] [drm] Initialized i915 1.6.0 20171023 for 0000:00:02.0 on minor 0
[    1.761861] PKCS#7 signature not signed with a trusted key
[    1.761870] nvidia: loading out-of-tree module taints kernel.
[    1.761894] nvidia: module license 'NVIDIA' taints kernel.
[    1.761895] Disabling lock debugging due to kernel taint
[    1.763968] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[    1.764520] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    1.769146] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input4
[    1.769321] ACPI: Video Device [PEGP] (multi-head: no  rom: yes  post: no)
[    1.769378] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:12/LNXVIDEO:01/input/input5
[    1.770521] nvidia-nvlink: Nvlink Core is being initialized, major device number 240
[    1.770894] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.77  Tue Jul 10 18:28:52 PDT 2018 (using threaded interrupts)
[    1.776813] PKCS#7 signature not signed with a trusted key
[    1.777825] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.77  Tue Jul 10 22:10:46 PDT 2018
[    1.778356] PKCS#7 signature not signed with a trusted key
[    1.778968] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    1.778973] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
[    1.794467] fbcon: inteldrmfb (fb0) is primary device
[    2.908825] Console: switching to colour frame buffer device 480x135
[    2.936886] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    3.214398] netpoll: netconsole: local port 6666
[    3.214418] netpoll: netconsole: local IPv4 address
[    3.214434] netpoll: netconsole: interface 'enp3s0f1'
[    3.214448] netpoll: netconsole: remote port 6666
[    3.214460] netpoll: netconsole: remote IPv4 address
[    3.214476] netpoll: netconsole: remote ethernet address 48:5d:60:62:b9:88
[    3.214505] netpoll: netconsole: device enp3s0f1 not up yet, forcing it
[    3.262223] r8169 0000:03:00.1 enp3s0f1: link down
[    3.262224] r8169 0000:03:00.1 enp3s0f1: link down
[    3.262336] IPv6: ADDRCONF(NETDEV_UP): enp3s0f1: link is not ready
[    7.272204] netpoll: netconsole: timeout waiting for carrier
[    7.362513] console [netcon0] enabled
[    7.362536] netconsole: network logging started

So in case of selecting intel power saving prime profile system hangs during loading video dirvers before starting netconsole.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.