Bug 101785 - [BDW][IGT] gem_cpu_reloc@full
Summary: [BDW][IGT] gem_cpu_reloc@full
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-13 16:48 UTC by maria guadalupe
Modified: 2017-07-27 16:58 UTC (History)
1 user (show)

See Also:
i915 platform: BDW
i915 features: GEM/Other


Attachments
dmesg.log (185.51 KB, text/plain)
2017-07-13 16:49 UTC, maria guadalupe
no flags Details
dmesgoutput.log (53.31 KB, text/plain)
2017-07-18 22:39 UTC, maria guadalupe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description maria guadalupe 2017-07-13 16:48:14 UTC
the following test is failing with the next configuration 

test
======================================
igt@gem_cpu_reloc@full

Software
======================================
kernel version              : 4.12.0-drm-tip-ww28-commit-8ad9e19+
architecture                : x86_64
os version                  : Ubuntu 16.10
os codename                 : yakkety
kernel driver               : i915
bios revision               : 5.6
hardware acceleration       : disabled
swap partition              : enabled on (/dev/sda3)

======================================
        Graphic drivers
======================================
modesetting                 : enabled
modesetting compiled for    : 1.18.4 X.Org Video Driver
xorg-xserver                : 1.18.4
libdrm                    : 2.4.70
libva                       : 1.7.1-2
vaapi (intel-driver)        : 1.7.1
cairo                       : 1.14.6-1build1
intel-gpu-tools             : 1.16-1

======================================
             Hardware
======================================
platform                   : Broadwell
motherboard id             : NUC5i7RYB
form factor                : Desktop
cpu family                 : Core i7
cpu family id              : 6
cpu information            : Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz
gpu card                   : Intel Corporation Iris Graphics 6100 (rev 09) (prog-if 00 [VGA controller])
memory ram                 : 7.72 GB
max memory ram             : 16 GB
cpu thread                 : 4
cpu core                   : 2
cpu model                  : 61
cpu stepping               : 4
socket                     : Socket BGA1168
signature                  : Type 0, Family 6, Model 61, Stepping 4
hard drive                 : 447GiB (480GB)
current cd clock frequency : 337500 kHz
maximum cd clock frequency : 540000 kHz
displays connected         : HDMI-A-1 DP-1

======================================
             kernel parameters
======================================
quiet drm.debug=0x1e resume=/dev/sda3 fastboot

======================================
attach : dmesg.log
Comment 1 maria guadalupe 2017-07-13 16:49:33 UTC
Created attachment 132670 [details]
dmesg.log
Comment 2 Chris Wilson 2017-07-13 23:37:27 UTC
Test output?
Comment 3 maria guadalupe 2017-07-18 22:38:12 UTC
(In reply to Chris Wilson from comment #2)
> Test output?

test output
========================================
(gem_cpu_reloc:1430) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_cpu_reloc:1430) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_cpu_reloc:1430) drmtest-DEBUG: Test requirement passed: is_i915_device(fd) && has_known_                                                                                                intel_chipset(fd)
(gem_cpu_reloc:1430) ioctl-wrappers-DEBUG: Test requirement passed: err == 0
(gem_cpu_reloc:1430) igt-core-DEBUG: Test requirement passed: !igt_run_in_simulation()
(gem_cpu_reloc:1430) igt-core-DEBUG: Starting subtest: full
(gem_cpu_reloc:1430) intel-chipset-DEBUG: Test requirement passed: pci_dev
(gem_cpu_reloc:1430) intel-os-DEBUG: Checking 131,074 surfaces of size 6,144 bytes (total 872                                                                                                ,431,616) against RAM
(gem_cpu_reloc:1430) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_cpu_reloc:1430) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_cpu_reloc:1430) intel-os-DEBUG: Test requirement passed: __intel_check_memory(count, siz                                                                                                e, mode, &required, &total)
(gem_cpu_reloc:1430) igt-core-DEBUG: Test requirement passed: !igt_run_in_simulation()
gem_cpu_reloc:   1%(gem_cpu_reloc:1430) ioctl-wrappers-CRITICAL: Test assertion failure funct                                                                                                ion gem_execbuf, file ioctl_wrappers.c:624:
(gem_cpu_reloc:1430) ioctl-wrappers-CRITICAL: Failed assertion: __gem_execbuf(fd, execbuf) ==                                                                                                 0
(gem_cpu_reloc:1430) ioctl-wrappers-CRITICAL: error: -5 != 0
Stack trace:
  #0 [__igt_fail_assert+0x101]
  #1 [gem_execbuf+0x44]
  #2 [copy+0x117]
  #3 [run_test+0x191]
  #4 [__real_main243+0x12f]
  #5 [main+0x33]
  #6 [__libc_start_main+0xf1]
  #7 [_start+0x29]
  #8 [<unknown>+0x29]
Subtest full failed.
**** DEBUG ****
(gem_cpu_reloc:1430) intel-chipset-DEBUG: Test requirement passed: pci_dev
(gem_cpu_reloc:1430) intel-os-DEBUG: Checking 131,074 surfaces of size 6,144 bytes (total 872                                                                                                ,431,616) against RAM
(gem_cpu_reloc:1430) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_cpu_reloc:1430) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_cpu_reloc:1430) intel-os-DEBUG: Test requirement passed: __intel_check_memory(count, siz                                                                                                e, mode, &required, &total)
(gem_cpu_reloc:1430) igt-core-DEBUG: Test requirement passed: !igt_run_in_simulation()
(gem_cpu_reloc:1430) ioctl-wrappers-CRITICAL: Test assertion failure function gem_execbuf, fi                                                                                                le ioctl_wrappers.c:624:
(gem_cpu_reloc:1430) ioctl-wrappers-CRITICAL: Failed assertion: __gem_execbuf(fd, execbuf) ==                                                                                                 0
(gem_cpu_reloc:1430) ioctl-wrappers-CRITICAL: error: -5 != 0
****  END  ****
Subtest full: FAIL (45.977s)
(gem_cpu_reloc:1430) igt-core-DEBUG: Exiting with status code 99
(gem_cpu_reloc:1430) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
Comment 4 maria guadalupe 2017-07-18 22:39:24 UTC
Created attachment 132750 [details]
dmesgoutput.log
Comment 5 Chris Wilson 2017-07-26 10:50:51 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.