Bug 101835 - [APL] HDMI 2.0 port cannot pass through Dolby TrueHD and DTS-HD under Linux
Summary: [APL] HDMI 2.0 port cannot pass through Dolby TrueHD and DTS-HD under Linux
Status: CLOSED DUPLICATE of bug 98797
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-19 01:45 UTC by samuelchueh
Modified: 2017-08-11 10:42 UTC (History)
4 users (show)

See Also:
i915 platform: BXT
i915 features: display/HDMI


Attachments
dmesg with drm.debug=0xe parameter (251.08 KB, text/plain)
2017-07-25 07:05 UTC, samuelchueh
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description samuelchueh 2017-07-19 01:45:31 UTC
Hi, we encounter an issue on ApolloLake platform. Our system includes a HDMI 2.0 port which is DP 1.2 à LSPCON (Parade PS176) à HDMI 2.0. We found that this port cannot pass through HBR audio streams (i.e., Dolby TrueHD and DTS-HD MA) under Linux. However video is playing correctly. And the other native HDMI 1.4 port can pass through those audio formats. We tested this issue under Unbuntu 16.04 and 17.04.  And we upgraded Linux kernel to the latest one: v4.12 and KODI 17.3. The result is the same.
 
However, this port can pass through Dolby TrueHD and DTS-HD under Windows-10 (using KODI software) without problems
Comment 1 samuelchueh 2017-07-19 02:36:22 UTC
Reproduce procedure: We connect HDMI 2.0 interface in ApolloLake platform to a AVR which can decode Dolby TrueHD and DTS-HD. And connect AVR HDMI output interface to a HDMI monitor / TV. You can download the test files through http://www.demo-world.eu/2d-demo-trailers-hd/
Comment 2 Elizabeth 2017-07-19 15:21:41 UTC
Hello Samuel,
Could you please attach dmesg with drm.debug=0xe parameter on grub and check if the AVR has any new firmware and update it if applies?
Thank you.
Comment 3 samuelchueh 2017-07-25 07:05:47 UTC
Created attachment 132947 [details]
dmesg with drm.debug=0xe parameter

Hi, 

Attach file is the dmesg with drm.debug=0xe parameter. 

And I have checked the AVR firmware is the latest version.
Comment 4 Elizabeth 2017-08-03 22:31:22 UTC
(In reply to samuelchueh from comment #3)
> Created attachment 132947 [details]
> dmesg with drm.debug=0xe parameter
Thanks for the update Samuel, if further information is needed it would be commented below.
Comment 5 Jani Nikula 2017-08-07 07:26:13 UTC
Duping LSPCON audio issues under one bug.

*** This bug has been marked as a duplicate of bug 1583 ***
Comment 6 Jani Nikula 2017-08-07 07:26:43 UTC

*** This bug has been marked as a duplicate of bug 101583 ***
Comment 7 Johnny Chen 2017-08-08 10:47:21 UTC
Hi Elizabeth,
Do you have any updates? Thank you!!(In reply to Elizabeth from comment #4)
> (In reply to samuelchueh from comment #3)
> > Created attachment 132947 [details]
> > dmesg with drm.debug=0xe parameter
> Thanks for the update Samuel, if further information is needed it would be
> commented below.

Hi Elizabeth,
Do you have any updates? Thank you!!
Comment 8 Elizabeth 2017-08-08 19:23:57 UTC
(In reply to Johnny Chen from comment #7)
> Hi Elizabeth,
> Do you have any updates? Thank you!!
Hello Johnny,
It seems that Jani found the probable root-cause of this problem,
(In reply to Jani Nikula from comment #4)
> (In reply to Joseph Nuzman from comment #0)
> > Observation:  on all working kernels, audio connection type is detected as
> > "DisplayPort".  On failing kernels, audio connection type is "HDMI".
> 
> This is possibly the key. The HDMI 2.0 ports on SKL/KBL NUCs have an
> internal DP->HDMI converter called LSPCON. It looks like DP to the driver.
A different approach is going to be taken, working all the problems at once.
(In reply to Jani Nikula from comment #9)
> Okay, I may be conflating some bugs here, but HD audio over LSPCON is
> problematic. Marking as dupe.
> 
> *** This bug has been marked as a duplicate of bug 101583 ***
Please refer to bug 101583 to keep track of the problem. Updates are going to be added in that bug, and new information also will be asked there when needed. Hopefully this will lead to the solution. 
Thanks for your patience.
Comment 9 samuelchueh 2017-08-09 07:03:57 UTC
Hi, 
  Bug 101583 is not the same issue. We have HDMI audio output. The issue is "DP 1.2 LSPCON (Parade PS176)  HDMI 2.0 port cannot pass through HBR audio streams (i.e., Dolby TrueHD and DTS-HD MA) "

Thanks
Comment 10 Elizabeth 2017-08-09 14:42:05 UTC
(In reply to samuelchueh from comment #9)
> Hi, 
>   Bug 101583 is not the same issue. We have HDMI audio output. The issue is
> "DP 1.2 LSPCON (Parade PS176)  HDMI 2.0 port cannot pass through HBR audio
> streams (i.e., Dolby TrueHD and DTS-HD MA) "
> 
> Thanks
Hello again,
Re-reading the problem again, this may be a duplicated of this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=98797
Could you please take a look to this one?
There are some patches and workarounds that may be helpful, while the audio team works on the case.
Thanks.
Comment 11 samuelchueh 2017-08-10 05:46:39 UTC
Hi, 
  Not helpful. The patches on this bug is "HDMI audio noise issue".
Our issue is "ApolloLake DP 1.2 LSPCON (Parade PS176) HDMI 2.0 port cannot pass through Dolby TrueHD and DTS-HD MA under Linux". 

Thanks.
Comment 12 Jani Nikula 2017-08-10 14:35:26 UTC
Sorry, the dupe target was wrong.

*** This bug has been marked as a duplicate of bug 98797 ***
Comment 13 samuelchueh 2017-08-11 03:00:26 UTC
Hi, 
 Bug 98797 DP is MegaChips. We use the LSPCON (Parade PS176) on our system. 
Not the same issue.
Comment 14 Achilles 2017-08-11 04:33:00 UTC
(In reply to samuelchueh from comment #13)
> Hi, 
>  Bug 98797 DP is MegaChips. We use the LSPCON (Parade PS176) on our system. 
> Not the same issue.

Actually it is. Jani is getting to the final root cause analysis here. The issue has to do with which output (hdmi vs dp) the drm-tip driver is receiving. It doesn't matter if its the Parade or the Megachips LSPCon, the same issue is experienced with both on Linux. I have been tracking this issue on Plex for some time now.

I can reproduce this on any system that emulates HDMI2.0 through a DP controller via LSPCon.
Comment 16 Jani Nikula 2017-08-11 05:45:48 UTC
(In reply to samuelchueh from comment #13)
> Hi, 
>  Bug 98797 DP is MegaChips. We use the LSPCON (Parade PS176) on our system. 
> Not the same issue.

Looks like the problem is not dependent on the LSPCON vendor.

*** This bug has been marked as a duplicate of bug 98797 ***
Comment 17 samuelchueh 2017-08-11 06:24:20 UTC
Hi, 
 This issue not resolved. Please don't change the status. We are waiting for the i915 driver solution. 

Thanks.
Comment 18 Jani Nikula 2017-08-11 10:41:59 UTC
We already have a bug on LSPCON audio passthrough issues with i915, and that is bug 98797. There is no evidence the bug depends on the LSPCON vendor, Megachips vs. Parade. The i915 driver has no code to distinguish between the two, there's just a generic LSPCON driver.

Please follow-up at bug 98797, and do not reopen, unless you come up with evidence that your bug is different.

Thank you.

*** This bug has been marked as a duplicate of bug 98797 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.