Bug 101974 - [snb] GPU hangs playing MegaGlest
Summary: [snb] GPU hangs playing MegaGlest
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-30 19:56 UTC by Peter
Modified: 2019-09-04 11:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
provides info on OS etc; the error file; and dmesg (1016.99 KB, text/plain)
2017-07-30 19:56 UTC, Peter
Details
attachment-26089-0.html (1.81 KB, text/html)
2018-03-07 16:08 UTC, Peter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2017-07-30 19:56:00 UTC
Created attachment 133136 [details]
provides info on OS etc; the error file; and dmesg

Megaglest usually recovers in kernel 4.8, but this time Megaglest crashed though without freezing the OS.  In kernel 4.10 the entire computer freezes and only a hard reboot fixes the problem, and this happens frequently.  The problem might be wider that just this video game.  My system periodically, though more rarely, freezes when I'm using the computer without Megaglest active.

Answers to your other questions are in the attachments.  It also contains /sys/class/drm/card0/error and dmesg (search for 'error' or 'dmesg' from the top).
Comment 1 Chris Wilson 2017-07-30 20:09:00 UTC
If you can get any information on the secondary problem, please do file a separate bug. Try setting up a netconsole, or logging in remotely if you have a second computer available.
Comment 2 Elizabeth 2018-03-06 21:15:56 UTC
Hi, is the hang still reproducible with latest versions? Which mesa version are you using? You're configuration seems a bit special, could you try mesa 17.3.6 if still reproducible? Thank you.
Comment 3 Peter 2018-03-07 16:08:18 UTC
Created attachment 137864 [details]
attachment-26089-0.html

Haven't had problems w/ megaglest in recent memory.  On the other hand, I
got rid of my HP laptop and am now on a HP desktop.  Ubuntu w/ KDE is much
more stable on this machine.



On Tue, Mar 6, 2018 at 4:15 PM, <bugzilla-daemon@freedesktop.org> wrote:

> *Comment # 2 <https://bugs.freedesktop.org/show_bug.cgi?id=101974#c2> on
> bug 101974 <https://bugs.freedesktop.org/show_bug.cgi?id=101974> from
> Elizabeth <elizabethx.de.la.torre.mena@intel.com> *
>
> Hi, is the hang still reproducible with latest versions? Which mesa version are
> you using? You're configuration seems a bit special, could you try mesa 17.3.6
> if still reproducible? Thank you.
>
> ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 4 Marina Chernish 2018-11-06 14:18:49 UTC
Hi Peter,

I tried to reproduce this issue on 13.0.6, 17.1.4 versions of mesa having 4.8.0 kernel and on 17.0.6 and the latest 18.3.0 mesa on kernel 4.10.0. I’ve caught a single hang on the latest mesa 18.3.0 (having 4.10.0 kernel) but cannot catch it again after hours of playing.

My environment: SandyBridge CPU Intel Core i5-2520M; GPU Intel® HD Graphics 3000; Ubuntu 16.04 and 18.10, kernel 4.8.0 and 4.10.0.

Have you faced this issue again on your environment?
Comment 5 Denis 2019-09-04 11:24:02 UTC
as I understand, this issue is not actual anymore, as we couldn't reproduce it and reporter also couldn't. Closing it, please fill free to reopen in case if you find steps to reproduce it


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.