Bug 102007 - Add support for ETSI.CAdES.detached signature type
Summary: Add support for ETSI.CAdES.detached signature type
Status: RESOLVED DUPLICATE of bug 99271
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-01 20:43 UTC by madcatx
Modified: 2017-08-03 19:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Patch to make poppler recognize ETSI.CAdES.detached signature (964 bytes, patch)
2017-08-01 20:43 UTC, madcatx
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description madcatx 2017-08-01 20:43:20 UTC
Created attachment 133181 [details] [review]
Patch to make poppler recognize ETSI.CAdES.detached signature

Add support for the other type of detached PDF signature. A patch that works for me is attached

Link to a test document: http://www.mfcr.cz/assets/cs/media/Zverejnovane-udaje-ze-Seznamu-nepovolenych-internetovych-her_v1.pdf
Comment 1 oliver.sander 2017-08-02 14:00:06 UTC
Isn't this included in

  https://bugs.freedesktop.org/show_bug.cgi?id=99271

?
Comment 2 Albert Astals Cid 2017-08-02 18:06:13 UTC
Seems it is, juts that the patch is coded by a different person.

Michal can you have a look at the url that Oliver pointed and see if that satifies your needs too?
Comment 3 madcatx 2017-08-03 07:48:44 UTC
Oliver's patch seems to go a few steps further but the check for the ETSI signature is there and it does work with my test document. Please disregard my patch...
Comment 4 Albert Astals Cid 2017-08-03 19:05:22 UTC

*** This bug has been marked as a duplicate of bug 99271 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.