Bug 102122 - [softpipe] piglit fdo10370 regression
Summary: [softpipe] piglit fdo10370 regression
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/softpipe (show other bugs)
Version: 17.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2017-08-08 23:06 UTC by Vinson Lee
Modified: 2019-07-15 18:24 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2017-08-08 23:06:28 UTC
mesa: c12c2e40a36f707f733c0d6ad90160472b7a3cf6 (master 17.3.0-devel)

$ ./bin/fdo10370 -auto
data[0x8f], foreground: expected RGBA (1.0, 0.0 0.0 1.0)
First execution, Readback RGBA:
pixel[0, 0]: 1.0 0.0 0.0 1.0
CallList execution, Readback RGBA:
pixel[0, 0]: 1.0 0.0 0.0 1.0
------------------------------------
data[0xff], foreground: expected RGBA (1.0, 0.0 0.0 1.0)
First execution, Readback RGBA:
pixel[0, 0]: 1.0 0.0 0.0 1.0
CallList execution, Readback RGBA:
pixel[0, 0]: 1.0 0.0 0.0 1.0
------------------------------------
data[0x7f], background: expected RGBA (0.0, 0.0 1.0 1.0)
First execution, Readback RGBA:
pixel[0, 0]: 1.0 0.0 0.0 1.0
CallList execution, Readback RGBA:
pixel[0, 0]: 1.0 0.0 0.0 1.0
------------------------------------
data[0x70], background: expected RGBA (0.0, 0.0 1.0 1.0)
First execution, Readback RGBA:
pixel[0, 0]: 1.0 0.0 0.0 1.0
CallList execution, Readback RGBA:
pixel[0, 0]: 1.0 0.0 0.0 1.0
------------------------------------
max delta: 1.000000
PIGLIT: {"result": "fail" }


678dadf1237a3fb492ee2d8daa32d0205dea59ba is the first bad commit
commit 678dadf1237a3fb492ee2d8daa32d0205dea59ba
Author: Nicolai Hähnle <nicolai.haehnle@amd.com>
Date:   Thu Jun 29 17:37:18 2017 +0200

    gallium: move driinfo XML to pipe_loader
    
    We will switch to the pipe_loader loading the configuration options,
    so that they can be passed to the driver independently of the state
    tracker.
    
    Put the description into its own file so that it can be merged easily
    with driver-specific options in future commits.
    
    Reviewed-by: Marek Olšák <marek.olsak@amd.com>

:040000 040000 f973edf38d4f55ed798bfd5e534c14fa79d7a030 c8d20373c9716a640f9ef4ea0c928b40912dda37 M	src
bisect run success
Comment 1 Nicolai Hähnle 2017-11-15 13:41:48 UTC
I cannot reproduce this on Mesa master by running:

$ GALLIUM_DRIVER=softpipe LIBGL_ALWAYS_SOFTWARE=true ./bin/fdo10370 -auto

What am I missing?
Comment 2 Mark Janes 2017-11-21 23:33:19 UTC
Removing from the tracker, since it couldn't be easily reproduced.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.