Bug 102275 - Laptop bootup and suspend and wake issues
Summary: Laptop bootup and suspend and wake issues
Status: RESOLVED DUPLICATE of bug 100228
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/nouveau (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Nouveau Project
Depends on:
Reported: 2017-08-17 15:36 UTC by Eric M
Modified: 2017-08-17 15:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

output of journalctl -b -1 booting into 4.12.5-300 (839.63 KB, text/plain)
2017-08-17 15:36 UTC, Eric M

Note You need to log in before you can comment on or make changes to this bug.
Description Eric M 2017-08-17 15:36:25 UTC
Created attachment 133577 [details]
output of journalctl -b -1 booting into 4.12.5-300

I don't know exactly where to post this bug. Initially I posted on RedHat bugzilla #1481510, but it appears perhaps I should be posting it here. The problem started on upgrading from kernel 4.11.11-300 to 4.12.5-300.

Description of problem:

15-30 seconds of black screen and unresponsive mouse, trackpad, keyboard on bootup and suspend and wake.

Version-Release number of selected component (if applicable):

kernel 4.12.5-300

How reproducible:

Every time booting up or suspending and waking laptop

Steps to Reproduce:
1. Boot up and wait for login screen
2. suspend laptop by closing lid with AC power on
3. wake computer by opening lid 

Actual results:

Expected results:

Additional info:
I was having lots of trouble with suspend and wake issues. See Bug 1470473. Resolved all issues after setting boot parameters and updating Dell XPS BIOS firmware and everything was working well with kernel 4.11.11-300.

Current boot sequence that works with 4.11.11-300 is:
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root  46985d35-b7e3-41f9-9bc0-8ae6c11bc84c
  search --no-floppy --fs-uuid --set=root 46985d35-b7e3-41f9-9bc0-8ae6c11bc84c
linuxefi /vmlinuz-4.11.11-300.fc26.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap nouveau.runpm=0 rhgb quiet resume=/dev/dm-1
initrdefi /initramfs-4.11.11-300.fc26.x86_64.img

Using the same boot sequence with 4.12.5-300 is problematic with bootup and suspend and wake.

Hardware: XPS 15 9560
Fedora 26: all the latest updates current as of 14 Aug 2017
Comment 1 Rhys Kidd 2017-08-17 15:47:24 UTC
Hi Eric,
Thanks for the report. This looks to be a duplicate of bz#100228.

nouveau has difficulties with the GTX 1050 Mobile (GP107/NV137) around power state up/down. I'd suggest you continue to follow that bug report for further updates.

Whilst nouveau.runpm=0 assists a little bit, for now, to improve the experience on the XPS 9560 you should use nouveau.modeset=0 (although that does mean the Nvidia GPU is unavailable for use). This suggestion might change with future kernel releases.

*** This bug has been marked as a duplicate of bug 100228 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.