Bug 102295 - [CI][BAT][KBL] *ERROR* Failed to probe lspcon
Summary: [CI][BAT][KBL] *ERROR* Failed to probe lspcon
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest critical
Assignee: shashank.sharma@intel.com
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-18 13:57 UTC by Martin Peres
Modified: 2017-10-16 06:03 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features: display/LSPCON


Attachments
attachment-13598-0.html (2.88 KB, text/html)
2017-10-16 06:03 UTC, shashank.sharma@intel.com
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2017-08-18 13:57:05 UTC
When running the test igt@drv_module_reload@basic-reload-inject on CI_DRM_2976, the machine fi-kbl-7260u encountered the following dmesg error:

[  453.176010] [drm:lspcon_init [i915]] *ERROR* Failed to probe lspcon
[  453.176066] [drm:intel_ddi_init [i915]] *ERROR* LSPCON init failed on port B

This may be related to https://bugs.freedesktop.org/show_bug.cgi?id=102294.

Full logs: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_2976/fi-kbl-7260u/igt@drv_module_reload@basic-reload-inject.html
Comment 1 Martin Peres 2017-08-21 07:59:01 UTC
Also seen on igt@drv_module_reload@basic-no-display:

Full logs: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_2983/fi-kbl-7260u/igt@drv_module_reload@basic-no-display.html
Comment 2 shashank.sharma@intel.com 2017-08-21 09:08:37 UTC
We have fixed this issue, 
Patches published here https://patchwork.freedesktop.org/series/28684/, 
one set of review done.
Second set of patches coming today.
Comment 3 shashank.sharma@intel.com 2017-08-21 14:08:25 UTC
Published set 2 addressing review comments,
Shashank
Comment 4 Jani Saarinen 2017-10-09 10:00:32 UTC
Shashank, when new v4 arrives?
https://patchwork.freedesktop.org/series/31320/
Comment 5 Jani Saarinen 2017-10-10 10:10:17 UTC
New series sent: https://patchwork.freedesktop.org/series/31639/
Comment 6 Jani Nikula 2017-10-13 09:20:57 UTC
Probably fixed by these commits in drm-intel-next-queued:

commit f687e25a7a245952349f1f9f9cc238ac5a3be258
Author: Shashank Sharma <shashank.sharma@intel.com>
Date:   Thu Oct 12 22:10:08 2017 +0530

    drm: Add retries for lspcon mode detection

commit d18aef0f75436abb95894a230b504432df26c167
Author: Shashank Sharma <shashank.sharma@intel.com>
Date:   Tue Oct 10 15:37:43 2017 +0530

    drm/i915: Don't give up waiting on INVALID_MODE

commit a2fc4bd61e7ec3bb1f7c8b3d47272be813f88aea
Author: Shashank Sharma <shashank.sharma@intel.com>
Date:   Tue Oct 10 15:37:44 2017 +0530

    drm/i915: Add retries for LSPCON detection
Comment 7 Marta Löfstedt 2017-10-13 12:38:55 UTC
The fix was integrated in CI_DRM_3228, the issue is not reproduced. However, I would like to see results from a couple of more runs before I call it verified.
Comment 8 Jani Saarinen 2017-10-13 13:11:35 UTC
Lets resolve as patches are merged.
But follow will be done and only after few runs will be verified
Comment 9 Marta Löfstedt 2017-10-16 06:02:55 UTC
The issue has not been seen since CI_DRM_3228.
Comment 10 shashank.sharma@intel.com 2017-10-16 06:03:35 UTC
Created attachment 134855 [details]
attachment-13598-0.html

Hello,
I am on vacation between 06 Dec - 16 Dec  with limited Phone and no mail access.
Please expect delay in response.

If this is something urgent, please contact my manager : Indranil, Mukherjee

Regards
Shashank


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.