Bug 102320 - Please sort output within lines, not the just between them.
Summary: Please sort output within lines, not the just between them.
Status: RESOLVED MOVED
Alias: None
Product: desktop-file-utils
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium enhancement
Assignee: Hans Petter Jansson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-20 15:06 UTC by Chris Lamb
Modified: 2018-11-12 15:15 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
0001-update-desktop-database.c-Sort-output-within-lines-n.patch (1.16 KB, patch)
2017-08-20 15:06 UTC, Chris Lamb
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Lamb 2017-08-20 15:06:46 UTC
Created attachment 133639 [details] [review]
0001-update-desktop-database.c-Sort-output-within-lines-n.patch

Hi,

Whilst working on the Reproducible Builds effort [0], we noticed
that desktop-file-utils produces mimeinfo.cache files that are not
reproducible.
      
This is because it inherits the non-deterministic hash ordering of
the mime_types_map data structure.
      
Patch attached that sorts just prior to output.
      
 [0] https://reproducible-builds.org/
Comment 1 GitLab Migration User 2018-11-12 15:15:49 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xdg/desktop-file-utils/issues/12.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.