Bug 102379 - GPU HANG: ecode 6:0:0x85fffffc, in unknown [18629], reason: Hang on rcs, action: reset
Summary: GPU HANG: ecode 6:0:0x85fffffc, in unknown [18629], reason: Hang on rcs, acti...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 111544 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-23 20:06 UTC by Christian Rebischke
Modified: 2019-09-25 19:03 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU Crash Dump (40.27 KB, text/plain)
2017-08-23 20:06 UTC, Christian Rebischke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Rebischke 2017-08-23 20:06:24 UTC
Created attachment 133725 [details]
GPU Crash Dump

Hello,
During a game with the Spring RTS Engine I got the following errors:

Aug 23 21:50:38 motoko kernel: [drm] GPU HANG: ecode 6:0:0x85fffffc, in unknown [18629], reason: Hang on rcs, action: reset
Aug 23 21:50:38 motoko kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Aug 23 21:50:38 motoko kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Aug 23 21:50:38 motoko kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Aug 23 21:50:38 motoko kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Aug 23 21:50:38 motoko kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error


For GPU crash dump see my attachment.

Here are some system details:

Kernel: Linux motoko 4.12.8-2-ARCH #1 SMP PREEMPT Fri Aug 18 14:08:02 UTC 2017 x86_64 GNU/Linux
Distribution: Arch Linux
xf86-video-intel: 1:2.99.917+779+g2100efa1-2
Comment 1 Chris Wilson 2017-08-23 20:19:59 UTC
Please check and report your version of mesa; updating if possible.
Comment 2 Christian Rebischke 2017-08-27 16:05:29 UTC
Hello,
My mesa version on Arch Linux is:

17.1.6-1
Comment 3 Christian Rebischke 2017-10-10 22:58:25 UTC
Same issues with: 17.2.2-1
Comment 4 Mark Janes 2017-10-11 10:00:23 UTC
Can you take an apitrace of the game?

We will use it to reproduce/investigate.
Comment 5 Christian Rebischke 2017-10-11 16:58:10 UTC
Hello,
I am not sure if i did the right way. I used the tool `apitrace` for it with the following parameters:

apitrace trace --output spring.trace spring

and then I started the game.

The trace is over 600mb big... I have uploaded it to one of my servers:

http://nullday.de/img/spring.trace
Comment 6 vadym 2018-01-04 13:23:36 UTC
Hello Christian,

For some reason provided link with apitrace doesn't work. 
So can you please share apitrace once again ?
Comment 7 Christian Rebischke 2018-01-04 18:05:27 UTC
Hello,
Sorry seems like my last rsync deleted the apitrace from my server and I have no backup for it :(

Maybe somebody else have it? If not I can try to reproduce it with the current mesa version.
Comment 8 vadym 2018-01-05 11:14:41 UTC
Hi Christian,

Can you please try it again and share new apitrace ?

Thanks in advance!
Comment 9 Denis 2018-07-24 14:45:33 UTC
hi Christian. Is there any changes in the ticket? If the issue is still actual, it would be great to have an apitrace, or, at least name of the game.
Just from glance, I took 3 random games with mentioned GPU - and they looked fine on 17.1.6
Comment 10 Christian Rebischke 2018-07-29 03:53:32 UTC
Hey,
Sorry for the late answer.
I still have indeed GPU hangs with mesa 17.3.7.

[72566.081160] [drm] GPU HANG: ecode 6:0:0x85fffffc, in unknown [12233], reason: Hang on rcs0, action: reset
[72566.081163] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[72566.081164] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[72566.081165] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[72566.081166] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[72566.081167] [drm] GPU crash dump saved to /sys/class/drm/card0/error


The game is `spring1944` it's a free and opensource `spring` engine based RTS game.
You can install it via using `springlobby`. Note that we still use spring engine version `103, because the game is still not ported to the new spring engine. I will try to provide an API trace.
Comment 11 Denis 2018-07-30 11:19:44 UTC
Thank you in advance.
BTW, I played this game on my laptop with Sandybrige CPU and didn't see any hangs. Used the same mesa version with you (so yes, apitrace would be very useful I think)
Comment 12 Christian Rebischke 2018-10-28 22:11:27 UTC
Hi,
sadly I have issues with reproducing this issues. Every time when I try to capture it I can't reproduce the crash. I can just reproduce the GPU hangs... I have made a trace file from this, maybe this is helpful.

https://nullday.de/img/spring.trace
https://nullday.de/img/error
Comment 13 Denis 2018-10-29 14:50:28 UTC
hi Christian. I checked provided apitrace on my configuration:
ubuntu 16.04
kernel 4.14-78 (taken from ukuu)
mesa version 17.1.6 (built from source)

Also I saw the moment, where you wrote in game chat that got a GPU hang. But unfortunately I didn't reproduce them :(

So maybe somebody will have better luck
Comment 14 Lakshmi 2019-09-06 10:45:45 UTC
*** Bug 111544 has been marked as a duplicate of this bug. ***
Comment 15 GitLab Migration User 2019-09-25 19:03:41 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1619.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.