Bug 102424 - PPI not calculated / wrong 96 "dpi" wrong unit / DisplaySize Xorg.conf overridden
Summary: PPI not calculated / wrong 96 "dpi" wrong unit / DisplaySize Xorg.conf overri...
Status: RESOLVED DUPLICATE of bug 41115
Alias: None
Product: xorg
Classification: Unclassified
Component: * Other (show other bugs)
Version: unspecified
Hardware: Other All
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-26 20:53 UTC by foren
Modified: 2017-08-26 21:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description foren 2017-08-26 20:53:21 UTC
Hi,

I do not know where to begin. First: It is not DPI, it's PPI. DPI is printing, PPI is Screen. Second: Not one screen today probably has 96 DPI. Most have more. Stop forcing this one. Third: If I need to manually write into Xorg.conf about the dpi/ppi, accept my values.

Thanks for listening. If someone has questions about ppi/dpi and what the heck it is, please ask me openly.

I am sorry I don't know which component does this mess.
Comment 1 Alan Coopersmith 2017-08-26 21:22:42 UTC
The global DPI value is a historical relic - it cannot have meaning in a world
with multiple outputs as part of the same logical display.  Actual measurements
need to come via the RandR extension that can provide info for each output
device independently.

*** This bug has been marked as a duplicate of bug 41115 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.