Bug 102504 - [CI] igt@kms_flip@plain-flip-fb-recreate failed assertion: ev.sequence == last_seq + 1
Summary: [CI] igt@kms_flip@plain-flip-fb-recreate failed assertion: ev.sequence == las...
Status: CLOSED DUPLICATE of bug 100368
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-01 06:19 UTC by Jani Saarinen
Modified: 2017-10-30 08:20 UTC (History)
1 user (show)

See Also:
i915 platform: HSW
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jani Saarinen 2017-09-01 06:19:16 UTC
On CI on sharded tests igt@kms_flip@plain-flip-fb-recreate failed.

Hostname	
shard-hsw2
Returncode	
99
Out	
IGT-Version: 1.19-g51481627 (x86_64) (Linux: 4.13.0-rc7-CI-CI_DRM_3021+ x86_64)
Using monotonic timestamps
Beginning plain-flip-fb-recreate on pipe A, connector VGA-1
  1024x768 60 1024 1048 1184 1344 768 771 777 806 0xa 0x40 65000
Stack trace:
  #0 [__igt_fail_assert+0x101]
  #1 [run_test_on_crtc_set.constprop.14+0x1cb3]
  #2 [_fini+0x1189]
  #3 [<unknown>+0x1189]
Subtest plain-flip-fb-recreate: FAIL (0.228s)
Err	
(kms_flip:2220) CRITICAL: Test assertion failure function calibrate_ts, file kms_flip.c:1202:
(kms_flip:2220) CRITICAL: Failed assertion: ev.sequence == last_seq + 1
(kms_flip:2220) CRITICAL: error: 4495 != 4494
Subtest plain-flip-fb-recreate failed.
**** DEBUG ****
(kms_flip:2220) DEBUG: Test requirement passed: (flags & TEST_HANG) == 0 || !is_wedged(drm_fd)
(kms_flip:2220) DEBUG: Test requirement passed: modes
(kms_flip:2220) INFO: Beginning plain-flip-fb-recreate on pipe A, connector VGA-1
(kms_flip:2220) igt-fb-DEBUG: igt_create_fb_with_bo_size(width=1024, height=768, format=0x34325258, tiling=0x0, size=0)
(kms_flip:2220) igt-fb-DEBUG: igt_create_fb_with_bo_size(handle=2, pitch=4096)
(kms_flip:2220) igt-fb-DEBUG: igt_create_fb_with_bo_size(width=1024, height=768, format=0x34325258, tiling=0x0, size=0)
(kms_flip:2220) igt-fb-DEBUG: igt_create_fb_with_bo_size(handle=3, pitch=4096)
(kms_flip:2220) igt-kms-INFO:   1024x768 60 1024 1048 1184 1344 768 771 777 806 0xa 0x40 65000
(kms_flip:2220) CRITICAL: Test assertion failure function calibrate_ts, file kms_flip.c:1202:
(kms_flip:2220) CRITICAL: Failed assertion: ev.sequence == last_seq + 1
(kms_flip:2220) CRITICAL: error: 4495 != 4494
(kms_flip:2220) igt-core-INFO: Stack trace:
(kms_flip:2220) igt-core-INFO:   #0 [__igt_fail_assert+0x101]
(kms_flip:2220) igt-core-INFO:   #1 [run_test_on_crtc_set.constprop.14+0x1cb3]
(kms_flip:2220) igt-core-INFO:   #2 [_fini+0x1189]
(kms_flip:2220) igt-core-INFO:   #3 [<unknown>+0x1189]
****  END  ****


https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3021/shard-hsw2/igt@kms_flip@plain-flip-fb-recreate.html
Comment 1 Jani Saarinen 2017-09-01 06:19:51 UTC
Similar seen on https://bugs.freedesktop.org/show_bug.cgi?id=101599
Comment 2 Marta Löfstedt 2017-10-30 08:19:56 UTC
Note: from CI_DRM_3287 to so far, CI_DRM_3292 APL- and GLK-shards failed this tests.

either:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3287/shard-apl8/igt@kms_flip@plain-flip-fb-recreate.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3289/shard-glkb3/igt@kms_flip@plain-flip-fb-recreate.html

(kms_flip:3816) CRITICAL: Test assertion failure function check_state, file kms_flip.c:536:
(kms_flip:3816) CRITICAL: Failed assertion: es->current_seq == es->last_seq + o->seq_step
(kms_flip:3816) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_flip:3816) CRITICAL: unexpected flip seq 45150, expected 45149
Subtest plain-flip-fb-recreate failed.

or:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3291/shard-apl4/igt@kms_flip@plain-flip-fb-recreate.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3287/shard-glkb5/igt@kms_flip@plain-flip-fb-recreate.html

(kms_flip:3783) CRITICAL: Test assertion failure function calibrate_ts, file kms_flip.c:1200:
(kms_flip:3783) CRITICAL: Failed assertion: ev.sequence == last_seq + 1
(kms_flip:3783) CRITICAL: error: 31938 != 31937
Subtest plain-flip-fb-recreate failed.

Also, the es->current_seq == es->last_seq + o->seq_step is filed on bug 100368. I will duplicate to that one.

*** This bug has been marked as a duplicate of bug 100368 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.