Bug 102516 - regression on glsl shaders on BE architecture mesa-17.2.0-rc6
Summary: regression on glsl shaders on BE architecture mesa-17.2.0-rc6
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: glsl-compiler (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-02 08:49 UTC by intermediadc@hotmail.com
Modified: 2017-10-10 06:57 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description intermediadc@hotmail.com 2017-09-02 08:49:01 UTC
when i run software that need shaders on mesa-17.2.0-rc6 
i have black windows with this comments:

Qemu:
./qemu-system-ppc64 -m 1024 -cpu G4 -display sdl,gl=on -M mac99
qemu_gl_create_compile_shader: compile vertex error
0:4(9): error: syntax error, unexpected $end, expecting ',' or ';'

qemu_gl_create_compile_shader: compile fragment error
0:4(19): error: syntax error, unexpected $end, expecting ',' or ';'



This is with Darkplace quake:
(line offset for any above warnings/errors: 50)
GLSL shader glsl/default.glsl depth/shadow failed!  some features may not work properly.
vertex shader compile log:
0:91(17): error: syntax error, unexpected $end, expecting ';'

Hope will help build
Comment 1 intermediadc@hotmail.com 2017-09-07 10:01:08 UTC
Tested on 17.2 offical and same issue 
this come on Mame

 mame -w
../../../../../src/osd/modules/opengl/gl_shader_tool.cpp:358: GL Error: object 0x1 compilation failed
../../../../../src/osd/modules/opengl/gl_shader_tool.cpp:358 glInfoLog: 0:2(6): error: syntax error, unexpected $end, expecting ',' or ';'

failed to process shader: <
void main()
{
   gl_TexCoord[0]  = gl_TextureMatrix[0] * gl_MultiTexCoord0;
   gl_Position     = ftransform();
}
Comment 2 Emil Velikov 2017-09-08 11:09:01 UTC
Shader shown seems fine. Can you bisect mesa to track the offending commit?
Comment 3 intermediadc@hotmail.com 2017-09-08 11:18:16 UTC
hi emil i can try but im not the best to this things .
if you gave me an hand step by step i can try. for sure the issue come after rc4 that was for sure the last i was build and was working ok on my system
Comment 4 Eero Tamminen 2017-09-08 13:22:14 UTC
If you have a working Apitrace trace, ezBench could be used to automatically bisect which Mesa commits cause changes in rendering i.e. regresses it.

ezBench is here:
  https://cgit.freedesktop.org/ezbench

You need to set up "user_parameters.sh" file so that ezBench can build Mesa & run it with Apitrace, and have a folder with the apitrace trace file used for render validation + a file which tells which frame in the trace is used for comparison.

README tells how to setup & use ezBench.  I will add some documentation on how to do the Apitrace validation (to the example parameter file).
Comment 5 intermediadc@hotmail.com 2017-10-10 06:57:40 UTC
Hi Emil and Aero,
the issue is fixed i had been tested with last mesa git.
but new one come if i build with radeonsi, amdgpu and with an ld error.
i will open a new bug report.

thanks
Luigi


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.