Bug 102550 - [ilk] GPU hang in plasmashell
Summary: [ilk] GPU hang in plasmashell
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.0
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-05 18:24 UTC by in+fd
Modified: 2019-09-25 19:03 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features: display/LVDS


Attachments
GPU crash dump (119.77 KB, application/gzip)
2017-09-05 18:24 UTC, in+fd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description in+fd 2017-09-05 18:24:45 UTC
Created attachment 133973 [details]
GPU crash dump

Bug description:

Hello,

My logs told me to open this ticket:

Sep 05 19:18:59 asdf kernel: [drm] GPU HANG: ecode 5:0:0x97cafffb, in plasmashell [3636], reason: Hang on render ring, action: reset
Sep 05 19:18:59 asdf kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Sep 05 19:18:59 asdf kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Sep 05 19:18:59 asdf kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Sep 05 19:18:59 asdf kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Sep 05 19:18:59 asdf kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
Sep 05 19:18:59 asdf kernel: drm/i915: Resetting chip after gpu hang
Sep 05 19:19:09 asdf kernel: drm/i915: Resetting chip after gpu hang
Sep 05 19:19:20 asdf kernel: drm/i915: Resetting chip after gpu hang


System environment:
-- chipset: i915
-- system architecture: 64-bit
-- xf86-video-intel: 2.99.917.770_gcb6ba2da-1.3
-- xserver: 7.6_1.18.3-22.1
-- mesa: 17.0.5-174.2
-- libdrm: 2.4.76-1.2
-- kernel: 4.4.79-19.1
-- Linux distribution: OpenSUSE Leap 42.3
-- Machine or mobo model: TOSHIBA PORTEGE R700 PT311E-018019EN
-- Display connector: LVDS


Reproducing steps:
The bug occurs on a daily basis, there's no obvious trigger.


Additional info:
The log points to a crash dump which is attach to this bug report.



If more information is needed, please let me know.

Best Regards
SH
Comment 1 Elizabeth 2018-03-06 21:01:42 UTC
Hi! If this is still reproducible, could you try latest mesa release 17.3.6? It had fixed various GPU hangs including some DE ones.
Comment 2 in+fd 2018-04-23 19:19:30 UTC
Hello, Mesa 17.3.6 is not available for my distro, but 18.0.1. Does it help if I try to reproduce the issue with 18.0.1 ?
Comment 3 Mark Janes 2018-04-23 20:07:46 UTC
18.0.1 is even better, thanks.
Comment 4 in+fd 2018-04-26 19:36:25 UTC
Since I didn't use the system for some time, there were many outdated packages.

At first I updated Mesa 18.0.1 and it's dependencies only and not any other packages. After the installation I rebooted and logged in to KDE. After a few seconds of doing nothing, the issue reappeared and the whole system froze. I had to hard reset the system.

Afterwards I retried after installing all outdated packages. This time the system froze immediately after the login to KDE: Black screen, no cursor, no tty switch (ALT + F-Keys).
Comment 5 GitLab Migration User 2019-09-25 19:03:57 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1625.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.