Bug 102663 - [G45] GLES CTS tests intermittently deadlock
Summary: [G45] GLES CTS tests intermittently deadlock
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 101450 (view as bug list)
Depends on:
Blocks: 102590
  Show dependency treegraph
 
Reported: 2017-09-11 20:06 UTC by Mark Janes
Modified: 2019-09-25 19:04 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2017-09-11 20:06:02 UTC

    
Comment 1 Mark Janes 2017-09-11 20:08:08 UTC
Roughly 10% of CTS test suite executions produce deadlocks, when running the suite in multiple threads.

For example, the suite has deadlocked with the following 2 tests stuck in execution:

  - ES2-CTS.functional.draw.draw_elements.line_strip.single_attribute
  - ES2-CTS.gtf.GL2FixedTests.mipmaps_interpolation.mipmaps_interpolation

Killing either of the test suite processes allows the other process to complete successfully.  The deadlocks stall execution indefinitely.
Comment 2 Mark Janes 2017-09-12 18:03:15 UTC
Other tests that hang:

ES2-CTS.functional.default_vertex_attrib.mat3.vertex_attrib_1f
ES2-CTS.functional.depth_range.write.zero_to_half
ES2-CTS.gtf.GL2FixedTests.buffer_color.buffer_color
Comment 3 Mark Janes 2017-10-27 18:48:36 UTC
It looks like we shipped this as far back as 17.1, so it is not a new regression for 17.3.
Comment 4 Mark Janes 2017-10-27 18:49:08 UTC
*** Bug 101450 has been marked as a duplicate of this bug. ***
Comment 5 GitLab Migration User 2019-09-25 19:04:08 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1630.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.