Bug 102797 - Running unigine superposition benchmark in wine freezes the system
Summary: Running unigine superposition benchmark in wine freezes the system
Status: RESOLVED DUPLICATE of bug 101731
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-15 17:18 UTC by Fabian Maurer
Modified: 2017-09-20 09:13 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Maurer 2017-09-15 17:18:53 UTC
Apitrace: http://www.mediafire.com/file/pc7yynmrmj9e6m2/unigine-freeze.7z
Running the trace with freeze the system, forcing a hard-reset.

System the bug was tested on:
- Arch Linux 64bit
- Linux 4.13.2, AMDGPU driver
- Mesa 17.3.0-devel (git-2f6ffab1ce) / 17.1.8
- Radeon R9 285
Comment 1 Samuel Pitoiset 2017-09-20 09:12:00 UTC
Very interesting stuff! It's similar to the TW3 issue (https://bugs.freedesktop.org/show_bug.cgi?id=101731).

Basically, Wine doesn't correctly set the transform feedback varyings (ie. count is 0 in glTransformFeedbackVaryings), then MEsa
Comment 2 Samuel Pitoiset 2017-09-20 09:13:32 UTC
[..] then Mesa reports the following errors:

Mesa: User error: GL_INVALID_OPERATION in glBeginTransformFeedback(no varyings to record)
358502: message: major api error 4: GL_INVALID_OPERATION in glBeginTransformFeedback(no varyings to record)

and the GPU hangs.

If you try the "special varying hack" patch from #101731 it fixes the issue.

*** This bug has been marked as a duplicate of bug 101731 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.