Bug 102846 - [BAT][KBL] igt@kms_pipe_crc_basic@suspend-read-crc-pipe-c Softdog Incomplete
Summary: [BAT][KBL] igt@kms_pipe_crc_basic@suspend-read-crc-pipe-c Softdog Incomplete
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: highest major
Assignee: Marta Löfstedt
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-19 05:50 UTC by Marta Löfstedt
Modified: 2017-11-23 13:08 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2017-09-19 05:50:59 UTC
On CI_DRM_3104 fi-kbl-7560u 


<3>[  556.687069] [drm:drm_atomic_helper_wait_for_flip_done] *ERROR* [CRTC:56:pipe C] flip_done timed out
<7>[  556.687517] [drm:verify_connector_state.isra.71 [i915]] [CONNECTOR:58:eDP-1]
<7>[  556.687711] [drm:intel_atomic_commit_tail [i915]] [CRTC:56:pipe C]
<7>[  556.688500] [drm:verify_single_dpll_state.isra.72 [i915]] DPLL 0
<2>[  631.151789] softdog: Initiating panic
<0>[  631.151813] Kernel panic - not syncing: Software Watchdog Timer expired
<4>[  631.151837] CPU: 1 PID: 0 Comm: swapper/1 Tainted: G     U          4.14.0-rc1-CI-CI_DRM_3104+ #1
<4>[  631.151861] Hardware name: Dell Inc. XPS 13 9360/093TW6, BIOS 1.3.2 01/18/2017
<4>[  631.151883] Call Trace:
<4>[  631.151906]  <IRQ>
<4>[  631.151936]  dump_stack+0x68/0x9f
<4>[  631.151956]  panic+0xd4/0x21d
<4>[  631.151986]  ? printk+0x43/0x4b
<4>[  631.152025]  softdog_fire+0x6b/0x70
<4>[  631.152042]  __hrtimer_run_queues+0xed/0x4d0
<4>[  631.152060]  ? softdog_ping+0x50/0x50
<4>[  631.152082]  hrtimer_interrupt+0xc1/0x220
<4>[  631.152118]  smp_apic_timer_interrupt+0x7d/0x2e0
<4>[  631.152145]  apic_timer_interrupt+0x9a/0xa0
<4>[  631.152161]  </IRQ>
<4>[  631.152180] RIP: 0010:cpuidle_enter_state+0x136/0x370
<4>[  631.152194] RSP: 0018:ffffc900000b3e80 EFLAGS: 00000216 ORIG_RAX: ffffffffffffff10
<4>[  631.152231] RAX: ffff880274b60040 RBX: 0000000000008b5c RCX: 0000000000000001
<4>[  631.152254] RDX: 0000000000000000 RSI: ffffffff81d0db8c RDI: ffffffff81cc1a16
<4>[  631.152276] RBP: ffffc900000b3eb8 R08: 00000000ffffffff R09: 0000000000000008
<4>[  631.152290] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000002
<4>[  631.152303] R13: 0000000000000002 R14: ffff88027e4a58a0 R15: 00000092f39344fc
<4>[  631.152342]  cpuidle_enter+0x17/0x20
<4>[  631.152370]  call_cpuidle+0x23/0x40
<4>[  631.152396]  do_idle+0x192/0x1e0
<4>[  631.152416]  cpu_startup_entry+0x1d/0x20
<4>[  631.152433]  start_secondary+0x11c/0x140
<4>[  631.152452]  secondary_startup_64+0xa5/0xa5
<0>[  631.153590] Kernel Offset: disabled


https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3104/fi-kbl-7560u/igt@kms_pipe_crc_basic@suspend-read-crc-pipe-c.html
Comment 2 Marta Löfstedt 2017-09-26 05:54:20 UTC
Reproduced CI_DRM_3131 on fi-kbl-r:

<6>[  552.609029] [drm] RC6 on
<6>[  552.651159] asix 1-2:1.0 enx0010603172d5: link up, 100Mbps, full-duplex, lpa 0xC1E1
<7>[  554.529173] [drm:edp_panel_vdd_off_sync [i915]] Turning eDP port A VDD off
<7>[  554.529348] [drm:edp_panel_vdd_off_sync [i915]] PP_STATUS: 0x80000008 PP_CONTROL: 0x00000007
<3>[  554.723877] [drm:i915_gem_idle_work_handler [i915]] *ERROR* Timeout waiting for engines to idle
<3>[  561.633012] [drm:drm_atomic_helper_wait_for_flip_done] *ERROR* [CRTC:56:pipe C] flip_done timed out
<7>[  561.633303] [drm:verify_connector_state.isra.71 [i915]] [CONNECTOR:58:eDP-1]
<7>[  561.633448] [drm:intel_atomic_commit_tail [i915]] [CRTC:56:pipe C]
<7>[  561.633665] [drm:verify_single_dpll_state.isra.72 [i915]] DPLL 0
<2>[  636.005312] softdog: Initiating panic

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3131/fi-kbl-r/igt@kms_pipe_crc_basic@suspend-read-crc-pipe-c.html
Comment 3 Jani Saarinen 2017-10-01 07:57:57 UTC
This also now seen on:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3158/fi-kbl-7560u/igt@gem_linear_blits@basic.html

<7>[  717.438390] [drm:missed_breadcrumb [i915]] rcs0 missed breadcrumb at intel_breadcrumbs_hangcheck+0x61/0x80 [i915], irq posted? yes, current seqno=14200d, last=14200d
<3>[  717.567175] [drm:i915_gem_idle_work_handler [i915]] *ERROR* Timeout waiting for engines to idle
<3>[  727.934290] [drm:drm_atomic_helper_wait_for_dependencies] *ERROR* [CRTC:36:pipe A] flip_done timed out
<2>[  738.088137] softdog: Initiating panic
<0>[  738.088190] Kernel panic - not syncing: Software Watchdog Timer expired
<4>[  738.088290] CPU: 3 PID: 0 Comm: swapper/3 Tainted: G     U          4.14.0-rc2-CI-CI_DRM_3158+ #1
<4>[  738.088399] Hardware name: Dell Inc. XPS 13 9360/093TW6, BIOS 1.3.2 01/18/2017
<4>[  738.088475] Call Trace:
<4>[  738.088525]  <IRQ>
<4>[  738.088561]  dump_stack+0x68/0x9f
<4>[  738.088627]  panic+0xd4/0x21d
<4>[  738.088675]  ? printk+0x43/0x4b
<4>[  738.088741]  softdog_fire+0x6b/0x70
<4>[  738.088792]  __hrtimer_run_queues+0xed/0x4d0
<4>[  738.088855]  ? softdog_ping+0x50/0x50
<4>[  738.088915]  hrtimer_interrupt+0xc1/0x220
<4>[  738.088982]  smp_apic_timer_interrupt+0x7d/0x2e0
<4>[  738.089042]  apic_timer_interrupt+0x9a/0xa0
<4>[  738.089098]  </IRQ>
<4>[  738.089151] RIP: 0010:cpuidle_enter_state+0x136/0x370
<4>[  738.089205] RSP: 0018:ffffc900000c3e80 EFLAGS: 00000202 ORIG_RAX: ffffffffffffff10
<4>[  738.089306] RAX: ffff880274b62a40 RBX: 00000000000029f7 RCX: 0000000000000001
<4>[  738.089400] RDX: 0000000000000000 RSI: ffffffff81d0e06c RDI: ffffffff81cc1ea6
<4>[  738.089474] RBP: ffffc900000c3eb8 R08: 00000000ffffffff R09: 0000000000000008
<4>[  738.089550] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000001
<4>[  738.089643] R13: 0000000000000001 R14: ffff88027e5a58a0 R15: 000000abd97ad493
<4>[  738.089743]  cpuidle_enter+0x17/0x20
<4>[  738.089793]  call_cpuidle+0x23/0x40
<4>[  738.089846]  do_idle+0x192/0x1e0
<4>[  738.089908]  cpu_startup_entry+0x1d/0x20
<4>[  738.089957]  start_secondary+0x11c/0x140
<4>[  738.090028]  secondary_startup_64+0xa5/0xa5
<0>[  738.090183] Kernel Offset: disabled
Comment 4 Marta Löfstedt 2017-10-10 10:16:52 UTC
Also, on CI_DRM_3201 fi-kbl-r igt@kms_pipe_crc_basic@suspend-read-crc-pipe-b

<3>[  550.778409] [drm:i915_gem_idle_work_handler [i915]] *ERROR* Timeout waiting for engines to idle
<7>[  551.351513] [drm:edp_panel_vdd_off_sync [i915]] Turning eDP port A VDD off
<7>[  551.351691] [drm:edp_panel_vdd_off_sync [i915]] PP_STATUS: 0x80000008 PP_CONTROL: 0x00000007
<3>[  558.455391] [drm:drm_atomic_helper_wait_for_flip_done] *ERROR* [CRTC:46:pipe B] flip_done timed out
<7>[  558.455692] [drm:verify_connector_state.isra.72 [i915]] [CONNECTOR:58:eDP-1]
<7>[  558.455841] [drm:intel_atomic_commit_tail [i915]] [CRTC:46:pipe B]
<7>[  558.456068] [drm:verify_single_dpll_state.isra.73 [i915]] DPLL 0
<2>[  632.707146] softdog: Initiating panic
<0>[  632.707170] Kernel panic - not syncing: Software Watchdog Timer expired
<4>[  632.707190] CPU: 2 PID: 0 Comm: swapper/2 Tainted: G     U          4.14.0-rc4-CI-CI_DRM_3201+ #1
<4>[  632.707204] Hardware name: Intel Corporation Kabylake Client platform/Kabylake R DDR4 RVP, BIOS KBLSE2R1.R00.X078.P02.1703030515 03/03/2017
<4>[  632.707217] Call Trace:
<4>[  632.707230]  <IRQ>
<4>[  632.707255]  dump_stack+0x68/0x9f
<4>[  632.707273]  panic+0xd4/0x21d
<4>[  632.707294]  ? printk+0x43/0x4b
<4>[  632.707318]  softdog_fire+0x6b/0x70
<4>[  632.707334]  __hrtimer_run_queues+0xed/0x4d0
<4>[  632.707353]  ? softdog_ping+0x50/0x50
<4>[  632.707372]  hrtimer_interrupt+0xc1/0x220
<4>[  632.707394]  smp_apic_timer_interrupt+0x7d/0x2e0
<4>[  632.707410]  apic_timer_interrupt+0x9a/0xa0
<4>[  632.707423]  </IRQ>
<4>[  632.707440] RIP: 0010:cpuidle_enter_state+0x136/0x370
<4>[  632.707454] RSP: 0018:ffffc900000f3e80 EFLAGS: 00000212 ORIG_RAX: ffffffffffffff10
<4>[  632.707478] RAX: ffff8802b4fe5440 RBX: 000000000947c0bf RCX: 0000000000000001
<4>[  632.707492] RDX: 0000000000000000 RSI: ffffffff81d0e3b4 RDI: ffffffff81cc212e
<4>[  632.707505] RBP: ffffc900000f3eb8 R08: 00000000001e40f1 R09: 0000000000000018
<4>[  632.707519] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000008
<4>[  632.707532] R13: 0000000000000008 R14: ffffe8ffffc84660 R15: 0000009347009e31
<4>[  632.707563]  cpuidle_enter+0x17/0x20
<4>[  632.707581]  call_cpuidle+0x23/0x40
<4>[  632.707597]  do_idle+0x192/0x1e0
<4>[  632.707618]  cpu_startup_entry+0x1d/0x20
<4>[  632.707634]  start_secondary+0x11c/0x140
<4>[  632.707653]  secondary_startup_64+0xa5/0xa5
<0>[  632.707796] Kernel Offset: disabled


https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3201/fi-kbl-r/igt@kms_pipe_crc_basic@suspend-read-crc-pipe-b.html
Comment 5 Jani Saarinen 2017-10-31 17:42:16 UTC
According to Imre:
"This looks like the DMC corruption issue"
Comment 6 Jani Saarinen 2017-11-23 09:58:36 UTC
As 1.04 now merged:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3375/commits_short.log
resolving to see if issue still exists...
Comment 7 Marta Löfstedt 2017-11-23 13:08:41 UTC
CI_DRM_3375 and CI_DRM_3376 has none of:
 "*ERROR* Timeout waiting for engines to idle" nor "*ERROR* [CRTC:36:pipe A] flip_done timed out.", related softdogs. 

I will close this


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.