Bug 102896 - GPU HANG: ecode 9:0:0x85dffffb, in Xorg [1162], reason: Hang on render ring, action: reset (with Libreoffice on KDE Plasma)
Summary: GPU HANG: ecode 9:0:0x85dffffb, in Xorg [1162], reason: Hang on render ring, ...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 103637 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-20 10:53 UTC by Pere Gellida
Modified: 2019-09-25 19:04 UTC (History)
3 users (show)

See Also:
i915 platform: SKL
i915 features: GPU hang


Attachments
/sys/class/drm/card0/error (755.48 KB, text/plain)
2017-09-20 10:53 UTC, Pere Gellida
Details
/sys/class/drm/card0/error (45.45 KB, text/plain)
2018-03-03 21:05 UTC, iczero4
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pere Gellida 2017-09-20 10:53:51 UTC
Created attachment 134359 [details]
/sys/class/drm/card0/error

Hi,

since the upgrade of Debian (from Debian Jessie to Debian Stretch 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u3 x86_64 GNU/Linux) the X server crashes completely while I'm using Libreoffice. It doesn't always happen. I don't know how to reproduce the crash.


This is the log

set 19 14:30:06 et11254 kernel: [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [1162], reason: Hang on render ring, action: reset
set 19 14:30:06 et11254 kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
set 19 14:30:06 et11254 kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
set 19 14:30:06 et11254 kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
set 19 14:30:06 et11254 kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
set 19 14:30:06 et11254 kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
set 19 14:30:06 et11254 kernel: drm/i915: Resetting chip after gpu hang
set 19 14:30:06 et11254 kernel: [drm] RC6 on
set 19 14:30:06 et11254 kernel: [drm] GuC firmware load skipped
set 19 14:30:18 et11254 kernel: drm/i915: Resetting chip after gpu hang
set 19 14:30:18 et11254 kernel: [drm] RC6 on
set 19 14:30:18 et11254 kernel: [drm] GuC firmware load skipped
set 19 14:30:18 et11254 org.kde.kuiserver[1286]: kuiserver: Fatal IO error: client killed
set 19 14:30:18 et11254 org.a11y.atspi.Registry[1490]: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server :0
set 19 14:30:18 et11254 org.a11y.atspi.Registry[1490]: after 17353 requests (17353 known processed) with 0 events remaining.
set 19 14:30:18 et11254 org.kde.KScreen[1286]: The X11 connection broke (error 1). Did the X11 server die?
set 19 14:30:18 et11254 org.kde.kglobalaccel[1286]: The X11 connection broke (error 1). Did the X11 server die?
set 19 14:30:18 et11254 polkitd(authority=local)[603]: Unregistered Authentication Agent for unix-session:3 (system bus name :1.27, object path /org/kde/PolicyKit1/AuthenticationAgent, loc
set 19 14:30:18 et11254 sddm[1158]: Display server stopped.

I have attached /sys/class/drm/card0/error file with the "GPU hang" report.
Comment 1 Elizabeth 2017-09-20 15:58:08 UTC
Hello Pere, 
Could you share your Mesa version, also is your display 4K? Are you using impress when this happens? Thank you.
Comment 2 Pere Gellida 2017-09-22 10:30:59 UTC
(In reply to Elizabeth from comment #1)
> Hello Pere, 
> Could you share your Mesa version, also is your display 4K? Are you using
> impress when this happens? Thank you.

This is the Mesa version 13.0.6-1+b2

I have had the crash using Libreoffice Write and Calc, but I think if had used Impress I would have had the same problem.
Comment 3 Pere Gellida 2017-09-22 10:36:07 UTC
(In reply to Elizabeth from comment #1)
> Hello Pere, 
> Could you share your Mesa version, also is your display 4K? Are you using
> impress when this happens? Thank you.

My display resolution is 2560 x 1440
Comment 4 Elizabeth 2017-12-04 23:49:28 UTC
*** Bug 103637 has been marked as a duplicate of this bug. ***
Comment 5 iczero4 2017-12-04 23:54:10 UTC
I am using Mesa 17.2.2. I am using two monitors with resolutions 1920x1200 and 1920x1080. I have only had the problem happen with LibreOffice Writer.
Comment 6 Elizabeth 2017-12-04 23:56:37 UTC
Hello Pere, Iczero4,
Could you please try to reproduce with more recent kernel(4.13 and up) and Mesa (17.2 and up)? As you state in the summary, is this only reproducible with KDE?? Have you identified any pattern while working with Libreoffice to make it hang easier??
Thanks for your time.
Comment 7 Mark Janes 2017-12-05 16:52:01 UTC
If you are going to try updating versions, please start with mesa 17.3 which will be released in the next day or so.  You can build 17.3-rc6 today, which have patches that have resolved similar behavior for engineers at Intel.
Comment 8 iczero4 2018-03-03 21:04:49 UTC
I am now on mesa 17.3.2 and kernel 4.13.0-36-generic (from ubuntu) and had this crash again. The crash occurred right after I had moved the typing cursor. The error given by /sys/class/drm/card0/error seems slightly different, so I have also attached that. I still have the same monitor configuration.
Comment 9 iczero4 2018-03-03 21:05:10 UTC
Created attachment 137769 [details]
/sys/class/drm/card0/error
Comment 10 Mark Janes 2018-03-03 21:28:38 UTC
GPU hangs in 17.3 were not fixed until the most recent 17.3.6 release.

Please verify that your hang is fixed, and mark this bug as a dup of 104411 if that is the case.
Comment 11 GitLab Migration User 2019-09-25 19:04:15 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1632.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.