Bug 102949 - chromium-vaapi-bin freezes while playing video via VA-API
Summary: chromium-vaapi-bin freezes while playing video via VA-API
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-23 01:15 UTC by nanericwang
Modified: 2017-11-21 16:40 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
i915 error output (39.37 KB, text/plain)
2017-10-08 15:28 UTC, Philipp Richter
Details
GPU crash dump saved to /sys/class/drm/card0/error (60.88 KB, text/plain)
2017-11-21 16:26 UTC, nanericwang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nanericwang 2017-09-23 01:15:42 UTC
My GPU is Intel Gen5. The bug causes the chrome tabs totally freeze.

Steps to reproduce:
1. install mesa-17.2
2. install chromium-vaapi-bin
3. enable vaapi accelaration
4. open a HTML5 video
5. expected playback smoothly, but actually freeze the whole process
Comment 1 nanericwang 2017-09-24 09:36:20 UTC
dmesg:

9/24 17:23:18 kernel: drm/i915: Resetting chip after gpu hang
9/24 17:23:26 kernel: drm/i915: Resetting chip after gpu hang
9/24 17:23:34 kernel: drm/i915: Resetting chip after gpu hang
9/24 17:25:38 kernel: drm/i915: Resetting chip after gpu hang
9/24 17:25:46 kernel: drm/i915: Resetting chip after gpu hang
9/24 17:25:54 kernel: drm/i915: Resetting chip after gpu hang
9/24 17:26:02 kernel: drm/i915: Resetting chip after gpu hang
Comment 2 nanericwang 2017-09-24 09:40:10 UTC
more details:

[  +1.195806] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[  +0.002587] [drm:ironlake_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Comment 3 Kenneth Graunke 2017-09-24 17:26:34 UTC
(In reply to nanericwang from comment #2)
> more details:
> 
> [  +1.195806] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU
> pipe A FIFO underrun
> [  +0.002587] [drm:ironlake_irq_handler [i915]] *ERROR* PCH transcoder A
> FIFO underrun

This is related to display / monitor problems - shouldn't affect this bug.  The GPU hangs are concerning.

Can you provide the output of:
$ lspci -nn | grep VGA

Thanks!
Comment 4 nanericwang 2017-09-25 04:48:34 UTC
(In reply to Kenneth Graunke from comment #3)
> (In reply to nanericwang from comment #2)
> > more details:
> > 
> > [  +1.195806] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU
> > pipe A FIFO underrun
> > [  +0.002587] [drm:ironlake_irq_handler [i915]] *ERROR* PCH transcoder A
> > FIFO underrun
> 
> This is related to display / monitor problems - shouldn't affect this bug. 
> The GPU hangs are concerning.
> 
> Can you provide the output of:
> $ lspci -nn | grep VGA
> 
> Thanks!

$ lspci -nn | grep VGA
2:00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
Comment 5 nanericwang 2017-09-25 23:40:59 UTC
video playback was good for first few seconds before frozen. i'm guessing it was because of some resource leaks?
Comment 6 Philipp Richter 2017-10-08 15:28:14 UTC
Created attachment 134750 [details]
i915 error output

Hi,

I added the output of /sys/class/drm/card0/error
This happens to me on my Dell XPS 13 9360. I'm using kernel 4.12.14 but it also happens on 4.13.5.

Mesa version is 17.2.2

$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 620 [8086:5916] (rev 02)

Journal output looks like this :
Oct 08 17:13:13 richter-xps-13 kernel: [drm] GPU HANG: ecode 9:0:0x85dffffb, in chromium [5245], reason: Hang on rcs, action: reset
Oct 08 17:13:13 richter-xps-13 kernel: drm/i915: Resetting chip after gpu hang
Oct 08 17:13:13 richter-xps-13 kernel: [drm] RC6 on
Oct 08 17:13:13 richter-xps-13 kernel: [drm] GuC submission enabled (firmware i915/kbl_guc_ver9_14.bin [version 9.14])
Oct 08 17:13:34 richter-xps-13 kernel: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun


This seems specific to chromium-vaapi, when playing a video everything freezes while the sound is playing then comes the reset and the video catches up to the sound by going in fast forward (all missed frames are played back at once it seems).
Comment 7 Philipp Richter 2017-10-08 15:39:43 UTC
So going back to mesa-17.1.8 makes the problem disappear. No hangs, normal video playback. Looks like a regression.
Comment 8 Kenneth Graunke 2017-10-08 21:10:27 UTC
(In reply to Philipp Richter from comment #7)
> So going back to mesa-17.1.8 makes the problem disappear. No hangs, normal
> video playback. Looks like a regression.

Philipp, your bug is https://bugs.freedesktop.org/show_bug.cgi?id=102774 - this one is about Ironlake.
Comment 9 Philipp Richter 2017-10-08 21:44:30 UTC
(In reply to Kenneth Graunke from comment #8)
> (In reply to Philipp Richter from comment #7)
> > So going back to mesa-17.1.8 makes the problem disappear. No hangs, normal
> > video playback. Looks like a regression.
> 
> Philipp, your bug is https://bugs.freedesktop.org/show_bug.cgi?id=102774 -
> this one is about Ironlake.

Oh, sorry for that you're absolutely right. Thank you for the patch now I can use chromium with 17.2.2.
Comment 10 nanericwang 2017-11-21 16:26:52 UTC
Created attachment 135637 [details]
GPU crash dump saved to /sys/class/drm/card0/error

Here is the GPU crash dump. Hopefully it helps.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.