Bug 103004 - [CI] igt@kms_flip@plain-flip-ts-check-interruptible - Failed assertion: es->current_seq == es->last_seq + o->seq_step
Summary: [CI] igt@kms_flip@plain-flip-ts-check-interruptible - Failed assertion: es->c...
Status: CLOSED DUPLICATE of bug 100368
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-27 06:26 UTC by Marta Löfstedt
Modified: 2018-09-25 11:25 UTC (History)
1 user (show)

See Also:
i915 platform: CFL, HSW
i915 features: display/Other


Attachments
kernel log (2.59 MB, text/plain)
2018-01-12 22:34 UTC, Hector Velazquez
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2017-09-27 06:26:42 UTC
On CI_DRM_3140 igt@kms_flip@plain-flip-ts-check-interruptible failed on HSW-shard

(kms_flip:1709) CRITICAL: Test assertion failure function check_state, file kms_flip.c:536:
(kms_flip:1709) CRITICAL: Failed assertion: es->current_seq == es->last_seq + o->seq_step
(kms_flip:1709) CRITICAL: Last errno: 4, Interrupted system call
(kms_flip:1709) CRITICAL: unexpected flip seq 597, expected 596
Subtest plain-flip-ts-check-interruptible failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3140/shard-hsw4/igt@kms_flip@plain-flip-ts-check-interruptible.html
Comment 1 Hector Velazquez 2018-01-12 22:33:59 UTC
This test has failed on CFL QA 

Tests List:

igt@kms_flip@2x-plain-flip-ts-check-interruptible

======================================
        output sample
======================================
. . .
(kms_flip:1909) CRITICAL: Test assertion failure function check_state, file kms_flip.c:536:
(kms_flip:1909) CRITICAL: Failed assertion: es->current_seq == es->last_seq + o->seq_step
(kms_flip:1909) CRITICAL: Last errno: 4, Interrupted system call
(kms_flip:1909) CRITICAL: unexpected flip seq 3656, expected 3654
Subtest 2x-plain-flip-ts-check-interruptible failed.
. . .

This is my configuration:
======================================
	     Software
======================================
IGT-Version: 1.20-gb64c093 (x86_64) (Linux: 4.15.0-rc7-drm-tip-ww2-commit-fcf7fdf+ x86_64)
Comment 2 Hector Velazquez 2018-01-12 22:34:22 UTC
Created attachment 136702 [details]
kernel log
Comment 3 Octavio 2018-03-14 22:12:16 UTC
This test fails on CFL QA 

igt@kms_flip@plain-flip-ts-check-interruptible
	
IGT-Version: 1.22-g1bb3995 (x86_64) (Linux: 4.16.0-rc5-drm-intel-qa-ww11-commit-307515c+ x86_64)

(kms_flip:1746) CRITICAL: Test assertion failure function check_state, file kms_flip.c:535:
(kms_flip:1746) CRITICAL: Failed assertion: es->current_seq == es->last_seq + o->seq_step
(kms_flip:1746) CRITICAL: Last errno: 4, Interrupted system call
(kms_flip:1746) CRITICAL: unexpected flip seq 1660, expected 1658
Subtest 2x-plain-flip-ts-check-interruptible failed.
Comment 4 Lakshmi 2018-09-25 11:25:39 UTC

*** This bug has been marked as a duplicate of bug 100368 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.