Bug 103008 - [OpenGL CTS] [HSW] KHR-GL45.texture_swizzle.functional
Summary: [OpenGL CTS] [HSW] KHR-GL45.texture_swizzle.functional
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 102590
  Show dependency treegraph
 
Reported: 2017-09-27 07:47 UTC by Kenneth Graunke
Modified: 2018-05-04 20:14 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Graunke 2017-09-27 07:47:35 UTC
KHR-GL45.texture_swizzle.functional fails on Haswell, some kind of FBO incompleteness issue.
Comment 1 Andrés Gómez García 2018-05-04 08:02:30 UTC
I'm unable to reproduce with current mesa master:

9a21c96126d ("egl/x11: Send invalidate to driver on copy_region path in swap_buffer")

I'm also unable to reproduce with mesa-18.0.2

d38da7bd2d4 ("docs: add release notes for 18.0.2")


Tested with HSW in Debian. System specs:

linux-image-4.9.0-6-amd64 4.9.88-1
libdrm-intel1:amd64 2.4.74-1
xserver-xorg 1:7.7+19
xserver-xorg-core 2:1.19.2-1+deb9u2
xserver-xorg-video-intel 2:2.99.917+git20161206-1

Kenneth, should we close this bug?
Comment 2 Mark Janes 2018-05-04 18:24:22 UTC
I can't find this test in the GL46 test suite.
Comment 3 Andrés Gómez García 2018-05-04 19:34:49 UTC
(In reply to Mark Janes from comment #2)
> I can't find this test in the GL46 test suite.

I can see KHR-GL46.texture_swizzle.functional in the mustpass file and I have the "PASS" result on the runs with different configurations using the cts-runner.
Comment 4 Mark Janes 2018-05-04 20:14:53 UTC
Ah, found it.

Texture swizzle tests were disabled except on daily builds, because they were so slow.

The test pases, as you reported.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.