Bug 103020 - [BAT] *ERROR* Atomic update failure on pipe B
Summary: [BAT] *ERROR* Atomic update failure on pipe B
Status: CLOSED DUPLICATE of bug 102403
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-28 08:13 UTC by Jani Saarinen
Modified: 2017-10-11 15:52 UTC (History)
1 user (show)

See Also:
i915 platform: BXT
i915 features: display/atomic


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jani Saarinen 2017-09-28 08:13:40 UTC
On CI running igt@kms_busy@basic-flip-b caused Atomic update failure on pipe B.
Some connection to bug seen previously (102403) but will make own now to not re-open whole issue again. 

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3146/fi-bxt-dsi/igt@kms_busy@basic-flip-b.html


Out	
IGT-Version: 1.19-g2885b10f (x86_64) (Linux: 4.14.0-rc2-CI-CI_DRM_3146+ x86_64)
Subtest basic-flip-B: SUCCESS (0.911s)
Test requirement not met in function __real_main311, file kms_busy.c:337:
Test requirement: !(n >= display.n_pipes)
Environment	
PIGLIT_SOURCE_DIR="/opt/igt/piglit" PIGLIT_PLATFORM="mixed_glx_egl"

Command	
/opt/igt/libexec/intel-gpu-tools/kms_busy --run-subtest basic-flip-B

Dmesg	
[  335.676578] Setting dangerous option reset - tainting kernel
[  336.201819] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe B (start=23 end=24) time 104 us, min 1192, max 1199, scanline start 1191, end 1202
[  336.588555] Setting dangerous option reset - tainting kernel
Comment 1 Vidya Srinivas 2017-10-05 09:44:45 UTC
We tried to reproduce this issue on the latest drm tip (top of tree).
Details below:

top commit
commit 247cb84af034b8e90ecd22cd69adb13a7a305350
Author: Jani Nikula <jani.nikula@intel.com>
Date:   Thu Oct 5 09:44:50 2017 +0300

    drm-tip: 2017y-10m-05d-06h-44m-09s UTC integration manifest

uname -a:
Linux intel-desktop 4.14.0-rc3+ #1 SMP Thu Oct 5 14:07:27 IST 2017 x86_64 x86_64 x86_64 GNU/Linux

We executed the test kms_busy (mentioned in the bug) for around 25 iterations and we were not able to reproduce the issue.

Can someone please reconfirm if this issue exists on the top of tree?
Comment 2 Marta Löfstedt 2017-10-10 13:19:06 UTC

*** This bug has been marked as a duplicate of bug 102403 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.