Bug 103149 - kernel: Touchpad two finger scroll broken after update to fedora 26
Summary: kernel: Touchpad two finger scroll broken after update to fedora 26
Status: RESOLVED NOTOURBUG
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-08 17:22 UTC by JanUlrich
Modified: 2018-04-04 02:19 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
evemu recording of two finger upscroll (37.71 KB, text/plain)
2017-10-08 17:22 UTC, JanUlrich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JanUlrich 2017-10-08 17:22:23 UTC
Created attachment 134751 [details]
evemu recording of two finger upscroll

I recently updated to Fedora 26 and now the two finger scroll of my touchpad does not work anymore.

I use a Lenovo Thinkpad T440s

libinput --version :
1.8.2

Output of xinput list-props "SynPS/2 Synaptics TouchPad":
Device 'SynPS/2 Synaptics TouchPad':
	Device Enabled (141):	1
	Coordinate Transformation Matrix (143):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (279):	0
	libinput Tapping Enabled Default (280):	0
	libinput Tapping Drag Enabled (281):	1
	libinput Tapping Drag Enabled Default (282):	1
	libinput Tapping Drag Lock Enabled (283):	0
	libinput Tapping Drag Lock Enabled Default (284):	0
	libinput Tapping Button Mapping Enabled (285):	1, 0
	libinput Tapping Button Mapping Default (286):	1, 0
	libinput Natural Scrolling Enabled (287):	0
	libinput Natural Scrolling Enabled Default (288):	0
	libinput Left Handed Enabled (289):	0
	libinput Left Handed Enabled Default (290):	0
	libinput Accel Speed (291):	0.000000
	libinput Accel Speed Default (292):	0.000000
	libinput Scroll Methods Available (293):	1, 1, 0
	libinput Scroll Method Enabled (294):	1, 0, 0
	libinput Scroll Method Enabled Default (295):	1, 0, 0
	libinput Click Methods Available (296):	1, 1
	libinput Click Method Enabled (297):	1, 0
	libinput Click Method Enabled Default (298):	1, 0
	libinput Middle Emulation Enabled (299):	0
	libinput Middle Emulation Enabled Default (300):	0
	libinput Send Events Modes Available (264):	1, 1
	libinput Send Events Mode Enabled (265):	0, 0
	libinput Send Events Mode Enabled Default (266):	0, 0
	libinput Disable While Typing Enabled (301):	1
	libinput Disable While Typing Enabled Default (302):	1
	Device Node (267):	"/dev/input/event15"
	Device Product ID (268):	2, 7
	libinput Drag Lock Buttons (303):	<no items>
	libinput Horizontal Scroll Enabled (304):	1

Output of udevadm info:
P: /devices/platform/i8042/serio1/input/input9/event15
N: input/event15
E: DEVNAME=/dev/input/event15
E: DEVPATH=/devices/platform/i8042/serio1/input/input9/event15
E: EVDEV_ABS_00=::41
E: EVDEV_ABS_01=::37
E: EVDEV_ABS_35=::41
E: EVDEV_ABS_36=::37
E: ID_BUS=i8042
E: ID_INPUT=1
E: ID_INPUT_HEIGHT_MM=66
E: ID_INPUT_TOUCHPAD=1
E: ID_INPUT_TOUCHPAD_INTEGRATION=internal
E: ID_INPUT_WIDTH_MM=97
E: LIBINPUT_DEVICE_GROUP=11/2/7/1b1:isa0060/serio1
E: LIBINPUT_MODEL_SYNAPTICS_SERIAL_TOUCHPAD=1
E: MAJOR=13
E: MINOR=79
E: SUBSYSTEM=input
E: USEC_INITIALIZED=5076372

Content of /sys/class/dmi/id/modalias :
dmi:bvnLENOVO:bvrGJET75WW(2.25):bd03/28/2014:svnLENOVO:pn20ARS1NW00:pvrThinkPadT440s:rvnLENOVO:rn20ARS1NW00:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNotAvailable:


and attached is a evemu recording of an attempted two finger scroll.
I just put two fingers on the touchpad and move them upwards. On Fedora 25 this triggered a upscroll.
Comment 1 Peter Hutterer 2017-10-08 20:42:23 UTC
This appears to be a kernel bug. There are two fingers on the touchpad, but only one finger moves. The second is perfectly still but that's almost impossible to do (and you indicated that you moved both upwards). Can you try a different (older?) kernel version to figure out what version introduced the bug?
Comment 2 JanUlrich 2017-10-09 18:30:49 UTC
I use kernel version 4.13.4-200.fc26.x86_64

when i reboot the two finger scroll works at first.

But after my laptop was in suspend mode (i closed the laptop lid)
the two finger scroll does not work anymore.
Comment 3 Peter Hutterer 2017-10-10 01:54:27 UTC
That's a kernel bug, I'm seeing this one locally too, somehow the finger count is off after suspend. For some reason I can't find the real bug number for this one now though
Comment 4 Martin Jørgensen 2017-10-25 21:06:22 UTC
I'm experiencing the same issue as JanUlirich on my Thinkpad X1 Carbon running Debian buster/sid, libinput 1.8.2 and linux 4.13.0-7.2-liquorix-amd64.

After returning from suspend my two-finger scroll stops working.
Comment 5 thorstenr_42 2017-10-29 17:59:29 UTC
Hi, i noticed this bug on ubuntu (see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1722478)

i tested some kernels and 4.11.12 was the last version where this was working. 4.12-rc1 introduced the bug. (i am also using a t440s)
Comment 6 Daniel Moraes 2017-11-10 05:56:23 UTC
I can confirm this bug on my thinkpad t440 running fedora 25.
Kernel version 4.13.11-200.fc26.x86_64.
Two-finger scroll and right click with two fingers tap stop working after suspend, but oddly you can scroll with three fingers.
Comment 7 Daniel Moraes 2017-11-15 03:57:02 UTC
Everyone having this problem on the thinkpad, check the bios to see if the trackpad is enabled ! I did some tests, if you disable the trackpad on bios, it will work anyways until you suspend.

On kernel 4.13.11-200 after the suspend, the trackpad would work, but not two finger scroll.

After updating fedora trough dnf, on kernel 4.13.12-200, with the trackpad disabled on bios everything works until you suspend, then the trackpad is completely disabled !
Comment 8 thorstenr_42 2017-11-17 09:03:32 UTC
this a kernel bug and is not caused by the bios: https://bugzilla.kernel.org/show_bug.cgi?id=196719

bisecting resulted that e839ffab028981ac77f650faf8c84f16e1719738 is the first bad commit (see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1722478 )

by setting the kernel parameter psmouse.synaptics_intertouch=0 the bug can be temporary circumvented
Comment 9 JanUlrich 2017-11-24 05:20:36 UTC
The bug seems to be solved in kernel version 4.13.10-200

but now that i upgraded my fedora to kernel 4.13.13 the problem resurfaced.
After a suspend the scrolling with the touchpad stops working.
Comment 10 Daniel Moraes 2017-12-28 03:24:31 UTC
(In reply to thorstenr_42 from comment #8)
> this a kernel bug and is not caused by the bios:
> https://bugzilla.kernel.org/show_bug.cgi?id=196719
> 
> bisecting resulted that e839ffab028981ac77f650faf8c84f16e1719738 is the
> first bad commit (see
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1722478 )
> 
> by setting the kernel parameter psmouse.synaptics_intertouch=0 the bug can
> be temporary circumvented

As sugested by you in the ubuntu launchpad, adding the parameter 'psmouse.synaptics_intertouch=0' to /etc/default/grub works perfectly !

In my case on fedora 27 I had to update grub with:
sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg instead of sudo update-grub

Tks for the temporary fix!
Comment 11 Gwendal 2018-01-18 13:35:54 UTC
Same problem here with 4.14.13-300.fc27.x86_64: no more touchpad scrolling when I resume after a suspend.
Comment 12 Steven Ellis 2018-02-15 19:01:19 UTC
I've got the same issue under Fedora 27 on a T440s

libinput --version 
1.9.4


xinput list-props "SynPS/2 Synaptics TouchPad":
unable to find device SynPS/2 Synaptics TouchPad:
[root@t440s ~]# xinput list-props "SynPS/2 Synaptics TouchPad"
Device 'SynPS/2 Synaptics TouchPad':
	Device Enabled (141):	1
	Coordinate Transformation Matrix (143):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (278):	0
	libinput Tapping Enabled Default (279):	0
	libinput Tapping Drag Enabled (280):	1
	libinput Tapping Drag Enabled Default (281):	1
	libinput Tapping Drag Lock Enabled (282):	0
	libinput Tapping Drag Lock Enabled Default (283):	0
	libinput Tapping Button Mapping Enabled (284):	1, 0
	libinput Tapping Button Mapping Default (285):	1, 0
	libinput Natural Scrolling Enabled (286):	0
	libinput Natural Scrolling Enabled Default (287):	0
	libinput Left Handed Enabled (288):	0
	libinput Left Handed Enabled Default (289):	0
	libinput Accel Speed (290):	0.000000
	libinput Accel Speed Default (291):	0.000000
	libinput Scroll Methods Available (292):	1, 1, 0
	libinput Scroll Method Enabled (293):	1, 0, 0
	libinput Scroll Method Enabled Default (294):	1, 0, 0
	libinput Click Methods Available (295):	1, 1
	libinput Click Method Enabled (296):	0, 1
	libinput Click Method Enabled Default (297):	1, 0
	libinput Middle Emulation Enabled (298):	0
	libinput Middle Emulation Enabled Default (299):	0
	libinput Send Events Modes Available (263):	1, 1
	libinput Send Events Mode Enabled (264):	0, 0
	libinput Send Events Mode Enabled Default (265):	0, 0
	libinput Disable While Typing Enabled (300):	1
	libinput Disable While Typing Enabled Default (301):	1
	Device Node (266):	"/dev/input/event16"
	Device Product ID (267):	2, 7
	libinput Drag Lock Buttons (302):	<no items>
	libinput Horizontal Scroll Enabled (303):	1
Comment 13 Peter Hutterer 2018-04-04 02:19:06 UTC
Closing this one, it's a kernel bug, no point keeping it open here just to attract more "me too" comments. We cannot fix this in libinput and the workaround for the kernel is to disable RMI4 via the 'psmouse.synaptics_intertouch=0' kernel parameter.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.