Bug 103152 - Mesa 17.2 cannot be built on ARM with GCC 7.2
Summary: Mesa 17.2 cannot be built on ARM with GCC 7.2
Status: RESOLVED WONTFIX
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: 17.2
Hardware: ARM Linux (All)
: high normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-09 00:35 UTC by Icenowy Zheng
Modified: 2019-05-07 02:37 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Icenowy Zheng 2017-10-09 00:35:28 UTC
In the Mesa configure.ac, it will use -std=c99 when GCC >= 4.6, however the unwind implementation on ARM uses some GNU extensions, which won't build with -std=c99 at least on GCC 7.x .


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.