Bug 103158 - [CI] igt@gem_exec_schedule@pi-ringfull-[blt|bsd*|default|render|vebox] - Test assertion failure function test_pi_ringfull
Summary: [CI] igt@gem_exec_schedule@pi-ringfull-[blt|bsd*|default|render|vebox] - Test...
Status: CLOSED WONTFIX
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords: bisected
: 103803 104483 104869 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-09 09:55 UTC by Marta Löfstedt
Modified: 2018-10-22 15:22 UTC (History)
4 users (show)

See Also:
i915 platform: BXT, CNL, GLK, KBL
i915 features: GEM/Other


Attachments
output (all reported subtests) (32.58 KB, text/plain)
2017-12-13 21:27 UTC, Hector Velazquez
no flags Details
kernel log (1.97 MB, text/plain)
2017-12-13 21:27 UTC, Hector Velazquez
no flags Details
dmesg (456.19 KB, text/plain)
2017-12-13 21:28 UTC, Hector Velazquez
no flags Details
attachment-26880-0.html (2.57 KB, text/html)
2018-03-12 10:57 UTC, Ricardo Perez
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2017-10-09 09:55:25 UTC
From CI_DRM_3175 APL- and KBL-shards.

Various igt@gem_exec_schedule@pi-ringfull-*

(gem_exec_schedule:1454) CRITICAL: Test assertion failure function test_pi_ringfull, file gem_exec_schedule.c:897:
(gem_exec_schedule:1454) CRITICAL: Failed assertion: result[2]
(gem_exec_schedule:1454) CRITICAL: Last errno: 4, Interrupted system call
(gem_exec_schedule:1454) CRITICAL: High priority child unable to submit within 10ms


examples:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3175/shard-apl3/igt@gem_exec_schedule@pi-ringfull-blt.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3190/shard-apl8/igt@gem_exec_schedule@pi-ringfull-bsd.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3190/shard-kbl1/igt@gem_exec_schedule@pi-ringfull-blt.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3190/shard-apl7/igt@gem_exec_schedule@pi-ringfull-blt.html
Comment 1 Chris Wilson 2017-10-09 10:00:23 UTC
Expected pi from struct_mutex, not going to be fixed in the near future. Unless someone has a driver rewrite ready.
Comment 2 Marta Löfstedt 2017-10-18 11:28:36 UTC
Also, GLK-shards:

example faiL:
(gem_exec_schedule:1633) CRITICAL: Test assertion failure function test_pi_ringfull, file gem_exec_schedule.c:940:
(gem_exec_schedule:1633) CRITICAL: Failed assertion: result[2]
(gem_exec_schedule:1633) CRITICAL: Last errno: 4, Interrupted system call
(gem_exec_schedule:1633) CRITICAL: High priority child unable to submit within 10ms
Subtest pi-ringfull-vebox failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3255/shard-glkb4/igt@gem_exec_schedule@pi-ringfull-vebox.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3255/shard-glkb4/igt@gem_exec_schedule@pi-ringfull-blt.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3255/shard-glkb5/igt@gem_exec_schedule@pi-ringfull-default.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3255/shard-glkb2/igt@gem_exec_schedule@pi-ringfull-bsd.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3255/shard-glkb5/igt@gem_exec_schedule@pi-ringfull-render.html
Comment 3 Elizabeth 2017-10-19 15:24:08 UTC
Quick note: Hello, I tried to do bisection with CI_DRM_3175 (when it changed from skip to fail) with ezbench, and I got the commit ac14fbd460d0ec16e7750e40dcd8199b0ff83d0a as the bad one. In case this is from any help...
Comment 4 Daniel Vetter 2017-11-08 09:07:21 UTC
Marta, can we somehow annotate this as WONTFIX in cibuglog? There's some other cases like this one here ...
Comment 5 Daniel Vetter 2017-11-08 10:13:37 UTC
Mark as wontfix (for now at least), while still tracking it in cibuglog.
Comment 6 Chris Wilson 2017-11-17 22:27:19 UTC
*** Bug 103803 has been marked as a duplicate of this bug. ***
Comment 7 Hector Velazquez 2017-12-13 21:23:04 UTC
This test are failing on CNL QA

igt@gem_exec_schedule@pi-ringfull-blt
igt@gem_exec_schedule@pi-ringfull-bsd
igt@gem_exec_schedule@pi-ringfull-default
igt@gem_exec_schedule@pi-ringfull-render
igt@gem_exec_schedule@pi-ringfull-vebox

using IGT-Version: 1.20-g7440741 (x86_64) (Linux: 4.15.0-rc3-drm-tip-ww50-commit-62d9383+ x86_64)
intel-gpu-tools commit: 74407418720ff7a9de7caabec05d4c3afe9a5c51

(gem_exec_schedule:2022) CRITICAL: Test assertion failure function test_pi_ringfull, file gem_exec_schedule.c:982:
(gem_exec_schedule:2022) CRITICAL: Failed assertion: result[2]
(gem_exec_schedule:2022) CRITICAL: Last errno: 4, Interrupted system call
(gem_exec_schedule:2022) CRITICAL: High priority child unable to submit within 10ms
Subtest pi-ringfull-blt failed.
Comment 8 Hector Velazquez 2017-12-13 21:27:35 UTC
Created attachment 136154 [details]
output (all reported subtests)
Comment 9 Hector Velazquez 2017-12-13 21:27:51 UTC
Created attachment 136155 [details]
kernel log
Comment 10 Hector Velazquez 2017-12-13 21:28:38 UTC
Created attachment 136156 [details]
dmesg
Comment 11 Chris Wilson 2018-01-04 09:21:43 UTC
*** Bug 104483 has been marked as a duplicate of this bug. ***
Comment 12 Ricardo Perez 2018-01-29 19:56:52 UTC
For CoffeeLake S UDIMM RVP QA systems,

Using:

IGT-Version: 1.21-g37bd27f (x86_64) (Linux: 4.15.0-rc9-drm-intel-qa-ww4-commit-59275f1+ x86_64)
Using GuC submission

The following tests are failing:

igt@gem_exec_schedule@pi-ringfull-blt
igt@gem_exec_schedule@pi-ringfull-bsd
igt@gem_exec_schedule@pi-ringfull-default
igt@gem_exec_schedule@pi-ringfull-render

For igt@gem_exec_schedule@pi-ringfull-*

**** DEBUG ****
(gem_exec_schedule:25628) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_exec_schedule:25628) DEBUG: Filled low-priority ring with 199 batches
(gem_exec_schedule:25628) DEBUG: LP parent executing
(gem_exec_schedule:25628) CRITICAL: Test assertion failure function test_pi_ringfull, file gem_exec_schedule.c:982:
(gem_exec_schedule:25628) CRITICAL: Failed assertion: result[2]
(gem_exec_schedule:25628) CRITICAL: Last errno: 4, Interrupted system call
(gem_exec_schedule:25628) CRITICAL: High priority child unable to submit within 10ms
(gem_exec_schedule:25628) igt-core-INFO: Stack trace:
(gem_exec_schedule:25628) igt-core-INFO:   #0 [__igt_fail_assert+0x101]
(gem_exec_schedule:25628) igt-core-INFO:   #1 [__real_main993+0x2716]
(gem_exec_schedule:25628) igt-core-INFO:   #2 [main+0x27]
(gem_exec_schedule:25628) igt-core-INFO:   #3 [__libc_start_main+0xf1]
(gem_exec_schedule:25628) igt-core-INFO:   #4 [_start+0x2a]
(gem_exec_schedule:25628) igt-core-INFO:   #5 [<unknown>+0x2a]
****  END  ****


**** DEBUG ****
(gem_exec_schedule:26741) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_exec_schedule:26741) DEBUG: Filled low-priority ring with 199 batches
(gem_exec_schedule:26741) DEBUG: LP parent executing
(gem_exec_schedule:26741) CRITICAL: Test assertion failure function test_pi_ringfull, file gem_exec_schedule.c:982:
(gem_exec_schedule:26741) CRITICAL: Failed assertion: result[2]
(gem_exec_schedule:26741) CRITICAL: Last errno: 4, Interrupted system call
(gem_exec_schedule:26741) CRITICAL: High priority child unable to submit within 10ms
(gem_exec_schedule:26741) igt-core-INFO: Stack trace:
(gem_exec_schedule:26741) igt-core-INFO:   #0 [__igt_fail_assert+0x101]
(gem_exec_schedule:26741) igt-core-INFO:   #1 [__real_main993+0x2716]
(gem_exec_schedule:26741) igt-core-INFO:   #2 [main+0x27]
(gem_exec_schedule:26741) igt-core-INFO:   #3 [__libc_start_main+0xf1]
(gem_exec_schedule:26741) igt-core-INFO:   #4 [_start+0x2a]
(gem_exec_schedule:26741) igt-core-INFO:   #5 [<unknown>+0x2a]
****  END  ****
Comment 13 Chris Wilson 2018-01-31 08:29:55 UTC
*** Bug 104869 has been marked as a duplicate of this bug. ***
Comment 14 Marta Löfstedt 2018-03-12 10:56:46 UTC
Here is data from full runs on CFL and CNL:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-8700k/igt@gem_exec_schedule@pi-ringfull-vebox.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-s2/igt@gem_exec_schedule@pi-ringfull-vebox.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-u/igt@gem_exec_schedule@pi-ringfull-vebox.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-drrs/igt@gem_exec_schedule@pi-ringfull-vebox.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-y3/igt@gem_exec_schedule@pi-ringfull-vebox.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-8700k/igt@gem_exec_schedule@pi-ringfull-render.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-s2/igt@gem_exec_schedule@pi-ringfull-render.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-u/igt@gem_exec_schedule@pi-ringfull-render.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-drrs/igt@gem_exec_schedule@pi-ringfull-render.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-y3/igt@gem_exec_schedule@pi-ringfull-render.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-8700k/igt@gem_exec_schedule@pi-ringfull-bsd.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-s2/igt@gem_exec_schedule@pi-ringfull-bsd.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-drrs/igt@gem_exec_schedule@pi-ringfull-bsd.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-y3/igt@gem_exec_schedule@pi-ringfull-bsd.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-8700k/igt@gem_exec_schedule@pi-ringfull-blt.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-s2/igt@gem_exec_schedule@pi-ringfull-blt.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cfl-u/igt@gem_exec_schedule@pi-ringfull-blt.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-drrs/igt@gem_exec_schedule@pi-ringfull-blt.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-y3/igt@gem_exec_schedule@pi-ringfull-blt.html
Comment 15 Ricardo Perez 2018-03-12 10:57:03 UTC
Created attachment 138015 [details]
attachment-26880-0.html

Hi Team,

I’ll be OoO 3/12/2018. Starting from today, I’m attending a family emergency, so I’ll be OoO.

See you in the office 3/13/2018.

If you need something from me that can't wait, please contact my manager: Vega, Ricardo.


Regards
-Richo
Comment 16 Marta Löfstedt 2018-03-16 06:43:14 UTC
A lot more machines coming in after we started running the shard testlist on the BAT machines. 

The full impact is visible through cibuglog or:
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip.html

Here are some random links:
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-bxt-dsi/igt@gem_exec_schedule@pi-ringfull-vebox.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-glk-1/igt@gem_exec_schedule@pi-ringfull-vebox.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-kbl-7500u/igt@gem_exec_schedule@pi-ringfull-render.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-kbl-7567u/igt@gem_exec_schedule@pi-ringfull-render.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-6770hq/igt@gem_exec_schedule@pi-ringfull-bsd2.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-gvtdvm/igt@gem_exec_schedule@pi-ringfull-bsd2.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-kbl-7567u/igt@gem_exec_schedule@pi-ringfull-bsd1.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-6260u/igt@gem_exec_schedule@pi-ringfull-bsd1.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-6700hq/igt@gem_exec_schedule@pi-ringfull-bsd.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-6700k2/igt@gem_exec_schedule@pi-ringfull-bsd.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-6700k2/igt@gem_exec_schedule@pi-ringfull-blt.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-6770hq/igt@gem_exec_schedule@pi-ringfull-blt.html
Comment 19 Jani Saarinen 2018-10-22 15:22:12 UTC
HI,
Why this is wontfix? Daniel, Chris?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.