Bug 103217 - Recent noveau causes errors with scilab 5.5.2 on NVIDIA G84GL [Quadro FX 570]
Summary: Recent noveau causes errors with scilab 5.5.2 on NVIDIA G84GL [Quadro FX 570]
Status: RESOLVED DUPLICATE of bug 103078
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/nouveau (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Nouveau Project
QA Contact: Nouveau Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-11 11:29 UTC by sergio.callegari
Modified: 2019-09-19 09:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2017-10-11 11:29:18 UTC
With git tip (as of today - 11 Sept 2017) launching scilab I get

javax.media.opengl.GLException: X11GLXDrawableFactory - Could not initialize shared resources for :0
        at jogamp.opengl.x11.glx.X11GLXDrawableFactory$SharedResourceImplementation.createSharedResource(X11GLXDrawableFactory.java:317)
        at jogamp.opengl.SharedResourceRunner.run(SharedResourceRunner.java:295)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
        at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:625)
        at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:539)
        at jogamp.opengl.x11.glx.X11GLXDrawableFactory$SharedResourceImplementation.createSharedResource(X11GLXDrawableFactory.java:293)
        ... 2 more

Almost sure, it used to work up to a few days ago.
Scilab works fine with LIBGL_ALWAYS_SOFTWARE=1
Comment 1 Ilia Mirkin 2017-10-11 13:10:41 UTC
So ... what changed since a few days ago?

Find a version of mesa that works and bisect?
Comment 2 sergio.callegari 2017-10-11 13:38:02 UTC
Contrary to what I have just said, scilab does not work anymore with LLVMPIPE either, aka LIBGL_ALWAYS_SOFTWARE=1.

Almost impossible for me to bisect, since this machine is shared by multiple users.  Currently, the machine is on git version of drivers only thanks to the fact that there is a PPA for up to date drivers on ubuntu.  Unfortunately, PPAs do not make easy to downgrade to previous versions of packages on the same PPA.
Comment 3 Ilia Mirkin 2017-10-11 13:40:51 UTC
So it sounds like an issue not related to nouveau then?
Comment 4 sergio.callegari 2017-10-11 14:03:33 UTC
May be related, may be two independent issues. The way in which the issue triggers is different:

- with nouveau, scilab complains at start up
- with llvmpipe, scilab does not complain at start up but throws java exception as soon as you try to make a plot.

The two have in common some infrastructure code, I guess, so the issue may lay there. Having both nouveau and the software rendering broken for this usage case at the same time is a bit unfortunate.
Comment 5 Ilia Mirkin 2017-10-11 14:04:55 UTC
Is scilab an application that I can run myself? If not, you're probably on your own.
Comment 6 sergio.callegari 2017-10-11 15:56:02 UTC
Yes, it is. It is free software. You can download it at www.scilab.org. Please, take version 5.5.2 (http://www.scilab.org/en/download/previous) since the latest version (6) is young and has some problems on its own.

Once you have downloaded it, just unpack it in some dir. Then,

1) try simply starting. There is a bin dir, with the scilab executable in in.
With nouveau on my hardware I already get issues at this point.

2) If it starts, you get an application window which may include multiple panels ( I do not remember if on a fresh install you have multiple panels or just one). One of the panels is the Scilab Console. In it write
plot([0 0], [1 1])
and see what happens.
Most likely, you will get an empty plot and a java exception.
Comment 7 Timo Aaltonen 2018-01-12 22:11:09 UTC

*** This bug has been marked as a duplicate of bug 103078 ***
Comment 8 Ruby Windler 2019-08-01 12:22:04 UTC Comment hidden (spam)
Comment 9 jaimeallen2019@gmail.com (Spammer; Account disabled) 2019-08-30 06:29:17 UTC Comment hidden (spam)
Comment 10 sarataylor 2019-09-16 13:04:09 UTC
After years of not sleeping well and not finding the right guide for natural products online, she decided to do the research so others don’t suffer when buying a new mattress as she did. For the past 3 years, she studied everything about sleep and natural product to put the best natural mattress buying guide online.

https://topnaturalmattresses.com/best-mattress-for-stomach-sleepers/#
Comment 11 sarataylor 2019-09-19 09:22:45 UTC
To complement your foam mattress checkoff list, we even added a few things that you might want to get with it.We hope you find this the most comprehensive guide about memory foam mattresses and that it helps you acquire the best memory foam mattress.

https://topnaturalmattresses.com/best-memory-foam-mattress/


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.