Bug 103257 - [CI][BAT] igt@kms_flip@(2x-)busy-flip(-interruptible) - Failed assertion: !(*v & flag)
Summary: [CI][BAT] igt@kms_flip@(2x-)busy-flip(-interruptible) - Failed assertion: !(...
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-13 11:19 UTC by Marta Löfstedt
Modified: 2019-04-11 10:34 UTC (History)
3 users (show)

See Also:
i915 platform: ALL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2017-10-13 11:19:40 UTC
CI_DRM_3227 APL-shards igt@kms_flip@busy-flip-interruptible fail:

(kms_flip:1796) CRITICAL: Test assertion failure function set_flag, file kms_flip.c:266:
(kms_flip:1796) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:1796) CRITICAL: Last errno: 4, Interrupted system call
Subtest busy-flip-interruptible failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3227/shard-apl5/igt@kms_flip@busy-flip-interruptible.html
Comment 1 Marta Löfstedt 2017-10-24 05:41:47 UTC
CI_DRM_3276 shard-apl5 igt@kms_flip@busy-flip fail:

(kms_flip:5187) CRITICAL: Test assertion failure function set_flag, file kms_flip.c:266:
(kms_flip:5187) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:5187) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest busy-flip failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3276/shard-apl5/igt@kms_flip@busy-flip.html
Comment 2 Marta Löfstedt 2017-11-08 11:15:26 UTC
Also on GLK-shards CI_DRM_3320 igt@kms_flip@busy-flip-interruptible

(kms_flip:5079) CRITICAL: Test assertion failure function set_flag, file kms_flip.c:266:
(kms_flip:5079) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:5079) CRITICAL: Last errno: 4, Interrupted system call
Subtest busy-flip-interruptible failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3320/shard-glkb1/igt@kms_flip@busy-flip-interruptible.html
Comment 3 Marta Löfstedt 2017-11-24 07:21:54 UTC
Also,
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4010/shard-hsw2/igt@kms_flip@busy-flip.html
	

(kms_flip:6629) CRITICAL: Test assertion failure function set_flag, file kms_flip.c:266:
(kms_flip:6629) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:6629) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest busy-flip failed.
Comment 4 Martin Peres 2018-01-15 19:16:52 UTC
Also seen on Kabylake:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3631/shard-kbl3/igt@kms_flip@busy-flip.html

	
(kms_flip:3875) CRITICAL: Test assertion failure function set_flag, file kms_flip.c:266:
(kms_flip:3875) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:3875) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest busy-flip failed.
Comment 5 Marta Löfstedt 2018-03-02 07:52:11 UTC
Last seen:  IGT_4209: 2018-02-01 / 242 runs ago,
Comment 6 Marta Löfstedt 2018-03-13 06:55:16 UTC
Re-opened on HSW:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3912/shard-hsw3/igt@kms_flip@busy-flip.html


(kms_flip:3324) CRITICAL: Test assertion failure function set_flag, file ../tests/kms_flip.c:265:
(kms_flip:3324) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:3324) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest busy-flip failed.
Comment 7 Marta Löfstedt 2018-03-16 08:51:08 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-gvtdvm/igt@kms_flip@busy-flip-interruptible.html

(kms_flip:1228) CRITICAL: Test assertion failure function set_flag, file ../tests/kms_flip.c:265:
(kms_flip:1228) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:1228) CRITICAL: Last errno: 4, Interrupted system call
Comment 8 Marta Löfstedt 2018-03-23 11:42:36 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3970/shard-apl3/igt@kms_flip@busy-flip.html

(kms_flip:2687) CRITICAL: Test assertion failure function set_flag, file ../tests/kms_flip.c:265:
(kms_flip:2687) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:2687) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest busy-flip failed.
Comment 9 Martin Peres 2018-04-13 11:42:30 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_8/fi-bwr-2160/igt@kms_flip@busy-flip-interruptible.html

(kms_flip:1207) CRITICAL: Test assertion failure function set_flag, file ../tests/kms_flip.c:265:
(kms_flip:1207) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:1207) CRITICAL: Last errno: 4, Interrupted system call
Subtest busy-flip-interruptible failed.
Comment 10 Martin Peres 2018-06-08 08:27:01 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_57/fi-bwr-2160/igt@kms_flip@2x-busy-flip-interruptible.html

(kms_flip:1668) CRITICAL: Test assertion failure function set_flag, file ../tests/kms_flip.c:265:
(kms_flip:1668) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:1668) CRITICAL: Last errno: 4, Interrupted system call(km
Comment 11 Martin Peres 2018-06-23 13:03:30 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_70/fi-bsw-n3050/igt@kms_flip@busy-flip.html

(kms_flip:2537) CRITICAL: Test assertion failure function set_flag, file ../tests/kms_flip.c:265:
(kms_flip:2537) CRITICAL: Failed assertion: !(*v & flag)
(kms_flip:2537) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest busy-flip failed.
Comment 12 Martin Peres 2018-10-24 11:51:53 UTC
Keeping the priority low because of the very low occurence rate
Comment 13 Nischala Yelchuri 2019-03-29 19:03:34 UTC
I haven't been able to reproduce this on ICL. 

This was last seen on SKL:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5832/shard-skl6/igt@kms_flip@busy-flip.html
Comment 14 Maarten Lankhorst 2019-04-10 11:22:48 UTC
Some fixes because this test was way too strict:

https://patchwork.freedesktop.org/series/59280/

It won't fix this bug, if the reason is that we stall longer than 16 ms, just make it less likely to occur.

This is not the goal of the test, the goal is just reducing runtime and improving test correctness.
Comment 15 Martin Peres 2019-04-11 10:34:20 UTC
(In reply to Maarten Lankhorst from comment #14)
> Some fixes because this test was way too strict:
> 
> https://patchwork.freedesktop.org/series/59280/
> 
> It won't fix this bug, if the reason is that we stall longer than 16 ms,
> just make it less likely to occur.
> 
> This is not the goal of the test, the goal is just reducing runtime and
> improving test correctness.

The series landed:
 - @busy-flip-interruptible is gone
 - The '!(*v & flag)' assertion should now not be hit anymore

I have suppressed the test, waiting for another failure to come, so as I can update the filter. But since everything changed, this bug should be closed as it is not applicable to the newer IGT.

Closing as INVALID, since we don't have OUTDATED. Thanks!
Comment 16 CI Bug Log 2019-04-11 10:34:47 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.