Bug 103299 - No audio since kernel 4.12
Summary: No audio since kernel 4.12
Status: RESOLVED NOTOURBUG
Alias: None
Product: PulseAudio
Classification: Unclassified
Component: alsa (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: pulseaudio-bugs
QA Contact: pulseaudio-bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-16 18:38 UTC by PhilS
Modified: 2017-11-03 04:42 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PhilS 2017-10-16 18:38:42 UTC
With the introduction of the 4.13 kernel, alsa audio is broken in the Intel Cherry Trail SOC.

This has been evident in the Millhouse builds of Librelec since release #0913.

A post from harry (harryharryharry) on Archlinux, where he stated that by reversing a commit, sound was restored.

https://bugs.archlinux.org/task/55592

Millhouse then built a one off release of Libreelec #1016c, I confirmed that the reversal of the commit did restore audio functionality.

https://forum.kodi.tv/showthread.php?tid=298462&pid=2656063#pid2656063

Thanks to harry and Millhouse for the information and build to confirm the issue(s).
Comment 1 PhilS 2017-10-17 16:12:31 UTC
Just realised an slight error in the description.

#0913 should have read #0903.
Comment 2 Tanu Kaskinen 2017-10-20 19:37:28 UTC
This is a known issue (bug 100488) that is being fixed. To make this sound card work, you need to apply a patch for alsa-lib and patches for pulseaudio.

alsa-lib:
http://git.alsa-project.org/?p=alsa-lib.git;a=commit;h=996dd33b5f0df06d0b1fdd8f43b7a212c26e2a27

pulseaudio:
https://patchwork.freedesktop.org/series/31556/

*** This bug has been marked as a duplicate of bug 100488 ***
Comment 3 freedesktop 2017-11-02 18:04:14 UTC
This bug has nothing to do with PulseAudio and should not have been closed as a duplicate.
Comment 4 Tanu Kaskinen 2017-11-02 18:26:37 UTC
Closing as "notourbug" then.
Comment 5 freedesktop 2017-11-02 19:22:52 UTC
> Closing as "notourbug" then.

Well pardon me for saying that seems like a bit of a dick move, considering I'm the developer (Milhouse) providing Phils with the builds that exhibit this issue, and you've already made the mistake of closing this genuine bug once so yeah, why not double down?
Comment 6 freedesktop 2017-11-02 19:32:15 UTC
If the "notyourbug" applies to the incorrect Product, ie. PulseAudio (rather than me!) then I apologise for responding so quickly as I agree that is incorrect (I guess it was chosen as being being the only audio-related Product).

What might be an idea is advise the OP on where this should/could be filed - my guess would be DRI/Intel but it's not really a rendering issue.
Comment 7 Tanu Kaskinen 2017-11-02 21:35:39 UTC
Audio bugs in the kernel should be reported to the alsa developers.
http://alsa-project.org/main/index.php/Bug_Tracking
Comment 8 Tanu Kaskinen 2017-11-02 21:53:35 UTC
By the way, the kernel patch that you reverted in the build that fixed the issue was this one:
https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/?h=next-20171013&id=8a2d6ae1f737fd22eaeadd0dc32b85c92f239025

The Arch bug discussion referenced this blog post:
https://linuxiumcomau.blogspot.com/2017/10/fixing-broken-hdmi-audio.html

As you can see from that blog post, there are now multiple devices created for HDMI. Have you verified that none of those work? You should check that before reporting the issue to the alsa developers. It's not a bug that there are multiple devices, since the hardware (at least in some sense) supports multiple HDMI outputs. I don't know why the kernel creates multiple devices even when there's only one physical HDMI connector, but this is the standard way how HDMI audio works on Linux (it's not only Intel that creates multiple audio devices for HDMI).

I don't know if Kodi is able to figure out which HDMI device is actually connected to a monitor. The information about what outputs are plugged in is available in the alsa mixer.
Comment 9 freedesktop 2017-11-02 22:26:41 UTC
> As you can see from that blog post, there are now multiple devices created for HDMI. Have you verified that none of those work?

Unfortunately I don't have access to any affected devices to debug this fully. Hopefully PhilS can answer your query - it's entirely possible there are new devices and one of them needs to be selected for audio to work.

Assuming none of the HDMI devices work, however, then it would be worth discussing further with the ALSA developers (by raising a bug, I guess) - the strange thing is that this issue seems to affect only Cherrytrail-class hardware.

Also, I've just realised you closed this with not-OUR-bug, which is entirely reasonable. For some bizarre reason (possibly myopia, maybe lack of coffee) I read that as not-YOUR-bug, hence the "dick move" accusation. Sorry! :)
Comment 10 Tanu Kaskinen 2017-11-02 23:12:15 UTC
(In reply to freedesktop from comment #9)
> the strange thing is that this issue seems to affect only Cherrytrail-class
> hardware.

Maybe Kodi is making similar assumptions that PulseAudio has been making about the device indexes. HDMI devices have so far followed a convention where the first HDMI device has index 3, the second has index 7, the third has index 8 etc. The Intel HDMI LPE driver doesn't use that convention.

> I read that as not-YOUR-bug, hence the "dick move" accusation. Sorry! :)

No worries :)
Comment 11 PhilS 2017-11-03 04:42:32 UTC
(In reply to freedesktop from comment #9)
> > As you can see from that blog post, there are now multiple devices created for HDMI. Have you verified that none of those work?
> 
> Unfortunately I don't have access to any affected devices to debug this
> fully. Hopefully PhilS can answer your query - it's entirely possible there
> are new devices and one of them needs to be selected for audio to work.
> 
> Assuming none of the HDMI devices work, however, then it would be worth
> discussing further with the ALSA developers (by raising a bug, I guess) -
> the strange thing is that this issue seems to affect only Cherrytrail-class
> hardware.
> 
> Also, I've just realised you closed this with not-OUR-bug, which is entirely
> reasonable. For some bizarre reason (possibly myopia, maybe lack of coffee)
> I read that as not-YOUR-bug, hence the "dick move" accusation. Sorry! :)

Yes I did check all devices created.

The one listed in the version that has 4.12 lists the device that works, wheras with 4.13 it is not listed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.