Bug 103369 - [CI] igt@kms_* fail - igt-kms-WARNING: connector 76/eDP-1 has no modes
Summary: [CI] igt@kms_* fail - igt-kms-WARNING: connector 76/eDP-1 has no modes
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Imre Deak
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks: 103443 103720
  Show dependency treegraph
 
Reported: 2017-10-20 07:48 UTC by Marta Löfstedt
Modified: 2018-01-23 08:11 UTC (History)
1 user (show)

See Also:
i915 platform: GLK
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2017-10-20 07:48:21 UTC
CI_DRM_3268 GLK-shards igt@kms_busy@basic-modeset-A fail:

(kms_busy:11905) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_busy:11905) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:584:
(kms_busy:11905) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_busy:11905) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest basic-modeset-A failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3268/shard-glkb4/igt@kms_busy@basic-modeset-A.html
Comment 1 Marta Löfstedt 2017-10-20 07:56:40 UTC
CI_DRM_3268 GLK-shards igt@kms_chv_cursor_fail@pipe-A-128x128-bottom-edge fail:

(kms_busy:11905) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_busy:11905) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:584:
(kms_busy:11905) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_busy:11905) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest basic-modeset-A failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3268/shard-glkb4/igt@kms_chv_cursor_fail@pipe-A-128x128-bottom-edge.html
Comment 2 Marta Löfstedt 2017-10-20 07:58:01 UTC
CI_DRM_3268 GLK-shards igt@kms_chv_cursor_fail@pipe-A-128x128-right-edge fail:

(kms_chv_cursor_fail:12457) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:12457) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:515:
(kms_chv_cursor_fail:12457) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:12457) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:12457) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-A-128x128-right-edge failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3268/shard-glkb4/igt@kms_chv_cursor_fail@pipe-A-128x128-right-edge.html
Comment 3 Marta Löfstedt 2017-10-20 07:59:07 UTC
CI_DRM_3268 GLK-shards igt@kms_chv_cursor_fail@pipe-B-128x128-bottom-edge fail:

(kms_chv_cursor_fail:12430) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:12430) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:515:
(kms_chv_cursor_fail:12430) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:12430) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:12430) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-B-128x128-bottom-edge failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3268/shard-glkb4/igt@kms_chv_cursor_fail@pipe-B-128x128-bottom-edge.html
Comment 4 Marta Löfstedt 2017-10-20 08:28:09 UTC
CI_DRM_3268 GLK-shards igt@kms_psr_sink_crc@sprite_mmap_gtt_waiting fail:

(kms_psr_sink_crc:11890) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_psr_sink_crc:11890) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:584:
(kms_psr_sink_crc:11890) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_psr_sink_crc:11890) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest sprite_mmap_gtt_waiting failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3268/shard-glkb4/igt@kms_psr_sink_crc@sprite_mmap_gtt_waiting.html
Comment 5 Marta Löfstedt 2017-10-20 08:29:26 UTC
CI_DRM_3268 GLK-shards igt@kms_plane_multiple@legacy-pipe-A-tiling-x fail:

(kms_plane_multiple:12418) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_plane_multiple:12418) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:515:
(kms_plane_multiple:12418) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_plane_multiple:12418) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_plane_multiple:12418) igt-kms-CRITICAL: error: -1 != 0
Subtest legacy-pipe-A-tiling-x failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3268/shard-glkb4/igt@kms_plane_multiple@legacy-pipe-A-tiling-x.html
Comment 6 Marta Löfstedt 2017-10-20 08:31:02 UTC
CI_DRM_3268 GLK-shards igt@kms_plane_multiple@atomic-pipe-C-tiling-x fail:

(kms_plane_multiple:11908) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_plane_multiple:11908) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:515:
(kms_plane_multiple:11908) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_plane_multiple:11908) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_plane_multiple:11908) igt-kms-CRITICAL: error: -1 != 0
Subtest atomic-pipe-C-tiling-x failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3268/shard-glkb4/igt@kms_plane_multiple@atomic-pipe-C-tiling-x.html
Comment 7 Marta Löfstedt 2017-10-20 08:31:59 UTC
CI_DRM_3268 GLK-shards igt@kms_pipe_crc_basic@suspend-read-crc-pipe-C fail:

(kms_pipe_crc_basic:12442) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_pipe_crc_basic:12442) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:515:
(kms_pipe_crc_basic:12442) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_pipe_crc_basic:12442) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_pipe_crc_basic:12442) igt-kms-CRITICAL: error: -1 != 0
Subtest suspend-read-crc-pipe-C failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3268/shard-glkb4/igt@kms_pipe_crc_basic@suspend-read-crc-pipe-C.html
Comment 8 Marta Löfstedt 2017-10-20 08:36:23 UTC
Note all these are on glk-4.
Also, none of them are in the first shard after reboot.
Comment 9 Marta Löfstedt 2017-10-25 07:36:14 UTC
*** Bug 103442 has been marked as a duplicate of this bug. ***
Comment 10 Marta Löfstedt 2017-10-25 07:38:35 UTC
CI_DRM_3278 GLK-shards igt@kms_ccs@pipe-B-bad-rotation-90

(kms_ccs:12279) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_ccs:12279) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:584:
(kms_ccs:12279) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_ccs:12279) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest pipe-B-bad-rotation-90 failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3278/shard-glkb5/igt@kms_ccs@pipe-B-bad-rotation-90.html
Comment 11 Marta Löfstedt 2017-10-25 07:39:47 UTC
	https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3278/shard-glkb5/igt@kms_rotation_crc@sprite-rotation-180-flip.html

(kms_rotation_crc:13326) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_rotation_crc:13326) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_rotation_crc:13326) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_rotation_crc:13326) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_rotation_crc:13326) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_rotation_crc:13326) igt-kms-CRITICAL: error: -1 != 0
Subtest sprite-rotation-180-flip failed.
Comment 12 Marta Löfstedt 2017-10-25 07:40:49 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3278/shard-glkb5/igt@kms_pipe_crc_basic@read-crc-pipe-B-frame-sequence.html

	

(kms_pipe_crc_basic:11148) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_pipe_crc_basic:11148) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_pipe_crc_basic:11148) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_pipe_crc_basic:11148) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_pipe_crc_basic:11148) igt-kms-CRITICAL: error: -1 != 0
Subtest read-crc-pipe-B-frame-sequence failed.
Comment 13 Marta Löfstedt 2017-10-25 07:41:31 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3278/shard-glkb5/igt@kms_universal_plane@disable-primary-vs-flip-pipe-B.html

	

(kms_universal_plane:13329) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_universal_plane:13329) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_universal_plane:13329) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_universal_plane:13329) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_universal_plane:13329) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_universal_plane:13329) igt-kms-CRITICAL: error: -1 != 0
Subtest disable-primary-vs-flip-pipe-B failed.
Comment 14 Marta Löfstedt 2017-10-25 07:42:37 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3278/shard-glkb5/igt@kms_ccs@pipe-D-crc-primary-rotation-180.html


(kms_ccs:12273) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_ccs:12273) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:584:
(kms_ccs:12273) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_ccs:12273) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest pipe-D-crc-primary-rotation-180 failed.
Comment 15 Marta Löfstedt 2017-10-25 08:04:33 UTC
Note I unduplicated Bug 103442.
Comment 16 Marta Löfstedt 2017-10-25 08:09:42 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3278/shard-glkb5/igt@kms_cursor_crc@cursor-size-change.html

	

(kms_cursor_crc:11171) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_cursor_crc:11171) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_cursor_crc:11171) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_cursor_crc:11171) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_cursor_crc:11171) igt-kms-CRITICAL: error: -1 != 0
Subtest cursor-size-change failed.
Comment 17 Marta Löfstedt 2017-10-26 07:25:12 UTC
new tests:
CI_DRM_3284 GLK-shards igt@kms_plane_multiple@atomic-pipe-C-tiling-none:

(kms_plane_multiple:10650) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_plane_multiple:10650) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_plane_multiple:10650) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_plane_multiple:10650) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_plane_multiple:10650) igt-kms-CRITICAL: error: -1 != 0
Subtest atomic-pipe-C-tiling-none failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3284/shard-glkb4/igt@kms_plane_multiple@atomic-pipe-C-tiling-none.html
Comment 18 Marta Löfstedt 2017-10-26 07:26:22 UTC
new test:
CI_DRM_3284 GLK-shards igt@kms_chv_cursor_fail@pipe-C-128x128-bottom-edge

(kms_chv_cursor_fail:10699) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:10699) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_chv_cursor_fail:10699) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:10699) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:10699) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-C-128x128-bottom-edge failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3284/shard-glkb4/igt@kms_chv_cursor_fail@pipe-C-128x128-bottom-edge.html
Comment 19 Marta Löfstedt 2017-10-26 07:27:26 UTC
CI_DRM_3284 GLK-shards igt@kms_cursor_crc@cursor-256x85-sliding


(kms_cursor_crc:10753) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_cursor_crc:10753) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_cursor_crc:10753) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_cursor_crc:10753) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_cursor_crc:10753) igt-kms-CRITICAL: error: -1 != 0
Subtest cursor-256x85-sliding failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3284/shard-glkb4/igt@kms_cursor_crc@cursor-256x85-sliding.html
Comment 20 Marta Löfstedt 2017-10-26 07:28:27 UTC
CI_DRM_3284 GLK-shards igt@kms_chv_cursor_fail@pipe-A-256x256-right-edge

(kms_chv_cursor_fail:10182) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:10182) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_chv_cursor_fail:10182) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:10182) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:10182) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-A-256x256-right-edge failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3284/shard-glkb4/igt@kms_chv_cursor_fail@pipe-A-256x256-right-edge.html
Comment 21 Marta Löfstedt 2017-10-26 07:29:36 UTC
CI_DRM_3284 GLK-shards igt@kms_chv_cursor_fail@pipe-B-64x64-left-edge

(kms_chv_cursor_fail:10702) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:10702) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_chv_cursor_fail:10702) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:10702) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:10702) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-B-64x64-left-edge failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3284/shard-glkb4/igt@kms_chv_cursor_fail@pipe-B-64x64-left-edge.html
Comment 22 Marta Löfstedt 2017-10-26 07:30:36 UTC
CI_DRM_3284 GLK-shards igt@kms_chv_cursor_fail@pipe-A-64x64-top-edge

(kms_chv_cursor_fail:10738) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:10738) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_chv_cursor_fail:10738) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:10738) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:10738) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-A-64x64-top-edge failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3284/shard-glkb4/igt@kms_chv_cursor_fail@pipe-A-64x64-top-edge.html
Comment 23 Marta Löfstedt 2017-10-26 07:31:39 UTC
CI_DRM_3284 GLK-shards igt@prime_mmap_kms@buffer-sharing

(prime_mmap_kms:10194) igt-kms-WARNING: connector 76/eDP-1 has no modes
(prime_mmap_kms:10194) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(prime_mmap_kms:10194) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(prime_mmap_kms:10194) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(prime_mmap_kms:10194) igt-kms-CRITICAL: error: -1 != 0
Subtest buffer-sharing failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3284/shard-glkb4/igt@prime_mmap_kms@buffer-sharing.html
Comment 24 Marta Löfstedt 2017-11-02 07:23:14 UTC
new subtest:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3305/shard-glkb1/igt@kms_universal_plane@universal-plane-pipe-C-functional.html

(kms_universal_plane:6375) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_universal_plane:6375) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_universal_plane:6375) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_universal_plane:6375) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_universal_plane:6375) igt-kms-CRITICAL: error: -1 != 0
Subtest universal-plane-pipe-C-functional failed.
Comment 25 Marta Löfstedt 2017-11-02 07:23:42 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3305/shard-glkb1/igt@kms_flip_tiling@flip-changes-tiling-Y.html

(kms_flip_tiling:6318) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_flip_tiling:6318) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:584:
(kms_flip_tiling:6318) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_flip_tiling:6318) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest flip-changes-tiling-Y failed.
Comment 26 Marta Löfstedt 2017-11-02 07:24:08 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3305/shard-glkb1/igt@kms_chv_cursor_fail@pipe-B-128x128-right-edge.html

(kms_chv_cursor_fail:6358) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:6358) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_chv_cursor_fail:6358) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:6358) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:6358) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-B-128x128-right-edge failed.
Comment 27 Marta Löfstedt 2017-11-02 07:24:40 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3305/shard-glkb1/igt@kms_cursor_crc@cursor-64x21-sliding.html

(kms_cursor_crc:6385) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_cursor_crc:6385) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_cursor_crc:6385) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_cursor_crc:6385) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_cursor_crc:6385) igt-kms-CRITICAL: error: -1 != 0
Subtest cursor-64x21-sliding failed.
Comment 28 Marta Löfstedt 2017-11-02 07:25:10 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3306/shard-glkb3/igt@kms_chv_cursor_fail@pipe-C-64x64-right-edge.html

(kms_chv_cursor_fail:13117) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:13117) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_chv_cursor_fail:13117) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:13117) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:13117) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-C-64x64-right-edge failed.
Comment 29 Marta Löfstedt 2017-11-02 07:25:37 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3306/shard-glkb3/igt@kms_chv_cursor_fail@pipe-A-128x128-top-edge.html

(kms_chv_cursor_fail:13096) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:13096) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_chv_cursor_fail:13096) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:13096) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:13096) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-A-128x128-top-edge failed.
Comment 30 Marta Löfstedt 2017-11-02 07:26:04 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3306/shard-glkb3/igt@kms_cursor_crc@cursor-256x256-dpms.html

(kms_cursor_crc:13160) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_cursor_crc:13160) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_cursor_crc:13160) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_cursor_crc:13160) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_cursor_crc:13160) igt-kms-CRITICAL: error: -1 != 0
Subtest cursor-256x256-dpms failed.
Comment 31 Marta Löfstedt 2017-11-02 07:26:31 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3306/shard-glkb3/igt@kms_universal_plane@universal-plane-gen9-features-pipe-C.html


(kms_universal_plane:13023) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_universal_plane:13023) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_universal_plane:13023) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_universal_plane:13023) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_universal_plane:13023) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_universal_plane:13023) igt-kms-CRITICAL: error: -1 != 0
Subtest universal-plane-gen9-features-pipe-C failed.
Comment 32 Marta Löfstedt 2017-11-02 07:27:07 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3306/shard-glkb3/igt@kms_busy@extended-pageflip-hang-newfb-render-B.html

(kms_busy:13132) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_busy:13132) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:584:
(kms_busy:13132) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_busy:13132) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest extended-pageflip-hang-newfb-render-B failed.
Comment 33 Marta Löfstedt 2017-11-02 07:28:10 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3306/shard-glkb3/igt@kms_plane_lowres@pipe-B-tiling-yf.html


(kms_plane_lowres:13107) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_plane_lowres:13107) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:584:
(kms_plane_lowres:13107) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_plane_lowres:13107) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest pipe-B-tiling-yf failed.
Comment 34 Marta Löfstedt 2017-11-02 07:36:14 UTC
To summarize the addition of test suppressed on GLK-shards by "eDP-1 has no modes".

On:
CI_DRM_3268 glk4 8 tests
CI_DRM_3278 glk5 6 tests
CI_DRM_3284 glk4 6 tests
CI_DRM_3305 glk1 4 tests
CI_DRM_3305 glk3 6 tests

This is going to go on until we have hidden the actual results of all kms tests.
Comment 37 Marta Löfstedt 2017-11-15 11:07:46 UTC
new big batch of no modes subtest CI_DRM_3348 GLKb3

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_plane_multiple@legacy-pipe-b-tiling-none.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_rotation_crc@exhaust-fences.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_cursor_crc@cursor-256x256-random.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_universal_plane@universal-plane-gen9-features-pipe-b.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_busy@extended-pageflip-hang-oldfb-render-c.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_plane_lowres@pipe-c-tiling-yf.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb4/igt@kms_cursor_crc@cursor-64x64-onscreen.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_plane@plane-position-covered-pipe-a-planes.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_cursor_crc@cursor-64x21-offscreen.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_cursor_legacy@short-flip-after-cursor-atomic-transitions-varying-size.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_chv_cursor_fail@pipe-b-256x256-right-edge.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb4/igt@kms_chv_cursor_fail@pipe-c-128x128-right-edge.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_cursor_crc@cursor-128x128-onscreen.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_cursor_crc@cursor-128x42-offscreen.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_cursor_legacy@short-flip-after-cursor-toggle.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_cursor_crc@cursor-64x64-random.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_busy@extended-modeset-hang-oldfb-with-reset-render-a.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_busy@basic-flip-a.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_plane@plane-panning-top-left-pipe-a-planes.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_plane_multiple@atomic-pipe-c-tiling-y.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_universal_plane@disable-primary-vs-flip-pipe-c.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_universal_plane@universal-plane-pipe-c-sanity.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_properties@plane-properties-atomic.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_vblank@wait-forked.html
Comment 38 Marta Löfstedt 2017-11-15 13:34:08 UTC
Imre, I went through the json files for the runs of KBL3 on CI_DRM_3348,
the first occurrence of "no modes" is on: igt@kms_busy@extended-pageflip-hang-newfb-render-b

i.e: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_busy@extended-pageflip-hang-newfb-render-b.html

then the rest of the test as listed in https://bugs.freedesktop.org/show_bug.cgi?id=103369#c37 also fail on the "no modes" warning. 

Note, the issues from the same KBL3 on CI_DRM_3348 I filed on bug 103443 and 103720 are happening after https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3348/shard-glkb3/igt@kms_busy@extended-pageflip-hang-newfb-render-b.html
Comment 39 Marta Löfstedt 2017-11-16 07:31:38 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3352/shard-glkb1/igt@kms_atomic_interruptible@legacy-pageflip.html

(kms_atomic_interruptible:7512) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_atomic_interruptible:7512) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_atomic_interruptible:7512) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_atomic_interruptible:7512) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_atomic_interruptible:7512) igt-kms-CRITICAL: error: -1 != 0
Subtest legacy-pageflip failed.
Comment 40 Marta Löfstedt 2017-11-17 08:02:13 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3355/shard-glkb3/igt@kms_cursor_crc@cursor-64x64-dpms.html

(kms_cursor_crc:1659) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_cursor_crc:1659) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_cursor_crc:1659) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_cursor_crc:1659) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_cursor_crc:1659) igt-kms-CRITICAL: error: -1 != 0
Subtest cursor-64x64-dpms failed.
Comment 41 Marta Löfstedt 2017-11-17 08:03:40 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3355/shard-glkb3/igt@kms_pipe_crc_basic@nonblocking-crc-pipe-b-frame-sequence.html

(kms_pipe_crc_basic:1732) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_pipe_crc_basic:1732) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_pipe_crc_basic:1732) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_pipe_crc_basic:1732) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_pipe_crc_basic:1732) igt-kms-CRITICAL: error: -1 != 0
Subtest nonblocking-crc-pipe-B-frame-sequence failed.
Comment 42 Marta Löfstedt 2017-11-17 08:04:28 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3355/shard-glkb3/igt@kms_chv_cursor_fail@pipe-a-64x64-right-edge.html

(kms_chv_cursor_fail:2270) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:2270) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_chv_cursor_fail:2270) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:2270) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:2270) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-A-64x64-right-edge failed.
Comment 43 Marta Löfstedt 2017-11-17 08:05:01 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3355/shard-glkb3/igt@kms_plane_multiple@legacy-pipe-c-tiling-none.html

(kms_plane_multiple:1624) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_plane_multiple:1624) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_plane_multiple:1624) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_plane_multiple:1624) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_plane_multiple:1624) igt-kms-CRITICAL: error: -1 != 0
Subtest legacy-pipe-C-tiling-none failed.
Comment 44 Marta Löfstedt 2017-11-17 08:05:24 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3355/shard-glkb3/igt@kms_flip_tiling@flip-x-tiled.html

(kms_flip_tiling:2201) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_flip_tiling:2201) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:584:
(kms_flip_tiling:2201) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_flip_tiling:2201) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest flip-X-tiled failed.
Comment 45 Marta Löfstedt 2017-11-17 08:05:54 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3355/shard-glkb3/igt@kms_chv_cursor_fail@pipe-b-256x256-top-edge.html
	

(kms_chv_cursor_fail:2198) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_chv_cursor_fail:2198) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_chv_cursor_fail:2198) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_chv_cursor_fail:2198) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_chv_cursor_fail:2198) igt-kms-CRITICAL: error: -1 != 0
Subtest pipe-B-256x256-top-edge failed.
Comment 46 Marta Löfstedt 2017-11-22 07:25:33 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3368/shard-glkb3/igt@kms_cursor_crc@cursor-128x128-offscreen.html
	
(kms_cursor_crc:12085) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_cursor_crc:12085) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_cursor_crc:12085) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_cursor_crc:12085) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_cursor_crc:12085) igt-kms-CRITICAL: error: -1 != 0
Subtest cursor-128x128-offscreen failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3368/shard-glkb3/igt@kms_cursor_legacy@cursor-vs-flip-atomic-transitions-varying-size.html
	

(kms_cursor_legacy:12079) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_cursor_legacy:12079) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_cursor_legacy:12079) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_cursor_legacy:12079) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_cursor_legacy:12079) igt-kms-CRITICAL: error: -1 != 0
Subtest cursor-vs-flip-atomic-transitions-varying-size failed.
Comment 48 Marta Löfstedt 2017-11-23 08:10:57 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3373/shard-glkb3/igt@kms_cursor_legacy@cursora-vs-flipa-toggle.html
(kms_cursor_legacy:6820) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_cursor_legacy:6820) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_cursor_legacy:6820) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_cursor_legacy:6820) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_cursor_legacy:6820) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_cursor_legacy:6820) igt-kms-CRITICAL: error: -1 != 0
Subtest cursorA-vs-flipA-toggle failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3373/shard-glkb3/igt@kms_plane@plane-panning-bottom-right-pipe-b-planes.html
(kms_plane:6725) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_plane:6725) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_plane:6725) igt-kms-CRITICAL: Test assertion failure function kmstest_dumb_create, file igt_kms.c:518:
(kms_plane:6725) igt-kms-CRITICAL: Failed assertion: igt_ioctl((fd), ((((2U|1U) << (((0+8)+8)+14)) | ((('d')) << (0+8)) | (((0xB2)) << 0) | ((((sizeof(struct drm_mode_create_dumb)))) << ((0+8)+8)))), (&create)) == 0
(kms_plane:6725) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_plane:6725) igt-kms-CRITICAL: error: -1 != 0
Subtest plane-panning-bottom-right-pipe-B-planes failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3373/shard-glkb3/igt@kms_busy@basic-flip-c.html
(kms_busy:6782) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_busy:6782) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_busy:6782) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:572:
(kms_busy:6782) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_busy:6782) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest basic-flip-C failed.

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3373/shard-glkb3/igt@kms_ccs@pipe-b-bad-pixel-format.html
(kms_ccs:6773) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_ccs:6773) igt-kms-WARNING: connector 76/eDP-1 has no modes
(kms_ccs:6773) ioctl-wrappers-CRITICAL: Test assertion failure function gem_create, file ioctl_wrappers.c:572:
(kms_ccs:6773) ioctl-wrappers-CRITICAL: Failed assertion: __gem_create(fd, size, &handle) == 0
(kms_ccs:6773) ioctl-wrappers-CRITICAL: error: -22 != 0
Subtest pipe-B-bad-pixel-format failed.
Comment 49 Imre Deak 2018-01-19 15:32:06 UTC
Looks like the modes on eDP are pruned due to too high mode clock. That in turn is caused by a previous link training failure:

<7>[ 2153.428268] [drm:intel_dp_dump_link_status [i915]] ln0_1:0x11 ln2_3:0x11 align:0x80 sink:0x0 adj_req0_1:0x77 adj_req2_3:0x77
<7>[ 2153.428303] [drm:intel_dp_start_link_train [i915]] Channel equalization failed 5 times
<7>[ 2153.428341] [drm:intel_dp_start_link_train [i915]] [CONNECTOR:76:eDP-1] Link Training failed at link rate = 270000, lane count = 4

which sets the ports maximum link rate to 162000 and afterwards causes failed modesets:
<7>[ 2153.723132] [drm:drm_mode_debug_printmodeline] Modeline 80:"3200x1800" 60 361310 3200 3248 3280 3316 1800 1802 1807 1816 0x48 0xa
<7>[ 2153.723247] [drm:intel_dp_compute_config [i915]] DP link computation with max lane count 4 max bw 162000 pixel clock 361310KHz
<7>[ 2153.723355] [drm:intel_atomic_check [i915]] Encoder config failure
<7>[ 2153.723465] [drm:intel_dump_pipe_config [i915]] [CRTC:42:pipe A][failed]

and pruned modes:

<7>[ 2154.575833] [drm:drm_mode_prune_invalid] Not using 3200x1800 mode: CLOCK_HIGH

One question is why link training fails, but also if we should reset the link rate limitation sometime afterwards. Currently for eDP it'd only happen during system resume or reloading the driver, since eDP ignores long HPDs where the link rate limit is reset atm.
Comment 50 Imre Deak 2018-01-22 15:53:19 UTC
The link training probably fails because it's from a retraining scheduled from intel_hpd_init() after runtime resume, which races with a modeset doing a normal link training. Not sure exactly how the retraining fails, perhaps simply the AUX writes for the training sequence are somehow interleaved. In any case it's bogus to do the retraining since the link is down at that point. The race itself is assumed to be fixed by

commit 42e5e65765265485ecf2a480c244d76c2c624449
Author:     Daniel Vetter <daniel.vetter@ffwll.ch>
AuthorDate: Mon Nov 13 17:01:40 2017 +0100
Commit:     Daniel Vetter <daniel.vetter@ffwll.ch>
CommitDate: Thu Nov 23 14:59:07 2017 +0100

    drm/i915: sync dp link status checks against atomic commmits

As for the fallback DP lane and rate limit values there is the following patch which fell through the cracks, I'll merge it:

https://lists.freedesktop.org/archives/intel-gfx/2017-October/142766.html
[Intel-gfx] [PATCH v2] drm/i915/edp: Do not do link training fallback or prune modes on EDP

Thanks to Ville to pointing to these commits.
Comment 51 Marta Löfstedt 2018-01-23 08:11:12 UTC
Thanks Imre for for fixing this long lived issue!
patches integrated from CI_DRM_3669. I will close and archive.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.