Bug 103410 - [BAT] igt@* - Incomplete - GEM_BUG_ON(!dev_priv->gt.awake) - kernel BUG at drivers/gpu/drm/i915/intel_lrc.c:782!
Summary: [BAT] igt@* - Incomplete - GEM_BUG_ON(!dev_priv->gt.awake) - kernel BUG at dr...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: highest critical
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-23 07:46 UTC by Marta Löfstedt
Modified: 2017-10-27 08:24 UTC (History)
2 users (show)

See Also:
i915 platform: GLK, KBL, SKL
i915 features: GEM/Other


Attachments

Description Marta Löfstedt 2017-10-23 07:46:24 UTC
CI_DRM_3273 fi-skl-6700hq igt@kms_pipe_crc_basic@hang-read-crc-pipe-b

Incomplete:

<14>[  450.114188] [IGT] kms_pipe_crc_basic: exiting, ret=0
<4>[  450.118865] ------------[ cut here ]------------
<2>[  450.118868] kernel BUG at drivers/gpu/drm/i915/intel_lrc.c:782!
<4>[  450.118886] invalid opcode: 0000 [#1] PREEMPT SMP
<4>[  450.118891] Modules linked in: vgem snd_hda_codec_hdmi snd_hda_codec_generic i915 x86_pkg_temp_thermal intel_powerclamp coretemp crct10dif_pclmul crc32_pclmul snd_hda_intel ghash_clmulni_intel snd_hda_codec snd_hwdep r8169 snd_hda_core mii snd_pcm mei_me mei prime_numbers pinctrl_sunrisepoint i2c_hid pinctrl_intel
<4>[  450.118935] CPU: 6 PID: 0 Comm: swapper/6 Tainted: G     U          4.14.0-rc5-CI-CI_DRM_3273+ #1
<4>[  450.118944] Hardware name: TOSHIBA SATELLITE P50-C/06F4                            , BIOS 1.40 03/29/2016
<4>[  450.118953] task: ffff880277e6a880 task.stack: ffffc900000f8000
<4>[  450.118986] RIP: 0010:intel_lrc_irq_handler+0x304/0x8a0 [i915]
<4>[  450.118992] RSP: 0018:ffff880281d83ea8 EFLAGS: 00010246
<4>[  450.118999] RAX: ffff88026b8124a0 RBX: ffff88026b812440 RCX: 0000000000000000
<4>[  450.119006] RDX: 0000000000000000 RSI: ffffffff81d0d97c RDI: ffff88026b812158
<4>[  450.119013] RBP: ffff880281d83f00 R08: 0000000000000000 R09: 0000000000000001
<4>[  450.119020] R10: 0000000000000000 R11: 0000000000000000 R12: ffff88026aec0000
<4>[  450.119027] R13: 0000000000000000 R14: ffffffff81d184a7 R15: 0000000000000000
<4>[  450.119034] FS:  0000000000000000(0000) GS:ffff880281d80000(0000) knlGS:0000000000000000
<4>[  450.119042] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4>[  450.119048] CR2: 000056313acb1fc8 CR3: 0000000003e0f003 CR4: 00000000003606e0
<4>[  450.119055] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
<4>[  450.119062] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
<4>[  450.119069] Call Trace:
<4>[  450.119073]  <IRQ>
<4>[  450.119079]  ? tasklet_hi_action+0x71/0x120
<4>[  450.119086]  ? __this_cpu_preempt_check+0x13/0x20
<4>[  450.119092]  tasklet_hi_action+0x98/0x120
<4>[  450.119099]  __do_softirq+0xc0/0x4ae
<4>[  450.119105]  irq_exit+0xae/0xc0
<4>[  450.119110]  do_IRQ+0x71/0x130
<4>[  450.119115]  common_interrupt+0x9a/0x9a
<4>[  450.119120]  </IRQ>
<4>[  450.119124] RIP: 0010:cpuidle_enter_state+0x136/0x370
<4>[  450.119130] RSP: 0018:ffffc900000fbe80 EFLAGS: 00000212 ORIG_RAX: ffffffffffffff9d
<4>[  450.119138] RAX: ffff880277e6a880 RBX: 000000000001c33d RCX: 0000000000000001
<4>[  450.119145] RDX: 0000000000000000 RSI: ffffffff81d0d97c RDI: ffffffff81cc18d6
<4>[  450.119153] RBP: ffffc900000fbeb8 R08: 000000000000074f R09: 0000000000000018
<4>[  450.119160] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000004
<4>[  450.119167] R13: 0000000000000004 R14: ffffe8ffffd84070 R15: 00000068cd2abc8b
<4>[  450.119177]  cpuidle_enter+0x17/0x20
<4>[  450.119183]  call_cpuidle+0x23/0x40
<4>[  450.119188]  do_idle+0x192/0x1e0
<4>[  450.119194]  cpu_startup_entry+0x1d/0x20
<4>[  450.119200]  start_secondary+0x11c/0x140
<4>[  450.119206]  secondary_startup_64+0xa5/0xa5
<4>[  450.119212] Code: 4d c8 05 a0 03 00 00 48 03 81 a8 0b 00 00 44 8b 28 44 89 eb 41 c1 ed 08 41 83 e5 07 83 e3 07 45 89 af 84 03 00 00 e9 af fd ff ff <0f> 0b 0f 0b 41 80 bf 68 03 00 00 00 4c 8b 65 c8 74 1e 41 8b b7 
<1>[  450.119297] RIP: intel_lrc_irq_handler+0x304/0x8a0 [i915] RSP: ffff880281d83ea8
<4>[  450.119316] ---[ end trace 27187793ce60fbf9 ]---

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3273/fi-skl-6700hq/igt@kms_pipe_crc_basic@hang-read-crc-pipe-b.html
Comment 1 Marta Löfstedt 2017-10-23 07:48:48 UTC
Also, CI_DRM_3272 fi-kbl-7567u igt@kms_flip@basic-flip-vs-dpms

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3272/fi-kbl-7567u/igt@kms_flip@basic-flip-vs-dpms.html
Comment 2 Marta Löfstedt 2017-10-23 08:01:30 UTC
Note this is un-duplicated from bug 102035

kernel BUG at drivers/gpu/drm/i915/intel_lrc.c:782!

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3269/fi-skl-6700hq/igt@kms_pipe_crc_basic@read-crc-pipe-b-frame-sequence.html
Comment 3 Maarten Lankhorst 2017-10-23 08:04:24 UTC
Very big reproducer on GEM tests too, when configuring the crtc's to be disabled by fbcon:

https://patchwork.freedesktop.org/series/31893/

Any gen9+ seems to be affected, not just skylake. And it doesn't appear to be bound to any specific test.
Comment 4 Marta Löfstedt 2017-10-23 08:07:10 UTC
Note this is un-duplicated from bug 102035

kernel BUG at drivers/gpu/drm/i915/intel_lrc.c:782!

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3266/fi-skl-6260u/igt@kms_cursor_legacy@basic-flip-after-cursor-varying-size.html
Comment 5 Marta Löfstedt 2017-10-23 11:11:23 UTC
Also on GLK_shards:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3275/fi-glk-1/igt@kms_pipe_crc_basic@nonblocking-crc-pipe-c.html

<2>[  470.937369] kernel BUG at drivers/gpu/drm/i915/intel_lrc.c:782!
Comment 8 Chris Wilson 2017-10-25 22:08:05 UTC
commit 4a118ecbe99c93cf9f9582e83a88d03f18d6cb84
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Mon Oct 23 22:32:36 2017 +0100

    drm/i915: Filter out spurious execlists context-switch interrupts
    
    Back in commit a4b2b01523a8 ("drm/i915: Don't mark an execlists
    context-switch when idle") we noticed the presence of late
    context-switch interrupts. We were able to filter those out by looking
    at whether the ELSP remained active, but in commit beecec901790
    ("drm/i915/execlists: Preemption!") that became problematic as we now
    anticipate receiving a context-switch event for preemption while ELSP
    may be empty. To restore the spurious interrupt suppression, add a
    counter for the expected number of pending context-switches and skip if
    we do not need to handle this interrupt to make forward progress.
Comment 9 Marta Löfstedt 2017-10-26 11:00:51 UTC
Chris patch was integrated into CI_DRM_3277 I want a couple of more clean runs before I close this and archive the cibuglog.
Comment 10 Marta Löfstedt 2017-10-27 08:24:23 UTC
No occurances on +10 runs I am closing


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.