Bug 10348 - vesa driver xrandr crash
Summary: vesa driver xrandr crash
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Vesa (show other bugs)
Version: 7.2 (2007.02)
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: xorg-7.4
  Show dependency treegraph
 
Reported: 2007-03-20 02:00 UTC by wsh
Modified: 2008-04-30 14:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wsh 2007-03-20 02:00:59 UTC
when issue xrandr -s <modenumber>, xserver exists.
Duplicate steps:
1.Launch X-Window with VESA driver
2.issue 'xrandr -s 1'
3.X-window exists abnormally.
Comment 1 wsh 2007-03-20 02:08:15 UTC
It seems that the root cause is :
in VESA driver, xf86EnableDisableFBAccess is called to disable the 
display,however this function is already called in xf86RandR.c, as a result, the second call empties pScrnInfo->pixmapPrivate, which is used to keep the copy of pspix->devPrivate.
Comment 2 Andrew Randrianasulu 2008-04-30 13:45:53 UTC
commit f5315667c0d827cca56a0a855b33e0efe83e3fa0 in xorg/driver/xf86-video-vesa should fix this, no? At least i tried recently and it doesn't crash anymore. (but i'm using xserver and vesa driver from git, Build Date: 29 April 2008  12:54:06AM)
Comment 3 Luc Verhaegen 2008-04-30 14:51:18 UTC
Yeah, you're right, this was indeed fixed by aaronp in may 2007. Good thing you poked this bug, this way i caught it in the maelstrom, it caught my eye as i ended up investigating the same issue and then ended backporting the fix to some SUSE version.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.