Bug 103604 - [SKL][bisected] multiple regressions in deqp-gles2@functional@shaders@keywords@reserved_keywords
Summary: [SKL][bisected] multiple regressions in deqp-gles2@functional@shaders@keyword...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-07 02:28 UTC by Martin Peres
Modified: 2019-09-25 19:05 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2017-11-07 02:28:26 UTC
A week ago, some deqp-gles2@functional@shaders@keywords@reserved_keywords tests started failing. Here is the result of the bisect:

34f7e761bc61d3086c1e4e42285c31678b256107 glsl/parser: Track built-in types using the glsl_type directly - 2017-10-30 18:27:09
deqp-gles2@functional@shaders@keywords@reserved_keywords@sampler2drect_vertex: pass -> fail
deqp-gles2@functional@shaders@keywords@reserved_keywords@sampler2drect_fragment: pass -> fail
deqp-gles2@functional@shaders@keywords@reserved_keywords@sampler2drectshadow_fragment: pass -> fail
deqp-gles2@functional@shaders@keywords@reserved_keywords@sampler2drectshadow_vertex: pass -> fail

747c057530a1da32860f3881ca73a0d648e8f317 glsl/parser: Return the glsl_type object from the lexer - 2017-10-30 18:27:09
deqp-gles2@functional@shaders@keywords@reserved_keywords@double_fragment: pass -> fail
deqp-gles2@functional@shaders@keywords@reserved_keywords@double_vertex: pass -> fail

Sorry for the delay, the egl regression prevented the machine from making progress (ezbench issue). It is now catching up on 2 weeks of work and found this issue.
Comment 1 Kenneth Graunke 2017-11-07 08:08:36 UTC
Ian, it looks like this really is supposed to be a reserved keyword in #version 100, but we're only marking it as reserved in #version 300 es and later.  It looks like it's been wrong since the Paul Berry era, but must've worked by luck somehow.  We should probably fix it (really trivial to do).

It looks like these tests are blacklisted in dEQP, not because of any known test bugs, but because a bunch of vendors failed them, and Google hasn't yet made them required for some reason.

Martin, I'm not sure it makes much sense to run dEQP tests in your CI system that aren't in the mustpass list (android/cts/master/gles2-master.txt).  A lot of them are blacklisted because of test bugs, and neither Google nor Khronos require them for conformance...

Cc'ing Mark as a heads up.
Comment 2 Mark Janes 2017-11-07 08:21:07 UTC
It seems to me that detecting regressions on blacklisted tests is desirable, even if we are not required to pass them.  It may be that some blacklisted tests are wrong, but this bug is a data point that indicates tracking pass->fail transitions will identify driver issues.

Tracking status for all the blacklisted tests will muddy the water for the mesa CI, as we rely on CI test results to confirm that we pass conformance.  Ideally, we want the config files listing test failures to be empty.

Martin's ezbench system is a nice way to get this test coverage.
Comment 3 Ian Romanick 2017-11-08 00:11:05 UTC
(In reply to Kenneth Graunke from comment #1)
> Ian, it looks like this really is supposed to be a reserved keyword in
> #version 100, but we're only marking it as reserved in #version 300 es and
> later.  It looks like it's been wrong since the Paul Berry era, but must've
> worked by luck somehow.  We should probably fix it (really trivial to do).

That was my thinking.  I asked Martin to submit the bug so that I wouldn't forget about it.
Comment 4 GitLab Migration User 2019-09-25 19:05:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1647.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.