Bug 103746 - [BDW BSW SKL KBL] dEQP-GLES31.functional.copy_image regressions
Summary: [BDW BSW SKL KBL] dEQP-GLES31.functional.copy_image regressions
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Jason Ekstrand
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords: bisected, regression
: 104570 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-14 22:52 UTC by Mark Janes
Modified: 2019-09-25 19:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
workaround (3.59 KB, patch)
2018-02-08 11:12 UTC, Tapani Pälli
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2017-11-14 22:52:25 UTC
The following tests fail:
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_24_bits.srgb8_rgb8_snorm.cubemap_to_texture2d_array
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_24_bits.srgb8_rgb8_snorm.texture2d_to_cubemap
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_24_bits.srgb8_rgb8_snorm.texture2d_to_texture2d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_24_bits.srgb8_rgb8_snorm.texture2d_to_texture2d_array
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_24_bits.srgb8_rgb8_snorm.texture2d_to_texture3d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.r11f_g11f_b10f_rgba8_snorm.cubemap_to_cubemap
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.r11f_g11f_b10f_rgba8_snorm.texture2d_to_cubemap
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.r11f_g11f_b10f_rgba8_snorm.texture2d_to_texture2d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.r11f_g11f_b10f_rgba8_snorm.texture2d_to_texture2d_array
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.r11f_g11f_b10f_rgba8_snorm.texture2d_to_texture3d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb10_a2_rgba8_snorm.texture2d_to_cubemap
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb10_a2_rgba8_snorm.texture2d_to_texture2d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb10_a2_rgba8_snorm.texture2d_to_texture2d_array
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb10_a2_rgba8_snorm.texture2d_to_texture3d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb10_a2ui_rgba8_snorm.texture2d_to_cubemap
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb10_a2ui_rgba8_snorm.texture2d_to_texture2d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb10_a2ui_rgba8_snorm.texture2d_to_texture2d_array
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb10_a2ui_rgba8_snorm.texture2d_to_texture3d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb9_e5_rgba8_snorm.cubemap_to_texture2d_array
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb9_e5_rgba8_snorm.texture2d_to_cubemap
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb9_e5_rgba8_snorm.texture2d_to_texture2d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb9_e5_rgba8_snorm.texture2d_to_texture2d_array
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.rgb9_e5_rgba8_snorm.texture2d_to_texture3d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.srgb8_alpha8_rgba8_snorm.texture2d_to_cubemap
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.srgb8_alpha8_rgba8_snorm.texture2d_to_texture2d
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.srgb8_alpha8_rgba8_snorm.texture2d_to_texture2d_array
 dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.srgb8_alpha8_rgba8_snorm.texture2d_to_texture3d


Test output indicates many successful comparisons, along with:
Image comparison failed: max difference = (122, 107, 172, 255), threshold = (2, 2, 2, 2)

These tests were disabled except on daily builds due to test time.  Bisection is underway.
Comment 1 Mark Janes 2017-11-14 23:16:38 UTC
Bisected to:
fb0e9b5197cb65bde1e116d89acd5deb32f9132c
Author: Jason Ekstrand <jason.ekstrand@intel.com>
    i965: Track the depth and render caches separately
Comment 2 Clayton Craft 2017-11-15 21:56:35 UTC
More tests in this group were (itermittently) failing again today on BDW & BSW, so I have disabled this group of tests from running on those two platforms: dEQP-GLES31.functional.copy_image.non_compressed.viewclass_32_bits.
Comment 3 Mark Janes 2018-01-10 17:20:06 UTC
*** Bug 104570 has been marked as a duplicate of this bug. ***
Comment 4 Jason Ekstrand 2018-01-10 17:38:55 UTC
Does this series help?

https://patchwork.freedesktop.org/series/35325/
Comment 5 Mark Janes 2018-01-10 18:59:58 UTC
No:
http://otc-mesa-ci.jf.intel.com/job/mesa_custom/3502/
Comment 6 Tapani Pälli 2018-02-08 11:12:50 UTC
Created attachment 137233 [details] [review]
workaround

I debugged this and noticed that flushing always for genX(blorp_exec) makes tests pass. Maybe this helps? Jason, let me know if there are some particular things I could check.
Comment 7 Jason Ekstrand 2018-02-10 20:10:04 UTC
I'm beginning to think that the root cause here is actually a hardware bug.  I'm trying to get a hold of someone who better understands GEN cache hierarchies to know for sure.
Comment 8 Clayton Craft 2018-02-12 19:10:57 UTC
dEQP-GLES31.functional.copy_image.mixed tests were also failing intermittently in CI on these 4 platforms.
Comment 9 Dylan Baker 2018-03-13 22:33:39 UTC
Jason, I thought I saw a patch to work around this land, is that correct?
Comment 10 Kenneth Graunke 2018-03-14 21:37:18 UTC
Hacked around with

commit 8379bff6c4456f8a77041eee225dcd44e5e00a76
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Fri Mar 9 21:23:23 2018 -0800

    i965: Emit texture cache invalidates around blorp_copy

So dropping from the 18.0 blockers list.  Leaving open as we'll need a real solution eventually.
Comment 11 GitLab Migration User 2019-09-25 19:05:48 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1653.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.