Bug 103763 - PackageKit is fetching even disabled repositories
Summary: PackageKit is fetching even disabled repositories
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-15 15:08 UTC by František Zatloukal
Modified: 2017-11-15 16:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description František Zatloukal 2017-11-15 15:08:05 UTC
Packagekit is fetching even disabled repositories. I've disabled one of my repositories (by setting enabled=0 in .repo file) and intentionally made a mistake in baseurl. After running "pkcon refresh", I've seen this in log:

15:53:54	PackageKit-DNF      Skipping refresh of frantisekz-fedora-developer-portal: cannot update repo 'frantisekz-fedora-developer-portal': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried; Last error: Status code: 404 for https://copr-be.cloud.fedoraproject.org/results/frantisekzx/fedora-developer-portal/fedora-rawhide-x86_64/repodata/repomd.xml

Testing was done on F27, with PackageKit-1.1.7-1.fc27.x86_64.
Comment 1 Kamil Páral 2017-11-15 15:10:04 UTC
I can confirm the same behavior, I clearly see disabled repos being accessed by packagekit in system journal. This might be one of the reasons why refreshing available updates in gnome-software has been taking so unbearably long lately.
Comment 2 Kamil Páral 2017-11-15 16:10:13 UTC
As it turns out, this is expected behavior when there is enabled_metadata=1 in the repo file, which there is in our case.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.