Bug 103776 - [skl] GPU reset when working on Microsoft Excel files (only when the file contains colored cells) under Rdesktop
Summary: [skl] GPU reset when working on Microsoft Excel files (only when the file con...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) other
: medium critical
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 103777 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-16 13:04 UTC by Albator_123
Modified: 2019-09-25 19:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
crash dump (762.13 KB, text/plain)
2017-11-16 13:04 UTC, Albator_123
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albator_123 2017-11-16 13:04:53 UTC
Created attachment 135514 [details]
crash dump

Hi everyone, 
i'm getting gpu resets when working with Microsft Excel 2007 over rdesktop.

This causes the GPU to reset until the computer crashes completely and returns to the screen session.
it only happens when there is colors in the cells, if not it doesn't crash.
So if i set set the parameter a (color) to 24 bits this happens less but it crashes anyway.

-Debian 9.1 
-system architecture :x86_64
-Display connector: DP
-Mother board:
 Handle 0x0002, DMI type 2, 15 bytes
 Base Board Information
        Manufacturer: LENOVO
        Product Name: 30D2
        Version: SDK0J40697 WIN 3305033032255
        Serial Number:
        Asset Tag:
        Features:
          Board is a hosting board
          Board is replaceable
        Location In Chassis: Default string
        Chassis Handle: 0x0003
        Type: Motherboard
        Contained Object Handles: 0
- Kernel version: 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u5 (2017-09-19) x86_64 GNU/Linux
rdesktop 1.8.3-2+b1

Details in the logs : 
Nov 16 11:38:16 USERX kernel: [13205.906830] [drm] GPU HANG: ecode 9:0:0x86dffffd, in Xorg [697], reason: Hang on render ring, action: reset
Nov 16 11:38:16 USERX kernel: [13205.906833] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Nov 16 11:38:16 USERX kernel: [13205.906834] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Nov 16 11:38:16 USERX kernel: [13205.906835] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Nov 16 11:38:16 USERX kernel: [13205.906837] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Nov 16 11:38:16 USERX kernel: [13205.906838] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Nov 16 11:38:16 USERX kernel: [13205.906903] drm/i915: Resetting chip after gpu hang
Nov 16 11:38:16 USERX kernel: [13205.906972] [drm] RC6 on
Nov 16 11:38:16 USERX kernel: [13205.921260] [drm] GuC firmware load skipped
Nov 16 11:38:28 USERX kernel: [13217.905687] drm/i915: Resetting chip after gpu hang
Nov 16 11:38:28 USERX kernel: [13217.905754] [drm] RC6 on
Nov 16 11:38:28 USERX kernel: [13217.917850] [drm] GuC firmware load skipped
Nov 16 11:38:28 USERX org.a11y.atspi.Registry[914]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Nov 16 11:38:28 USERX org.a11y.atspi.Registry[914]:       after 16426 requests (16426 known processed) with 0 events remaining.
Nov 16 11:38:28 USERX org.a11y.atspi.Registry[842]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Nov 16 11:38:28 USERX org.a11y.atspi.Registry[842]:       after 16440 requests (16440 known processed) with 0 events remaining.
Nov 16 11:38:28 USERX systemd[1]: Stopping User Manager for UID 111...
Nov 16 11:38:28 USERX systemd[815]: Stopping D-Bus User Message Bus...
Nov 16 11:38:28 USERX systemd[815]: Stopped target Default.
Nov 16 11:38:28 USERX systemd[815]: Stopping Virtual filesystem service...
Nov 16 11:38:28 USERX systemd[815]: Stopped D-Bus User Message Bus.
Nov 16 11:38:28 USERX systemd[815]: Stopped Virtual filesystem service.
Nov 16 11:38:28 USERX systemd[815]: Stopped target Basic System.
Nov 16 11:38:28 USERX systemd[815]: Stopped target Timers.
Comment 1 Chris Wilson 2017-11-16 13:57:33 UTC
*** Bug 103777 has been marked as a duplicate of this bug. ***
Comment 2 Elizabeth 2017-12-04 23:22:02 UTC
Good afternoon Albator,
Have you tried with more recent kernel, preferable 4.13 or up? Also could you share your Mesa version, if default, try 17.2 or up if possible.
Comment 3 GitLab Migration User 2019-09-25 19:05:50 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1654.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.