Bug 103781 - Intel - display brightness control not working with i915.fastboot=1
Summary: Intel - display brightness control not working with i915.fastboot=1
Status: CLOSED DUPLICATE of bug 108225
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: low major
Assignee: Maarten Lankhorst
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-16 16:01 UTC by Arthur Borsboom
Modified: 2018-10-23 13:28 UTC (History)
2 users (show)

See Also:
i915 platform: HSW
i915 features: display/backlight


Attachments
dmesg when booted with the fastboot flag (55.97 KB, text/plain)
2017-11-16 16:01 UTC, Arthur Borsboom
no flags Details
Call intel_opregion_notify_encoder (568 bytes, patch)
2017-11-20 15:21 UTC, Maarten Lankhorst
no flags Details | Splinter Review
boot log with drm.debug (500.76 KB, text/plain)
2017-11-30 17:59 UTC, Arthur Borsboom
no flags Details
dmesg with fastboot and drm debugging enabled (217.81 KB, text/plain)
2018-09-10 15:22 UTC, Arthur Borsboom
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arthur Borsboom 2017-11-16 16:01:01 UTC
Created attachment 135522 [details]
dmesg when booted with the fastboot flag

Hardware: Asus N751JK laptop, i7-4710HQ
OS: Arch Linux
Kernel: 4.13.11
Kernel module: i915

While reading through a news article on Phoronix.com, I decided to test an upcoming kernel/driver feature: Intel display 'fastboot'.

This can be activated by the kernel option i915.fastboot=1
This indeed speeds up the boot process and reduces the flickering, but with a side effect. Normally I use the Fn-buttons to change the brightness of the (laptop) screen. This works fine without the fastboot kernel parameter.

This does not work anymore with the kernel parameter. It seems to be stuck at maximum brightness. When I press the reduce brightness button multiple times, the screen turns black. When I press then only 1 time the increase brightness button, the screen is back on at maximum brightness. 

dmesg when booted with the fastboot parameter is attached.

Is this misconfiguration, a bug or something else?
Do I need to provide more information and if so what?

Best regards,
Arthur Borsboom.
Comment 1 Maarten Lankhorst 2017-11-20 15:21:54 UTC
Created attachment 135605 [details] [review]
Call intel_opregion_notify_encoder

Just a hunch, does this work?
Comment 2 Arthur Borsboom 2017-11-20 15:39:33 UTC
Hi Maarten,

I am an application developer and not an OS/driver developer, so I cannot judge the hunch by looking at your patch. However, I can test, but I do need some instructions/guidance. :)

For example, against which (git) source do I have to apply your patch? After that, give me some time to get the hang of the kernel compilation and patching process.

How do you suggest I apply your patch?
Comment 3 Maarten Lankhorst 2017-11-21 06:57:21 UTC
You can build drm-tip by cloning git://anongit.freedesktop.org/drm-tip

To build you can use the patches from

http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/current/HEADER.html

After applying the patches you can also apply the patch I linked in this bug, and then build the kernel like you would for any other debian/ubuntu package.

If that doesn't work I can make some own packages, but that will take a while to upload.
Comment 4 Arthur Borsboom 2017-11-27 21:02:22 UTC
Hi Maarten,

I have cloned drm-tip, applied your patch, compiled and installed this kernel 4.15.0-rc1 to my daily system.

If I boot this kernel without the fastboot kernel option, the brightness keys still work. If I add 'i915.fastboot=1', then the brightness keys do not work as before anymore.

I also noticed that when using the fastboot method, the brightness of the screen is at maximum.
Comment 5 Maarten Lankhorst 2017-11-30 14:41:07 UTC
Can you get a boot log with drm.debug=0x1f with the patched kernel?
Comment 6 Arthur Borsboom 2017-11-30 17:59:11 UTC
Created attachment 135832 [details]
boot log with drm.debug

Requested boot log.
Comment 7 Arthur Borsboom 2017-11-30 17:59:20 UTC
Booted with the patched kernel including the fastboot and the drm debug setting.

Around 16 seconds the system has been booted.
Around 20 seconds I have pressed 4 or 5 times to decrease the backlight until the screen turned black. After that I have pressed 1 time to increase the backlist, which turned it on to maximum brightness again. 

See attachment.
Comment 8 Ivan Majhen 2018-03-02 10:56:26 UTC
Same here on same laptop with 4.15.5 kernel. It works after resume from suspend to ram.
Comment 9 Jani Saarinen 2018-03-29 07:10:45 UTC
First of all. Sorry about spam.
This is mass update for our bugs. 

Sorry if you feel this annoying but with this trying to understand if bug still valid or not.
If bug investigation still in progress, please ignore this and I apologize!

If you think this is not anymore valid, please comment to the bug that can be closed.
If you haven't tested with our latest pre-upstream tree(drm-tip), can you do that also to see if issue is valid there still and if you cannot see issue there, please comment to the bug.
Comment 10 Lakshmi 2018-09-08 22:57:37 UTC
Reporter, do you still have the issue?
Please try to reproduce the issue using drm-tip (https://cgit.freedesktop.org/drm-tip) and kernel parameters drm.debug=0x1e log_buf_len=4M, and if the problem persists attach the full dmesg from boot.
Comment 11 Arthur Borsboom 2018-09-10 15:22:06 UTC
Created attachment 141507 [details]
dmesg with fastboot and drm debugging enabled
Comment 12 Arthur Borsboom 2018-09-10 15:24:00 UTC
I have just tested the issue on the stable kernel on my laptop, since I do not have the knowledge yet to use 'drm-tip'.

The issue seems to remain with kernel 4.18.5 with a small difference that the screen does not turn black anymore, after pressing the Fn-Brightness down key many times.

I have added the dmesg output with DRM debugging enabled.

Is this sufficient information or is more needed?

If the drm-tip usage is a necessity, please provide detailed step-by-step instructions how to do that.
Comment 13 Lakshmi 2018-09-13 09:55:19 UTC
> The issue seems to remain with kernel 4.18.5 with a small difference that
> the screen does not turn black anymore, after pressing the Fn-Brightness
> down key many times.
> 
Does it mean, pressing reduce brightness button multiple times doesn't go black (which is the original problem) but stays full brightness.

Now the issue is that you are not able to reduce the brightness. Correct me, if I am wrong.
Comment 14 Arthur Borsboom 2018-09-14 13:40:06 UTC
The original problem is not the fact that the screen goes completely black. The original problem is that the brightness cannot be changed, except after pressing the Fn-Brightness-down for 10 or 20 times and then the screen turns black.

I will summarize the differences by the behavior below.

-----------------------------------------------------------
Fastboot disabled (default) / everything works as expected
-----------------------------------------------------------

Brightness keys function as expected. Brightness up + down keys change the intensity of the backlight with certain steps. Pressing the down button many times, will lower the backlight and finally turns of the screen and results in a black screen. 

-------------------------------------------------------------
Fastboot enabled with kernel 4.13.11 - 4.15.5 (original problem)
-------------------------------------------------------------
Pressing the brightness keys does not change the intensity of the backlight. Pressing the brightness down key many times, results in a black screen.

-------------------------------------------------------------
Fastboot enabled with kernel 4.18.5 - 4.15.5
-------------------------------------------------------------

Pressing the brightness keys does not change the intensity of the backlight. Pressing the brightness down key many times, does not result in a black screen anymore. I am not sure if that is good or bad, but something did change in comparison to previous kernels.


In other words, with fastboot enabled, I cannot change the brightness of the screen anymore with the brightness keys, as was the case without fastboot enabled.

Does this help sufficiently to understand the issue?
Comment 15 Jani Nikula 2018-10-23 11:22:03 UTC
Pretty sure this has been debugged in bug 108225. Resolving dupe. If the steps in that bug don't lead to similar results, please reopen.

*** This bug has been marked as a duplicate of bug 108225 ***
Comment 16 Lakshmi 2018-10-23 13:28:25 UTC
Closed as duplicate.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.