Bug 103783 - atombios stuck in loop for more than 5secs
Summary: atombios stuck in loop for more than 5secs
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-16 17:54 UTC by Rene Barbosa
Modified: 2017-12-05 18:38 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (123 bytes, text/plain)
2017-11-16 17:54 UTC, Rene Barbosa
no flags Details
lspci (10.39 KB, text/plain)
2017-11-16 17:55 UTC, Rene Barbosa
no flags Details
modules (6.79 KB, text/plain)
2017-11-16 17:55 UTC, Rene Barbosa
no flags Details
dmesg (74.08 KB, text/plain)
2017-11-16 18:10 UTC, Rene Barbosa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Barbosa 2017-11-16 17:54:35 UTC
Created attachment 135524 [details]
dmesg

Hello there,

I'm using Ubuntu 17.10 (fully updated) and my system is crashing at shutdown. It's freezing until I force a reboot/shutdown using Magic SysRq.

The error is:

Nov 6 22:16:49 rene-Inspiron-5447 kernel: [ 248.294280] [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 5secs aborting
Nov 6 22:16:49 rene-Inspiron-5447 kernel: [ 248.294336] [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing 75A8 (len 272, WS 0, PS 4) @ 0x75F1
Nov 6 22:16:49 rene-Inspiron-5447 kernel: [ 248.294384] [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing 640C (len 68, WS 0, PS 8) @ 0x6430]

This behavior is only happening when my laptop is charging. When running on battery I got a clean shutdown/reboot.

Already tried to run the latest kernel package from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14 and the problem is exactly the same.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: linux-image-4.13.0-16-generic 4.13.0-16.19 [modified: boot/vmlinuz-4.13.0-16-generic]
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: rene 1249 F.... pulseaudio
 /dev/snd/controlC0: rene 1249 F.... pulseaudio
CurrentDesktop: GNOME
Date: Wed Nov 8 01:00:51 2017
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=0f3b9237-1086-430d-be15-043b9ca00fd2
InstallationDate: Installed on 2017-11-06 (1 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
MachineType: Dell Inc. Inspiron 5447
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.13.0-16-generic.efi.signed root=UUID=1237aa76-9a2f-4a06-8552-526f124914ff ro quiet splash acpi_backlight=intel_backlight
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-16-generic N/A
 linux-backports-modules-4.13.0-16-generic N/A
 linux-firmware 1.169
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/25/2016
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.name: 0MHP6R
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A10
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd08/25/2016:svnDellInc.:pnInspiron5447:pvrA10:rvnDellInc.:rn0MHP6R:rvrA00:cvnDellInc.:ct8:cvrA10:
dmi.product.family: 00
dmi.product.name: Inspiron 5447
dmi.product.version: A10
dmi.sys.vendor: Dell Inc.
Comment 1 Rene Barbosa 2017-11-16 17:55:13 UTC
Created attachment 135525 [details]
lspci
Comment 2 Rene Barbosa 2017-11-16 17:55:34 UTC
Created attachment 135526 [details]
modules
Comment 3 Alex Deucher 2017-11-16 18:00:00 UTC
(In reply to Rene Barbosa from comment #0)
> Created attachment 135524 [details]
> dmesg

Looks like you attached the wrong file.  Please attach your full dmesg output.
Comment 4 Rene Barbosa 2017-11-16 18:10:09 UTC
Created attachment 135527 [details]
dmesg
Comment 5 Rene Barbosa 2017-11-16 18:10:51 UTC
Err. Sorry about that.
I've uploaded the correct file now.
Comment 6 Rene Barbosa 2017-11-16 19:36:45 UTC
An interesting information: It's only with open source amdgpu driver. With amdgpu-pro it's not happening but this driver isn't compatible with Ubuntu 17.10.
Comment 7 vkrevs 2017-11-18 20:54:52 UTC
I've got a similar issue on a recently purchased Dell Inspiron 5770 with an AMD Radeon 530 graphics card with openSUSE Tumbleweed.

Reboot or attempt to switch to text console causes a hang and /var/log/messages contains the above message + kernel bug with a stack trace. Full details are here:

https://bugzilla.opensuse.org/show_bug.cgi?id=1068793
Comment 8 Rene Barbosa 2017-11-24 22:28:21 UTC
vkrevs@yahoo.com, 

Are you using TLP or something similar?

I ran some tests and found that's only happening when using TLP. Tried with Ubuntu 17.10 and Fedora 27, same results.

Regards, 
Rene Barbosa
Comment 9 vkrevs 2017-11-25 09:21:33 UTC
Looks like TLP was installed on my laptop at initial installation time.

rpm -qa  | grep -i tlp
tlp-1.0-1.2.noarch
tlp-rdw-1.0-1.2.noarch


The latest openSUSE Tumbleed snapshot switched to 4.14 kernel - I got the same issue with that too on first boot. The bug report in openSUSE's bugzilla contains the /var/log/messages for that first boot with 4.14.
Comment 10 vkrevs 2017-11-25 11:08:07 UTC
OTOH, TLP services are not enabled according to tlp-stat -s, so does that mean my laptop is not using TLP after all?

tlp-stat -s
--- TLP 1.0 --------------------------------------------

+++ System Info
System         = Dell Inc. Inspiron 5770
BIOS           = 1.0.5
Release        = "openSUSE Tumbleweed"
Kernel         = 4.14.0-1-default #1 SMP PREEMPT Mon Nov 13 21:02:46 UTC 2017 (ab9e909) x86_64
/proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-4.14.0-1-default root=UUID=d58e8e85-bfdd-4a74-a694-5149ccd85110 quiet resume=/dev/sda3 splash=silent quiet showopts
Init system    = systemd v234
Boot mode      = UEFI

+++ TLP Status
State          = enabled
Last run       = 11:02:47,     14 sec(s) ago
Mode           = AC
Power source   = AC

Notice: tlp.service is not enabled -- invoke "systemctl enable tlp.service" to correct this!
Notice: tlp-sleep.service is not enabled -- invoke "systemctl enable tlp-sleep.service" to correct this!
Notice: systemd-rfkill.service is not masked -- invoke "systemctl mask systemd-rfkill.service" to correct this!
Comment 11 Rene Barbosa 2017-11-27 12:49:06 UTC
These systemd services are not running but according to tlp-stat, it's enabled.
Can you try to uninstall these packages and see if the error persists?

In my laptop, the problem is only happening when I install/enable them. Is it a power management bug?

Regards, 
Rene Barbosa
Comment 12 vkrevs 2017-11-27 20:03:27 UTC
Uninstalling tlp and tlp-rdw packages eliminates the error. 

What I don't get is that runtime pm for amggpu driver is supposed to be disabled by default according to TLP docs.

I'll try reinstalling TLP and follow the TLP troubleshooting guide to see exactly what setting is causing this.
Comment 13 Rene Barbosa 2017-11-28 01:38:38 UTC
Hey, 

Is your system using 'pcieport' module?

I've added it to RUNTIME_PM_DRIVER_BLACKLIST in TLP's configuration and now the problem is fixed!

Not sure why it's happening in Linux 4.13+ and not in 4.4 with AMDGPU-Pro installed.
Comment 14 vkrevs 2017-12-05 18:38:59 UTC
Hi Rene,

Sorry for the delay in responding. Thanks for your suggestion regarding the pcieport module. Adding it to RUNTIME_PM_DRIVER_BLACKLIST does fix the problem while TLP is installed.

Vadym


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.