Bug 103874 - The Witcher 3: flickering regression with radeonsi
Summary: The Witcher 3: flickering regression with radeonsi
Status: RESOLVED DUPLICATE of bug 103808
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-24 03:23 UTC by Shmerl
Modified: 2017-11-27 10:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shmerl 2017-11-24 03:23:20 UTC
With latest Mesa master, The Witcher 3 in Wine started performing worse and it also introduced noticeable flickering (once in a few seconds).

I was able to narrow down this flickering to these commits by Marek:

adab7f16ffd3ea4c52e8d07f40ca6ae4868c3706 2017-11-06 radeonsi: don't map big VRAM buffers for the first upload directly

4b0dc098b2561c07c59f7dab2813640a25789bf1 2017-11-06 gallium/u_threaded: don't map big VRAM buffers for the first upload directly

a5d3999c31e2460f690b561b41170bb7bc24fc65 2017-11-06 gallium/u_threaded: clean up tc_improve_map_buffer_flags and prevent reentry

One commit before them this flickering doesn't occur:

OpenGL renderer string: AMD Radeon (TM) RX 480 Graphics (POLARIS10 / DRM 3.18.0 / 4.13.0-1-amd64, LLVM 5.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.4.0-devel (git-60a9705e00)

And with them, it does:

OpenGL renderer string: AMD Radeon (TM) RX 480 Graphics (POLARIS10 / DRM 3.18.0 / 4.13.0-1-amd64, LLVM 5.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.4.0-devel (git-adab7f16ff)

I'm running The Witcher3 with mesa_glthread and csmt enabled (both). You can use latest Wine staging to test it.
Comment 1 Nicolai Hähnle 2017-11-27 10:40:46 UTC
Thanks for the report. This is likely a duplicate of bug #103808.

*** This bug has been marked as a duplicate of bug 103808 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.