Bug 104172 - [BAT] igt@kms_pipe_crc_basic@suspend-read-crc-pipe-[a|b|c] - dmesg-warn - Unclaimed read from register 0x71240 -WARNING: CPU: 7 PID: 3246 at drivers/gpu/drm/i915/intel_uncore.c:986 __unclaimed_reg_debug+0x3b/0x50 [i915]
Summary: [BAT] igt@kms_pipe_crc_basic@suspend-read-crc-pipe-[a|b|c] - dmesg-warn - Unc...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Marta Löfstedt
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-08 11:56 UTC by Marta Löfstedt
Modified: 2018-01-17 11:43 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2017-12-08 11:56:42 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3480/fi-kbl-r/igt@kms_pipe_crc_basic@suspend-read-crc-pipe-a.html

<6>[  464.323758] serial 00:06: activated
<4>[  464.323772] ------------[ cut here ]------------
<4>[  464.323784] Unclaimed read from register 0x71240
<4>[  464.323814] WARNING: CPU: 7 PID: 3246 at drivers/gpu/drm/i915/intel_uncore.c:986 __unclaimed_reg_debug+0x3b/0x50 [i915]
<4>[  464.323815] Modules linked in: vgem snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic asix usbnet mii i915 x86_pkg_temp_thermal intel_powerclamp coretemp crct10dif_pclmul crc32_pclmul snd_hda_intel ghash_clmulni_intel snd_hda_codec snd_hwdep e1000e snd_hda_core snd_pcm mei_me ptp mei pps_core prime_numbers pinctrl_sunrisepoint pinctrl_intel
<4>[  464.323845] CPU: 7 PID: 3246 Comm: kworker/u16:39 Tainted: G     U           4.15.0-rc2-CI-CI_DRM_3480+ #1
<4>[  464.323846] Hardware name: Intel Corporation Kabylake Client platform/Kabylake R DDR4 RVP, BIOS KBLSE2R1.R00.X078.P02.1703030515 03/03/2017
<4>[  464.323849] Workqueue: events_unbound async_run_entry_fn
<4>[  464.323851] task: 000000000b2371bc task.stack: 00000000aac1762f
<4>[  464.323868] RIP: 0010:__unclaimed_reg_debug+0x3b/0x50 [i915]
<4>[  464.323869] RSP: 0018:ffffc900008bfb10 EFLAGS: 00010086
<4>[  464.323871] RAX: 0000000000000024 RBX: 0000000000000000 RCX: 0000000000000002
<4>[  464.323872] RDX: 0000000000000000 RSI: ffffffff81d057c9 RDI: ffffffff81cb6b16
<4>[  464.323873] RBP: 0000000000071240 R08: 0000000000000000 R09: 0000000000000001
<4>[  464.323874] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000001
<4>[  464.323875] R13: ffff8802ab100ca8 R14: 0000000000000000 R15: 0000000000000206
<4>[  464.323877] FS:  0000000000000000(0000) GS:ffff8802bedc0000(0000) knlGS:0000000000000000
<4>[  464.323878] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4>[  464.323879] CR2: 00005643ea472028 CR3: 0000000003e10005 CR4: 00000000003606e0
<4>[  464.323880] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
<4>[  464.323881] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
<4>[  464.323882] Call Trace:
<4>[  464.323900]  fwtable_read32+0x214/0x290 [i915]
<4>[  464.323915]  skl_pipe_wm_get_hw_state+0xc9/0x1e0 [i915]
<4>[  464.323932]  skl_wm_get_hw_state+0x4d/0xd0 [i915]
<4>[  464.323952]  intel_modeset_setup_hw_state+0xee8/0xf80 [i915]
<4>[  464.323959]  ? pci_pm_suspend_late+0x30/0x30
<4>[  464.323976]  __intel_display_resume+0x19/0xc0 [i915]
<4>[  464.323994]  intel_display_resume+0xbc/0xf0 [i915]
<4>[  464.323997]  ? __mutex_unlock_slowpath+0x38/0x270
<4>[  464.324014]  i915_pm_restore+0xc4/0x140 [i915]
<4>[  464.324017]  dpm_run_callback+0x5f/0x310
<4>[  464.324021]  device_resume+0xa3/0x1b0
<4>[  464.324025]  ? dpm_watchdog_set+0x60/0x60
<4>[  464.324030]  async_resume+0x14/0x40
<4>[  464.324032]  async_run_entry_fn+0x2e/0x160
<4>[  464.324035]  process_one_work+0x227/0x650
<4>[  464.324041]  worker_thread+0x48/0x3a0
<4>[  464.324046]  kthread+0x173/0x1b0
<4>[  464.324048]  ? process_one_work+0x650/0x650
<4>[  464.324049]  ? _kthread_create_on_node+0x30/0x30
<4>[  464.324052]  ret_from_fork+0x24/0x30
<4>[  464.324060] Code: 3c 01 75 30 84 db 75 2c 45 84 e4 48 c7 c0 3a d1 2b a0 48 c7 c6 30 d1 2b a0 48 0f 44 f0 89 ea 48 c7 c7 43 d1 2b a0 e8 f5 93 e7 e0 <0f> ff 83 2d 3c 78 16 00 01 5b 5d 41 5c c3 0f 1f 80 00 00 00 00 
<4>[  464.324119] ---[ end trace 5d435f000ce4dd4e ]---
Comment 1 Marta Löfstedt 2017-12-11 07:41:38 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3494/fi-kbl-r/igt@kms_pipe_crc_basic@suspend-read-crc-pipe-c.html

[  481.292281] Suspending console(s) (use no_console_suspend to debug)
[  497.284461] ------------[ cut here ]------------
[  497.284475] Unclaimed read from register 0x71240
[  497.284507] WARNING: CPU: 3 PID: 3202 at drivers/gpu/drm/i915/intel_uncore.c:986 __unclaimed_reg_debug+0x3b/0x50 [i915]
[  497.284509] Modules linked in: vgem snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic asix usbnet mii i915 x86_pkg_temp_thermal intel_powerclamp coretemp snd_hda_intel e1000e crct10dif_pclmul snd_hda_codec crc32_pclmul snd_hwdep ghash_clmulni_intel snd_hda_core snd_pcm ptp pps_core mei_me mei prime_numbers pinctrl_sunrisepoint pinctrl_intel
[  497.284541] CPU: 3 PID: 3202 Comm: kworker/u16:66 Tainted: G     U           4.15.0-rc2-CI-CI_DRM_3494+ #1
[  497.284543] Hardware name: Intel Corporation Kabylake Client platform/Kabylake R DDR4 RVP, BIOS KBLSE2R1.R00.X078.P02.1703030515 03/03/2017
[  497.284545] Workqueue: events_unbound async_run_entry_fn
[  497.284548] task: 00000000b17ee485 task.stack: 00000000a69e7c1f
[  497.284567] RIP: 0010:__unclaimed_reg_debug+0x3b/0x50 [i915]
[  497.284568] RSP: 0018:ffffc90000ac7b10 EFLAGS: 00010086
[  497.284570] RAX: 0000000000000024 RBX: 0000000000000000 RCX: 0000000000000002
[  497.284572] RDX: 0000000000000000 RSI: ffffffff81d057c9 RDI: ffffffff81cb6b16
[  497.284573] RBP: 0000000000071240 R08: 0000000000000000 R09: 0000000000000001
[  497.284574] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000001
[  497.284575] R13: ffff8802a0c40ca8 R14: 0000000000000000 R15: 0000000000000206
[  497.284577] FS:  0000000000000000(0000) GS:ffff8802becc0000(0000) knlGS:0000000000000000
[  497.284578] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  497.284579] CR2: 000055bd95f0ad80 CR3: 0000000003e10004 CR4: 00000000003606e0
[  497.284581] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[  497.284582] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[  497.284583] Call Trace:
[  497.284603]  fwtable_read32+0x214/0x290 [i915]
[  497.284620]  skl_pipe_wm_get_hw_state+0xc9/0x1e0 [i915]
[  497.284639]  skl_wm_get_hw_state+0x4d/0xd0 [i915]
[  497.284661]  intel_modeset_setup_hw_state+0xee8/0xf80 [i915]
[  497.284668]  ? pci_pm_suspend_late+0x30/0x30
[  497.284688]  __intel_display_resume+0x19/0xc0 [i915]
[  497.284708]  intel_display_resume+0xbc/0xf0 [i915]
[  497.284712]  ? __mutex_unlock_slowpath+0x38/0x270
[  497.284731]  i915_pm_restore+0xc4/0x140 [i915]
[  497.284735]  dpm_run_callback+0x5f/0x310
[  497.284739]  device_resume+0xa3/0x1b0
[  497.284743]  ? dpm_watchdog_set+0x60/0x60
[  497.284749]  async_resume+0x14/0x40
[  497.284751]  async_run_entry_fn+0x2e/0x160
[  497.284755]  process_one_work+0x227/0x650
[  497.284762]  worker_thread+0x48/0x3a0
[  497.284767]  kthread+0x173/0x1b0
[  497.284769]  ? process_one_work+0x650/0x650
[  497.284771]  ? _kthread_create_on_node+0x30/0x30
[  497.284774]  ret_from_fork+0x24/0x30
[  497.284783] Code: 3c 01 75 30 84 db 75 2c 45 84 e4 48 c7 c0 88 91 2f a0 48 c7 c6 7e 91 2f a0 48 0f 44 f0 89 ea 48 c7 c7 91 91 2f a0 e8 85 d3 e3 e0 <0f> ff 83 2d cc 77 16 00 01 5b 5d 41 5c c3 0f 1f 80 00 00 00 00 
[  497.284850] ---[ end trace b58b1c00140dfed2 ]---
[  497.516464] atkbd serio0: Failed to deactivate keyboard on isa0060/serio0
[  497.892287] atkbd serio0: Failed to enable keyboard on isa0060/serio0
Comment 2 Marta Löfstedt 2017-12-11 07:41:53 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4054/fi-kbl-r/igt@kms_pipe_crc_basic@suspend-read-crc-pipe-b.html

	

[  493.244744] Suspending console(s) (use no_console_suspend to debug)
[  509.318824] ------------[ cut here ]------------
[  509.318838] Unclaimed read from register 0x71240
[  509.318869] WARNING: CPU: 5 PID: 3236 at drivers/gpu/drm/i915/intel_uncore.c:986 __unclaimed_reg_debug+0x3b/0x50 [i915]
[  509.318870] Modules linked in: vgem snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic asix usbnet mii i915 x86_pkg_temp_thermal snd_hda_intel intel_powerclamp snd_hda_codec coretemp e1000e crct10dif_pclmul crc32_pclmul snd_hwdep snd_hda_core ghash_clmulni_intel snd_pcm ptp pps_core mei_me mei prime_numbers pinctrl_sunrisepoint pinctrl_intel
[  509.318902] CPU: 5 PID: 3236 Comm: kworker/u16:18 Tainted: G     U           4.15.0-rc2-CI-CI_DRM_3495+ #1
[  509.318904] Hardware name: Intel Corporation Kabylake Client platform/Kabylake R DDR4 RVP, BIOS KBLSE2R1.R00.X078.P02.1703030515 03/03/2017
[  509.318907] Workqueue: events_unbound async_run_entry_fn
[  509.318909] task: 00000000ba5bfcc9 task.stack: 0000000030374e5b
[  509.318927] RIP: 0010:__unclaimed_reg_debug+0x3b/0x50 [i915]
[  509.318929] RSP: 0018:ffffc9000045fb10 EFLAGS: 00010086
[  509.318931] RAX: 0000000000000024 RBX: 0000000000000000 RCX: 0000000000000002
[  509.318933] RDX: 0000000000000000 RSI: ffffffff81d057c9 RDI: ffffffff81cb6b16
[  509.318934] RBP: 0000000000071240 R08: 0000000000000000 R09: 0000000000000001
[  509.318935] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000001
[  509.318936] R13: ffff8802a8470ca8 R14: 0000000000000000 R15: 0000000000000206
[  509.318938] FS:  0000000000000000(0000) GS:ffff8802bed40000(0000) knlGS:0000000000000000
[  509.318939] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  509.318940] CR2: 000000000172d068 CR3: 0000000003e10004 CR4: 00000000003606e0
[  509.318941] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[  509.318943] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[  509.318944] Call Trace:
[  509.318964]  fwtable_read32+0x214/0x290 [i915]
[  509.318981]  skl_pipe_wm_get_hw_state+0xc9/0x1e0 [i915]
[  509.319000]  skl_wm_get_hw_state+0x4d/0xd0 [i915]
[  509.319022]  intel_modeset_setup_hw_state+0xee8/0xf80 [i915]
[  509.319029]  ? pci_pm_suspend_late+0x30/0x30
[  509.319048]  __intel_display_resume+0x19/0xc0 [i915]
[  509.319069]  intel_display_resume+0xbc/0xf0 [i915]
[  509.319072]  ? __mutex_unlock_slowpath+0x38/0x270
[  509.319092]  i915_pm_restore+0xc4/0x140 [i915]
[  509.319095]  dpm_run_callback+0x5f/0x310
[  509.319099]  device_resume+0xa3/0x1b0
[  509.319103]  ? dpm_watchdog_set+0x60/0x60
[  509.319109]  async_resume+0x14/0x40
[  509.319111]  async_run_entry_fn+0x2e/0x160
[  509.319115]  process_one_work+0x227/0x650
[  509.319122]  worker_thread+0x48/0x3a0
[  509.319127]  kthread+0x173/0x1b0
[  509.319129]  ? process_one_work+0x650/0x650
[  509.319131]  ? _kthread_create_on_node+0x30/0x30
[  509.319134]  ret_from_fork+0x24/0x30
[  509.319143] Code: 3c 01 75 30 84 db 75 2c 45 84 e4 48 c7 c0 88 91 2d a0 48 c7 c6 7e 91 2d a0 48 0f 44 f0 89 ea 48 c7 c7 91 91 2d a0 e8 85 d3 e5 e0 <0f> ff 83 2d cc 77 16 00 01 5b 5d 41 5c c3 0f 1f 80 00 00 00 00 
[  509.319210] ---[ end trace 505b718db1bac3a6 ]---
[  509.550616] atkbd serio0: Failed to deactivate keyboard on isa0060/serio0
[  509.617677] done.
[  509.934552] atkbd serio0: Failed to enable keyboard on isa0060/serio0
Comment 3 Marta Löfstedt 2017-12-11 10:00:12 UTC
This looks like a regression that for the first time occurred on:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3480/fi-kbl-r/igt@kms_pipe_crc_basic@suspend-read-crc-pipe-a.html

then it has been on each run on at least on of the igt@kms_pipe_crc_basic@suspend-read-crc-pipe-[a|b|c] subtest except on CI_DRM_3493.
Comment 4 Marta Löfstedt 2017-12-11 15:17:15 UTC
Try-bot with revert of b68763741aa29f2541c7ca58bcb0c2bb6cb5f449

https://patchwork.freedesktop.org/series/35182/
Comment 5 Marta Löfstedt 2017-12-12 07:32:24 UTC
Result from 2 try-bot runs the issue isn't reproduced I have queued up another round:

https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_1507/issues.html
Comment 6 Marta Löfstedt 2017-12-12 08:59:31 UTC
The revert now has 3 runs and the issue isn't reproduced.

https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_1511/issues.html
Comment 7 Maarten Lankhorst 2017-12-12 12:46:25 UTC
https://patchwork.freedesktop.org/patch/192935/
Comment 8 Maarten Lankhorst 2018-01-16 18:02:41 UTC
commit ac25dfed15d470d7f23dd817e965b54aa3f94a1e (HEAD -> drm-intel-next-queued, drm-intel/drm-intel-next-queued)
Author: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Date:   Tue Jan 16 16:53:24 2018 +0100

    drm/i915: Always call to intel_display_set_init_power() in resume_early.
Comment 9 Marta Löfstedt 2018-01-17 08:20:03 UTC
fix integrated to CI_DRM_3637, I will close after some more green runs.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.