Bug 104260 - [BAT] igt@kms_psr_sink_crc@psr_basic - dmesg-warn - *ERROR* Potential atomic update failure on pipe A
Summary: [BAT] igt@kms_psr_sink_crc@psr_basic - dmesg-warn - *ERROR* Potential atomic ...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Marta Löfstedt
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-14 09:18 UTC by Marta Löfstedt
Modified: 2018-01-08 12:16 UTC (History)
1 user (show)

See Also:
i915 platform: KBL, SKL
i915 features: display/PSR


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2017-12-14 09:18:54 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3514/fi-kbl-7560u/igt@kms_psr_sink_crc@psr_basic.html

[  433.655111] [drm:intel_pipe_update_start [i915]] *ERROR* Potential atomic update failure on pipe A

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3514/fi-skl-6600u/igt@kms_psr_sink_crc@psr_basic.html

[  454.001572] [drm:intel_pipe_update_start [i915]] *ERROR* Potential atomic update failure on pipe A

there is already bug 104095 and bug 103821. However, since this was on smae run 2 tests 2 machines, I believe it deserves its own bug, since it is a potential regression.
Comment 1 Marta Löfstedt 2017-12-18 12:04:44 UTC
Also, see https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3516/fi-skl-6700hq/igt@kms_psr_sink_crc@psr_basic.html 

started flip-flopping on the same issue.
Comment 2 Marta Löfstedt 2017-12-18 12:11:19 UTC
This IGT run appear to be the first occurrence:

https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4063/fi-kbl-7560u/igt%40kms_psr_sink_crc%40psr_basic.html
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4063/fi-skl-6600u/igt%40kms_psr_sink_crc%40psr_basic.html

Note this is on CI_DRM_3513 i.e. so this is probably due to IGT change.
Comment 3 Marta Löfstedt 2018-01-04 10:30:51 UTC
Note the dmesg appear to come when the subtest is exiting:

<7>[  433.630093] [IGT] kms_psr_sink_crc: exiting, ret=0
<4>[  433.630477] Setting dangerous option enable_psr - tainting kernel
<3>[  433.655111] [drm:intel_pipe_update_start [i915]] *ERROR* Potential atomic update failure on pipe A
<7>[  433.775081] [IGT] kms_setmode: executing
Comment 4 Marta Löfstedt 2018-01-04 11:55:02 UTC
This appear to fix it:

https://patchwork.freedesktop.org/series/36000/
Comment 5 Marta Löfstedt 2018-01-04 13:52:24 UTC
Also tested if I should do the same update to the psr_drrs subtest, but that looks green...

https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_744/all.html
Comment 6 Marta Löfstedt 2018-01-05 10:57:34 UTC
Fixed by:

https://patchwork.freedesktop.org/series/36065/
Comment 7 Marta Löfstedt 2018-01-08 11:43:08 UTC
Fixed by:

commit 472ecd3b2e24bd07128c0a42609a2940c8fd07ed
Author: Marta Lofstedt <marta.lofstedt@intel.com>
Date:   Fri Jan 5 11:04:13 2018 +0200

    test/kms_psr_sink_crc - subtests psr_basic and psr_drrs need test cleanup
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=104260
    Signed-off-by: Marta Lofstedt <marta.lofstedt@intel.com>
    Reviewed-by: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.