Bug 104384 - [skl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg
Summary: [skl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-26 08:30 UTC by advocatux
Modified: 2018-03-14 23:37 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error dump (41.70 KB, text/plain)
2017-12-26 08:30 UTC, advocatux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description advocatux 2017-12-26 08:30:35 UTC
Created attachment 136387 [details]
/sys/class/drm/card0/error dump

PC running Debian (Sid) + KDE

Kernel: Linux version 4.14.0-2-amd64 (debian-kernel@lists.debian.org) (gcc version 7.2.0 (Debian 7.2.0-18)) #1 SMP Debian 4.14.7-1 (2017-12-22)

OpenGL version string: 3.0 Mesa 17.3.1

VGA compatible controller: Intel Corporation HD Graphics 510 (rev 06)

Attached crash dump from /sys/class/drm/card0/error

PS Dear devs, thank you for your work.
Comment 1 Elizabeth 2017-12-27 16:17:38 UTC
Hello Advocatux, any way to reproduce/trigger this? Thank you.
Comment 2 advocatux 2017-12-27 21:59:35 UTC
(In reply to Elizabeth from comment #1)
> Hello Advocatux, any way to reproduce/trigger this? Thank you.

Hello Elizabeth, and thank you for your interest.

Alas this bug seems completely random, so I don't know how to trigger it.

The only pattern is that it happens when I'm opening a program in KDE, never when closing it, at least for now.

Just a moment ago it happened again when I've tried to open Firefox. Do you want to see the crash dump?
Comment 3 Elizabeth 2017-12-27 22:16:45 UTC
I don't expect to see much differences if the environment haven't changed. It is possible to check if it happens with another desktop, like gnome? Just to check if this is desktop dependent.
Comment 4 advocatux 2017-12-28 08:05:32 UTC
(In reply to Elizabeth from comment #3)
> I don't expect to see much differences if the environment haven't changed.
> It is possible to check if it happens with another desktop, like gnome? Just
> to check if this is desktop dependent.

I can't do it now but I'll give gnome a try in the coming days.
Comment 5 advocatux 2018-02-25 21:03:28 UTC
Update
******

I didn't suffer this random bug while running Gnome but maybe I didn't run it for a long enough time. The same happens with KDE, days may pass without any hang and then two or three hangs in the same day.

Anyway I've seen other people reporting this bug with other desktops than KDE and it seems the recommended action is to try Mesa 18.0.0, and that's what I'm doing.

Let see how it goes, and I'll report any bug I may find.
Comment 6 Elizabeth 2018-03-06 20:12:52 UTC
If KDE is suspected, the latest fixes in the mesa 17.3.6 release could help.
Comment 7 advocatux 2018-03-06 22:09:09 UTC
(In reply to Elizabeth from comment #6)
> If KDE is suspected, the latest fixes in the mesa 17.3.6 release could help.

KDE is not really a suspect to me, I mentioned it because you asked me to try Gnome, I did, and then I came back to KDE.

Anyway I'm running KDE with Mesa 18.0.0 now and, since my last comment (2018-02-25) I haven't suffered any crash, so it seems fixed.

Thank you for your work.
Comment 8 Elizabeth 2018-03-14 23:37:44 UTC
Thanks for the update and clarify the KDE topic. I'm marking as resolve then. Thanks again for you time.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.