Bug 104422 - [kbl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [427]
Summary: [kbl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [427]
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium critical
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-30 23:56 UTC by Ramiro Magno
Modified: 2019-09-25 19:06 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (67.54 KB, text/plain)
2017-12-30 23:56 UTC, Ramiro Magno
Details
output of /sys/class/drm/card0/error (50.20 KB, text/plain)
2017-12-30 23:58 UTC, Ramiro Magno
Details
machine hardware details (14.71 KB, text/plain)
2017-12-30 23:59 UTC, Ramiro Magno
Details
output of "xrandr --verbose" (5.94 KB, text/plain)
2017-12-30 23:59 UTC, Ramiro Magno
Details
GPU crash dump saved to /sys/class/drm/card0/error (51.94 KB, text/plain)
2018-02-10 11:53 UTC, Claudio
Details
extract from kern.log (119.92 KB, text/plain)
2018-02-10 12:15 UTC, Claudio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ramiro Magno 2017-12-30 23:56:02 UTC
Created attachment 136454 [details]
dmesg output

Machine: Dell XPS 13 9360

uname -a: Linux midget 4.14.6-1-ARCH #1 SMP PREEMPT Thu Dec 14 21:26:16 UTC 2017 x86_64 GNU/Linux

See attachments for more details.
Comment 1 Ramiro Magno 2017-12-30 23:58:56 UTC
Created attachment 136455 [details]
output of /sys/class/drm/card0/error
Comment 2 Ramiro Magno 2017-12-30 23:59:18 UTC
Created attachment 136456 [details]
machine hardware details
Comment 3 Ramiro Magno 2017-12-30 23:59:58 UTC
Created attachment 136457 [details]
output of "xrandr --verbose"
Comment 4 Ramiro Magno 2017-12-31 00:04:54 UTC
I was using jabref (https://www.jabref.org/) version 4.1, which depends on the java runtime environment. Java runtime env is OpenJDK Java 8.
Comment 5 Elizabeth 2018-01-05 22:32:47 UTC
Hello Ramiro,
Could you please share your mesa version? Is this easily reproducible? 
Thanks.
Comment 6 Ramiro Magno 2018-01-06 02:01:07 UTC
hi Beth

my mesa version is 17.3.0.

I could not reproduce it anymore though..
Comment 7 Elizabeth 2018-01-11 17:43:39 UTC
Thanks Ramiro. Leaving as NEEDINFO while more sights of this issue are reported.
Comment 8 Claudio 2018-02-10 11:53:51 UTC
Created attachment 137255 [details]
GPU crash dump saved to /sys/class/drm/card0/error
Comment 9 Claudio 2018-02-10 11:56:48 UTC
Hi.
I'm encountering the same problem.

Using Dell XPS 13 9360/0PF86Y, BIOS 2.3.1 10/03/2017

uname -a: Linux onthego 4.14.0-041400-generic #201711122031 SMP Sun Nov 12 20:32:29 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

It so far has only happened when I have a second screen plugged in and am actively working with the DrRacket application, but so far it has always happened after a few minutes of running the application. So I can replicate it if required.

The previous attachment I created is the crash log, and am going to attach the output from kern.log next.
Comment 10 Claudio 2018-02-10 12:15:48 UTC
Created attachment 137256 [details]
extract from kern.log
Comment 11 Claudio 2018-02-10 13:12:02 UTC
I'm actually finding a lot of similarities between my problem and [this other bug](https://bugs.freedesktop.org/show_bug.cgi?id=104578), as DrRacket uses emacs keybindings.

I will keep following both, but unfortunately I ran out of time before I could compile the latest Mesa 18.0-rc4 to test it, so I'll follow both this and the other thread and either wait for a `.deb` to be released, or try to compile the latest rc when I have time.

Btw, my mesa version is still 17.2.4, and I'm running Ubuntu 16.04.3.
Comment 12 Elizabeth 2018-03-14 23:34:51 UTC
Hello, if it's emacs related, it should be fixed with mesa 17.3.6. Could you try it and report back. Thank you.
Comment 13 GitLab Migration User 2019-09-25 19:06:55 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1668.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.