Bug 104440 - [skl] GPU HANG: ecode 9:0:0x84df1cfc, in stanley_linux (Stanley Parable)
Summary: [skl] GPU HANG: ecode 9:0:0x84df1cfc, in stanley_linux (Stanley Parable)
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-01 22:22 UTC by Jethro Beekman
Modified: 2019-09-25 19:06 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (111.27 KB, application/x-xz)
2018-01-01 22:22 UTC, Jethro Beekman
Details
/sys/class/drm/card0/error (again) (115.93 KB, application/x-xz)
2018-01-01 22:37 UTC, Jethro Beekman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jethro Beekman 2018-01-01 22:22:32 UTC
Created attachment 136473 [details]
/sys/class/drm/card0/error

This happens every time in the same location in the game (Stanley Parable)

jan 01 14:18:20 jethro kernel: [drm] GPU HANG: ecode 9:0:0x84df1cfc, in stanley_linux [1772], reason: Hang on rcs0, action: reset
jan 01 14:18:20 jethro kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
jan 01 14:18:20 jethro kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
jan 01 14:18:20 jethro kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
jan 01 14:18:20 jethro kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
jan 01 14:18:20 jethro kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
jan 01 14:18:20 jethro kernel: i915 0000:00:02.0: Resetting rcs0 after gpu hang
Comment 1 Jethro Beekman 2018-01-01 22:37:26 UTC
Created attachment 136474 [details]
/sys/class/drm/card0/error (again)

Same crash after upgrading to latest kernel/mesa.
Comment 2 Elizabeth 2018-01-05 22:53:43 UTC
(In reply to Jethro Beekman from comment #1)
> Created attachment 136474 [details]
> /sys/class/drm/card0/error (again)
> 
> Same crash after upgrading to latest kernel/mesa.
Hello Jethro, what mesa is it? How long ahead it crash, like some minutes or..?
What desktop are you using? If is steam, do it gives any trace back when crashes?
Thank you.
Comment 3 Jethro Beekman 2018-01-06 19:04:07 UTC
This is with mesa 17.3.1-2.

It always crashes in the same spot in the game. Take the left door, then go up the stairs. The crash happens right as you start ascending the stairs. I don't think it matters how long you take to get there.

What do you mean by desktop? I'm using Arch Linux, with xorg-server 1.19.6-2 and cinnamon 3.6.7-1.

I am using Steam. I'm not sure where to find the traceback. I have to restart the window manager from the text console if this crash happens, because X hangs.

I tried reproducing it today to give you some more information, but I'm unable to reproduce this again now...
Comment 4 Elizabeth 2018-01-11 17:48:25 UTC
If you start steam by terminal, when a crash is reported the path is show there, something like /tmp/dump/crash...
Do you know if this worked without issues in some previous Mesa version??
Comment 5 Denis 2018-09-19 13:15:10 UTC
hello. As and in this ticket https://bugs.freedesktop.org/show_bug.cgi?id=98013, I think, issue is not actual anymore
Comment 6 GitLab Migration User 2019-09-25 19:06:59 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1669.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.