Bug 104494 - Thin lines on graph are not rendered.
Summary: Thin lines on graph are not rendered.
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
Depends on:
Reported: 2018-01-04 18:02 UTC by Simon Shugar
Modified: 2018-08-20 21:59 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Pdf with Problem (73.75 KB, application/pdf)
2018-01-04 18:02 UTC, Simon Shugar
Expected - Lines show on graph. (29.06 KB, image/png)
2018-01-04 18:03 UTC, Simon Shugar
Actual - Lines don't show on graph. (44.22 KB, image/png)
2018-01-04 18:03 UTC, Simon Shugar

Description Simon Shugar 2018-01-04 18:02:59 UTC
Created attachment 136551 [details]
Pdf with Problem

The uploaded PDF "pdfwithproblem" doesn't render correctly when converted to an image. Only part of the line graph shows on the Poppler image. I am able to reproduce this in Adobe Acrobat X Pro but not able to reproduce it in other PDF readers (Chrome, Acrobat Reader). I can fix the issue in Adobe Acrobat X Pro by unticking "Smooth Line Art" using "Adobe Acrobat X > Edit > Preferences > Rendering > Un-tick > Smooth Line Art fixes" but of course this doesn't fix the Poppler image rendition. The issue is also in XPDF. 

pdftoppm version 0.51.0

1. Run "pdfwithproblem" through pdftoppm to create an image.
  - "pdftoppm-withlcms -cropbox -f 1 -l 1 -r 202 -png rendition.pdf pageImage"

Lines on graph render correctly. Please see EXPECTED_pdfwithproblem

Lines on graph not rendered. Please see ACTUAL_pdfwithproblem.
Comment 1 Simon Shugar 2018-01-04 18:03:33 UTC
Created attachment 136552 [details]
Expected - Lines show on graph.
Comment 2 Simon Shugar 2018-01-04 18:03:53 UTC
Created attachment 136553 [details]
Actual - Lines don't show on graph.
Comment 3 Simon Shugar 2018-01-04 18:05:42 UTC
Additional notes
- Tried to increase the resolution of the image produced. No fix.
- Tried thinlinemode. No fix. 
- Replicated the issue in XPDF.
Comment 4 Simon Shugar 2018-03-05 22:01:01 UTC
Is there any update on this?

p.s Please let me know if I am breaking etiquette by asking for an update.
Comment 5 GitLab Migration User 2018-08-20 21:59:18 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/143.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.